find a way HDU-2612

2024-04-20 05:08
文章标签 find hdu 2612 way

本文主要是介绍find a way HDU-2612,希望对大家解决编程问题提供一定的参考价值,需要的开发者们随着小编来一起学习吧!

Pass a year learning in Hangzhou, yifenfei arrival hometown Ningbo at finally. Leave Ningbo one year, yifenfei have many people to meet. Especially a good friend Merceki.
Yifenfei’s home is at the countryside, but Merceki’s home is in the center of city. So yifenfei made arrangements with Merceki to meet at a KFC. There are many KFC in Ningbo, they want to choose one that let the total time to it be most smallest.
Now give you a Ningbo map, Both yifenfei and Merceki can move up, down ,left, right to the adjacent road by cost 11 minutes.
Input
The input contains multiple test cases.
Each test case include, first two integers n, m. (2<=n,m<=200).
Next n lines, each line included m character.
‘Y’ express yifenfei initial position.
‘M’ express Merceki initial position.
‘#’ forbid road;
‘.’ Road.
‘@’ KCF
Output
For each test case output the minimum total time that both yifenfei and Merceki to arrival one of KFC.You may sure there is always have a KFC that can let them meet.
Sample Input
4 4
Y.#@

.#…
@…M
4 4
Y.#@

.#…
@#.M
5 5
Y…@.
.#…
.#…
@…M.
#…#
Sample Output
66
88
66
题意: 这道题是“Y”和“M”两个人决定在“@”地点集合,求两个人最少花费多少时间,每走一格花费11分钟。

思路: 这道题用到了广搜,即分别从“Y”和“M”进行搜索,记录两个人到达同一个“@”的时间,输出最短时间即可。

代码:

#include<stdio.h>
#include<string.h>
int n,m,p;
int d[4][2]= {{1,0},{-1,0},{0,1},{0,-1}};
int book[1010][1010];
char a[1010][1010];
int b[1010][1010];
int c[1010][1010];
struct node
{int x;int y;int step;
} s[10010];
void dfs(int x,int y)
{int tail=0,head=0,pp=0;s[tail].x=x;s[tail].y=y;s[tail].step=0;book[x][y]=1;tail++;while(head<tail){if(a[s[head].x][s[head].y]=='@'){pp++;b[s[head].x][s[head].y]+=s[head].step;c[s[head].x][s[head].y]++;}if(pp==p)break;for(int i=0; i<4; i++){int tx=s[head].x+d[i][0];int ty=s[head].y+d[i][1];if(tx<0||ty<0||tx>=n||ty>=m||book[tx][ty]||a[tx][ty]=='#')continue;book[tx][ty]=1;s[tail].x=tx;s[tail].y=ty;s[tail].step=s[head].step+1;tail++;}head++;}
}
int main()
{while(~scanf("%d%d",&n,&m)){int i,j;for(i=0; i<n; i++)scanf("%s",a[i]);p=0;for(i=0; i<n; i++)for(j=0; j<m; j++)if(a[i][j]=='@')p++;int x1,x2,y1,y2;for(i=0; i<n; i++){for(j=0; j<m; j++){if(a[i][j]=='Y'){x1=i;y1=j;}if(a[i][j]=='M'){x2=i;y2=j;}}}memset(c,0,sizeof(c));memset(b,0,sizeof(b));memset(book,0,sizeof(book));book[x1][y1]=1;dfs(x1,y1);//从“Y"搜索,记录”Y“到达每个”@“的时间memset(book,0,sizeof(book));book[x2][y2]=1;dfs(x2,y2);//从”M“搜索,记录”M“到达每个”@“的时间int sum,max=3421423;for(i=0; i<n; i++){for(j=0; j<m; j++){if(b[i][j]>0&&c[i][j]==2)//用b数组记录”Y“和”M“到达每个”@“的时间之和,c数组代表每个”@被搜到的次数,必须被搜到两次。{sum=b[i][j];if(sum<max)max=sum;}}}printf("%d\n",max*11);}return 0;
}

这篇关于find a way HDU-2612的文章就介绍到这儿,希望我们推荐的文章对编程师们有所帮助!



http://www.chinasem.cn/article/919340

相关文章

usaco 1.3 Mixing Milk (结构体排序 qsort) and hdu 2020(sort)

到了这题学会了结构体排序 于是回去修改了 1.2 milking cows 的算法~ 结构体排序核心: 1.结构体定义 struct Milk{int price;int milks;}milk[5000]; 2.自定义的比较函数,若返回值为正,qsort 函数判定a>b ;为负,a<b;为0,a==b; int milkcmp(const void *va,c

poj 3974 and hdu 3068 最长回文串的O(n)解法(Manacher算法)

求一段字符串中的最长回文串。 因为数据量比较大,用原来的O(n^2)会爆。 小白上的O(n^2)解法代码:TLE啦~ #include<stdio.h>#include<string.h>const int Maxn = 1000000;char s[Maxn];int main(){char e[] = {"END"};while(scanf("%s", s) != EO

hdu 2093 考试排名(sscanf)

模拟题。 直接从教程里拉解析。 因为表格里的数据格式不统一。有时候有"()",有时候又没有。而它也不会给我们提示。 这种情况下,就只能它它们统一看作字符串来处理了。现在就请出我们的主角sscanf()! sscanf 语法: #include int sscanf( const char *buffer, const char *format, ... ); 函数sscanf()和

hdu 2602 and poj 3624(01背包)

01背包的模板题。 hdu2602代码: #include<stdio.h>#include<string.h>const int MaxN = 1001;int max(int a, int b){return a > b ? a : b;}int w[MaxN];int v[MaxN];int dp[MaxN];int main(){int T;int N, V;s

hdu 1754 I Hate It(线段树,单点更新,区间最值)

题意是求一个线段中的最大数。 线段树的模板题,试用了一下交大的模板。效率有点略低。 代码: #include <stdio.h>#include <string.h>#define TREE_SIZE (1 << (20))//const int TREE_SIZE = 200000 + 10;int max(int a, int b){return a > b ? a :

hdu 1166 敌兵布阵(树状数组 or 线段树)

题意是求一个线段的和,在线段上可以进行加减的修改。 树状数组的模板题。 代码: #include <stdio.h>#include <string.h>const int maxn = 50000 + 1;int c[maxn];int n;int lowbit(int x){return x & -x;}void add(int x, int num){while

hdu 3790 (单源最短路dijkstra)

题意: 每条边都有长度d 和花费p,给你起点s 终点t,要求输出起点到终点的最短距离及其花费,如果最短距离有多条路线,则输出花费最少的。 解析: 考察对dijkstra的理解。 代码: #include <iostream>#include <cstdio>#include <cstdlib>#include <algorithm>#include <cstrin

hdu 2489 (dfs枚举 + prim)

题意: 对于一棵顶点和边都有权值的树,使用下面的等式来计算Ratio 给定一个n 个顶点的完全图及它所有顶点和边的权值,找到一个该图含有m 个顶点的子图,并且让这个子图的Ratio 值在所有m 个顶点的树中最小。 解析: 因为数据量不大,先用dfs枚举搭配出m个子节点,算出点和,然后套个prim算出边和,每次比较大小即可。 dfs没有写好,A的老泪纵横。 错在把index在d

hdu 1102 uva 10397(最小生成树prim)

hdu 1102: 题意: 给一个邻接矩阵,给一些村庄间已经修的路,问最小生成树。 解析: 把已经修的路的权值改为0,套个prim()。 注意prim 最外层循坏为n-1。 代码: #include <iostream>#include <cstdio>#include <cstdlib>#include <algorithm>#include <cstri

hdu 1285(拓扑排序)

题意: 给各个队间的胜负关系,让排名次,名词相同按从小到大排。 解析: 拓扑排序是应用于有向无回路图(Direct Acyclic Graph,简称DAG)上的一种排序方式,对一个有向无回路图进行拓扑排序后,所有的顶点形成一个序列,对所有边(u,v),满足u 在v 的前面。该序列说明了顶点表示的事件或状态发生的整体顺序。比较经典的是在工程活动上,某些工程完成后,另一些工程才能继续,此时