大连2016A - Wrestling Match HDU - 5971(二分图)

2024-04-16 02:32

本文主要是介绍大连2016A - Wrestling Match HDU - 5971(二分图),希望对大家解决编程问题提供一定的参考价值,需要的开发者们随着小编来一起学习吧!

Nowadays, at least one wrestling match is held every year in our country. There are a lot of people in the game is "good player”, the rest is "bad player”. Now, Xiao Ming is referee of the wrestling match and he has a list of the matches in his hand. At the same time, he knows some people are good players,some are bad players. He believes that every game is a battle between the good and the bad player. Now he wants to know whether all the people can be divided into “good player” and “bad player”.
Input
Input contains multiple sets of data.For each set of data,there are four numbers in the first line:N (1 ≤ N≤ 1000)、M(1 ≤M ≤ 10000)、X,Y(X+Y≤N ),in order to show the number of players(numbered 1toN ),the number of matches,the number of known “good players” and the number of known “bad players”.In the next M lines,Each line has two numbersa, b(a≠b) ,said there is a game between a and b .The next line has X different numbers.Each number is known as a “good player” number.The last line contains Y different numbers.Each number represents a known “bad player” number.Data guarantees there will not be a player number is a good player and also a bad player.
Output
If all the people can be divided into “good players” and "bad players”, output “YES”, otherwise output “NO”.
Sample Input
5 4 0 0
1 3
1 4
3 5
4 5
5 4 1 0
1 3
1 4
3 5
4 5
2
Sample Output
NO
YES

题意: 每个人是好运动员或者坏运动员,有n个人,其中有x+y个人的身份确定了。有m场比赛,每场比赛只能好运动员与坏运动员打。试问能否把所有人分成两堆,一堆好运动员,一堆坏运动员。

思路: 感觉题意不是很清楚,存在一个人身份不确定,也没有比过赛的情况怎么办呢?应该可以是任意一个身份,然后可以分在一堆里面的。但是本题不行,有这种情况就是no(样例1)

所以算法就是,二分图染色,对于初始有颜色的人,直接染本身的颜色。所有初始有颜色的人染完了以后,再去染没有颜色的人(随便染一个初始颜色就可以了)。染色中间出问题或者出现有人没有被染色,输出NO。

#include <iostream>
#include <cstdio>
#include <algorithm>
#include <queue>
#include <cmath>
#include <cstring>
#define ls rt << 1
#define rs rt << 1 | 1
using namespace std;
typedef long long ll;
const int MX = 2e6 + 7;
const int INF = 0x3f3f3f3f;
const int mod = 1e9 + 7;
const double pi = 3.1415926535;int head[20005],nex[20005],to[20005],tot,color[20005];
int flag;void add(int x,int y)
{to[++tot] = y;nex[tot] = head[x];head[x] = tot;
}void init(int m,int n)
{tot = 0;for(int i = 1;i <= max(n * 2,m * 2);i++){head[i] = nex[i] = 0;color[i] = 0;}
}void dfs(int x,int ccolor)
{if(flag == 0)return;for(int i = head[x];i;i = nex[i]){color[x] = ccolor;int v = to[i];if(color[v] == 0)dfs(v,3 - ccolor);else if(color[v] == ccolor){flag = 0;break;}}
}int main()
{int n,m,x,y;while(~scanf("%d%d%d%d",&n,&m,&x,&y)){init(n,m);flag = 1;for(int i = 1;i <= m;i++){int x,y;scanf("%d%d",&x,&y);add(x,y);add(y,x);}for(int i = 1;i <= x;i++){int tmp;scanf("%d",&tmp);color[tmp] = 1;}for(int i = 1;i <= y;i++){int tmp;scanf("%d",&tmp);color[tmp] = 2;}if(x == 0 && y == 0){for(int i = 1;i <= n;i++){if(color[i])continue;dfs(i,1);if(flag == 0)break;}}else{for(int i = 1;i <= n;i++){if(color[i])dfs(i,color[i]);if(flag == 0)break;}for(int i = 1;i <= n;i++){if(color[i])continue;dfs(i,1);if(flag == 0)break;}}for(int i = 1;i <= n;i++){if(color[i] == 0){flag = 0;break;}}if(flag == 0){printf("NO\n");}else printf("YES\n");}return 0;
}

这篇关于大连2016A - Wrestling Match HDU - 5971(二分图)的文章就介绍到这儿,希望我们推荐的文章对编程师们有所帮助!



http://www.chinasem.cn/article/907580

相关文章

hdu2241(二分+合并数组)

题意:判断是否存在a+b+c = x,a,b,c分别属于集合A,B,C 如果用暴力会超时,所以这里用到了数组合并,将b,c数组合并成d,d数组存的是b,c数组元素的和,然后对d数组进行二分就可以了 代码如下(附注释): #include<iostream>#include<algorithm>#include<cstring>#include<stack>#include<que

hdu2289(简单二分)

虽说是简单二分,但是我还是wa死了  题意:已知圆台的体积,求高度 首先要知道圆台体积怎么求:设上下底的半径分别为r1,r2,高为h,V = PI*(r1*r1+r1*r2+r2*r2)*h/3 然后以h进行二分 代码如下: #include<iostream>#include<algorithm>#include<cstring>#include<stack>#includ

usaco 1.3 Mixing Milk (结构体排序 qsort) and hdu 2020(sort)

到了这题学会了结构体排序 于是回去修改了 1.2 milking cows 的算法~ 结构体排序核心: 1.结构体定义 struct Milk{int price;int milks;}milk[5000]; 2.自定义的比较函数,若返回值为正,qsort 函数判定a>b ;为负,a<b;为0,a==b; int milkcmp(const void *va,c

poj 3974 and hdu 3068 最长回文串的O(n)解法(Manacher算法)

求一段字符串中的最长回文串。 因为数据量比较大,用原来的O(n^2)会爆。 小白上的O(n^2)解法代码:TLE啦~ #include<stdio.h>#include<string.h>const int Maxn = 1000000;char s[Maxn];int main(){char e[] = {"END"};while(scanf("%s", s) != EO

hdu 2093 考试排名(sscanf)

模拟题。 直接从教程里拉解析。 因为表格里的数据格式不统一。有时候有"()",有时候又没有。而它也不会给我们提示。 这种情况下,就只能它它们统一看作字符串来处理了。现在就请出我们的主角sscanf()! sscanf 语法: #include int sscanf( const char *buffer, const char *format, ... ); 函数sscanf()和

hdu 2602 and poj 3624(01背包)

01背包的模板题。 hdu2602代码: #include<stdio.h>#include<string.h>const int MaxN = 1001;int max(int a, int b){return a > b ? a : b;}int w[MaxN];int v[MaxN];int dp[MaxN];int main(){int T;int N, V;s

hdu 1754 I Hate It(线段树,单点更新,区间最值)

题意是求一个线段中的最大数。 线段树的模板题,试用了一下交大的模板。效率有点略低。 代码: #include <stdio.h>#include <string.h>#define TREE_SIZE (1 << (20))//const int TREE_SIZE = 200000 + 10;int max(int a, int b){return a > b ? a :

hdu 1166 敌兵布阵(树状数组 or 线段树)

题意是求一个线段的和,在线段上可以进行加减的修改。 树状数组的模板题。 代码: #include <stdio.h>#include <string.h>const int maxn = 50000 + 1;int c[maxn];int n;int lowbit(int x){return x & -x;}void add(int x, int num){while

hdu 3790 (单源最短路dijkstra)

题意: 每条边都有长度d 和花费p,给你起点s 终点t,要求输出起点到终点的最短距离及其花费,如果最短距离有多条路线,则输出花费最少的。 解析: 考察对dijkstra的理解。 代码: #include <iostream>#include <cstdio>#include <cstdlib>#include <algorithm>#include <cstrin

hdu 2489 (dfs枚举 + prim)

题意: 对于一棵顶点和边都有权值的树,使用下面的等式来计算Ratio 给定一个n 个顶点的完全图及它所有顶点和边的权值,找到一个该图含有m 个顶点的子图,并且让这个子图的Ratio 值在所有m 个顶点的树中最小。 解析: 因为数据量不大,先用dfs枚举搭配出m个子节点,算出点和,然后套个prim算出边和,每次比较大小即可。 dfs没有写好,A的老泪纵横。 错在把index在d