【PAT】1075. PAT Judge (25)【结构体的使用】

2024-04-12 06:18
文章标签 使用 25 结构 pat 1075 judge

本文主要是介绍【PAT】1075. PAT Judge (25)【结构体的使用】,希望对大家解决编程问题提供一定的参考价值,需要的开发者们随着小编来一起学习吧!

题目描述

The ranklist of PAT is generated from the status list, which shows the scores of the submittions. This time you are supposed to generate the ranklist for PAT.

翻译:PAT的排名是根据显示提交的得分情况的状态表进行排名的,这一次你需要得出PAT的排名表。

INPUT FORMAT

Each input file contains one test case. For each case, the first line contains 3 positive integers, N (<=104), the total number of users, K (<=5), the total number of problems, and M (<=105), the total number of submittions. It is then assumed that the user id’s are 5-digit numbers from 00001 to N, and the problem id’s are from 1 to K. The next line contains K positive integers p[i] (i=1, …, K), where p[i] corresponds to the full mark of the i-th problem. Then M lines follow, each gives the information of a submittion in the following format:

user_id problem_id partial_score_obtained

where partial_score_obtained is either -1 if the submittion cannot even pass the compiler, or is an integer in the range [0, p[problem_id]]. All the numbers in a line are separated by a space.

翻译:每个输入文件包含一组测试数据。对于每组输入数据,第一行包括3个正整数N(<=10^4),用户总数,K(<=5),题目总数,和M(<=10^5),提交总数。假设用户id是一个从00001到N的5位数字,问题的编号为从1到K。第二行包括K个正整数p[i] (i=1,…k),p[i]代表第i题的满分分数。接着M行,每行按照以下格式给出一个提交记录:
user_id problem_id partial_score_obtained
如果提交不能通过编译器,则 得分为-1,否则为一个[0,p[problem_id]]的整数。一行内所有数字之间用空格隔开。

OUTPUT FORMAT

For each test case, you are supposed to output the ranklist in the following format:

rank user_id total_score s[1] … s[K]

where rank is calculated according to the total_score, and all the users with the same total_score obtain the same rank; and s[i] is the partial score obtained for the i-th problem. If a user has never submitted a solution for a problem, then “-” must be printed at the corresponding position. If a user has submitted several solutions to solve one problem, then the highest score will be counted.

The ranklist must be printed in non-decreasing order of the ranks. For those who have the same rank, users must be sorted in nonincreasing order according to the number of perfectly solved problems. And if there is still a tie, then they must be printed in increasing order of their id’s. For those who has never submitted any solution that can pass the compiler, or has never submitted any solution, they must NOT be shown on the ranklist. It is guaranteed that at least one user can be shown on the ranklist.

翻译:对于每组测试数据,你需要按照以下格式输出:
rank user_id total_score s[1] … s[K]
rank根据总分排名,所有拥有相同分数的用户获得同样的排名;s[i]代表第i题的部分得分。如果用户有一题没有提交过结果,则需要在对应位置输出“-”。如果一个用户一道题提交了多次,则输出最高的分数。
排名表必须按照排名升序输出。对于那些排名相同的人,用户必须按照完美解决题目的个数进行降序排序。如果仍然相同,则他们必须根据他们的id号进行升序输出。对于那些提交过题目未通过编译或从未提交过题目的人,他们将不会在排名中显示。数据保证至少有一个用户可以被展示在排名表上。


Sample Input:

7 4 20
20 25 25 30
00002 2 12
00007 4 17
00005 1 19
00007 2 25
00005 1 20
00002 2 2
00005 1 15
00001 1 18
00004 3 25
00002 2 25
00005 3 22
00006 4 -1
00001 2 18
00002 1 20
00004 1 15
00002 4 18
00001 3 4
00001 4 2
00005 2 -1
00004 2 0

Sample Output:

1 00002 63 20 25 - 18
2 00005 42 20 0 22 -
2 00007 42 - 25 - 17
2 00001 42 18 18 4 2
5 00004 40 15 0 25 -


解题思路

模拟题目要求即可,只要有一道题得分>=0,就参与排名。根据总分->满分题目个数->ID号大小的方式排序。

#include<iostream>
#include<cstdio>
#include<cstring>
#include<cmath>
#include<string>
#include<vector>
#include<algorithm>
#define INF 99999999
using namespace std;
int N,K,M; 
int score[10];
struct Stu{int id,sum,sco[10],flag;Stu(){sum=0;for(int i=0;i<10;i++)sco[i]=-2;flag=0;}int getSum(){for(int i=1;i<=K;i++){if(sco[i]>0)sum+=sco[i];if(sco[i]>=0&&!flag)flag++;if(sco[i]==score[i])flag++;}return flag;}bool operator<(const Stu &a)const{return sum==a.sum?(flag==a.flag?id<a.id:flag>a.flag):sum>a.sum;}
};
Stu stu[10010];
vector<Stu> ans;
int main(){scanf("%d%d%d",&N,&K,&M);for(int i=1;i<=K;i++)scanf("%d",&score[i]);int Tid,Tnum,Tscore; for(int i=0;i<M;i++){scanf("%d%d%d",&Tid,&Tnum,&Tscore);stu[Tid].id=Tid;stu[Tid].sco[Tnum]=max(stu[Tid].sco[Tnum],Tscore);}for(int i=1;i<=N;i++){if(stu[i].getSum())ans.push_back(stu[i]);}sort(ans.begin(),ans.end());int Grade=0,Score=-1;for(int i=0;i<ans.size();i++){if(ans[i].sum!=Score)Grade=i+1,Score=ans[i].sum;printf("%d %05d %d",Grade,ans[i].id,ans[i].sum);for(int j=1;j<=K;j++){if(ans[i].sco[j]>0)printf(" %d",ans[i].sco[j]);else if(ans[i].sco[j]>=-1)printf(" 0",ans[i].sco[j]);else printf(" -");}printf("\n");}return 0;
}

这篇关于【PAT】1075. PAT Judge (25)【结构体的使用】的文章就介绍到这儿,希望我们推荐的文章对编程师们有所帮助!



http://www.chinasem.cn/article/896333

相关文章

vue使用docxtemplater导出word

《vue使用docxtemplater导出word》docxtemplater是一种邮件合并工具,以编程方式使用并处理条件、循环,并且可以扩展以插入任何内容,下面我们来看看如何使用docxtempl... 目录docxtemplatervue使用docxtemplater导出word安装常用语法 封装导出方

Linux换行符的使用方法详解

《Linux换行符的使用方法详解》本文介绍了Linux中常用的换行符LF及其在文件中的表示,展示了如何使用sed命令替换换行符,并列举了与换行符处理相关的Linux命令,通过代码讲解的非常详细,需要的... 目录简介检测文件中的换行符使用 cat -A 查看换行符使用 od -c 检查字符换行符格式转换将

使用Jackson进行JSON生成与解析的新手指南

《使用Jackson进行JSON生成与解析的新手指南》这篇文章主要为大家详细介绍了如何使用Jackson进行JSON生成与解析处理,文中的示例代码讲解详细,感兴趣的小伙伴可以跟随小编一起学习一下... 目录1. 核心依赖2. 基础用法2.1 对象转 jsON(序列化)2.2 JSON 转对象(反序列化)3.

使用Python实现快速搭建本地HTTP服务器

《使用Python实现快速搭建本地HTTP服务器》:本文主要介绍如何使用Python快速搭建本地HTTP服务器,轻松实现一键HTTP文件共享,同时结合二维码技术,让访问更简单,感兴趣的小伙伴可以了... 目录1. 概述2. 快速搭建 HTTP 文件共享服务2.1 核心思路2.2 代码实现2.3 代码解读3.

Elasticsearch 在 Java 中的使用教程

《Elasticsearch在Java中的使用教程》Elasticsearch是一个分布式搜索和分析引擎,基于ApacheLucene构建,能够实现实时数据的存储、搜索、和分析,它广泛应用于全文... 目录1. Elasticsearch 简介2. 环境准备2.1 安装 Elasticsearch2.2 J

使用C#代码在PDF文档中添加、删除和替换图片

《使用C#代码在PDF文档中添加、删除和替换图片》在当今数字化文档处理场景中,动态操作PDF文档中的图像已成为企业级应用开发的核心需求之一,本文将介绍如何在.NET平台使用C#代码在PDF文档中添加、... 目录引言用C#添加图片到PDF文档用C#删除PDF文档中的图片用C#替换PDF文档中的图片引言在当

Java中List的contains()方法的使用小结

《Java中List的contains()方法的使用小结》List的contains()方法用于检查列表中是否包含指定的元素,借助equals()方法进行判断,下面就来介绍Java中List的c... 目录详细展开1. 方法签名2. 工作原理3. 使用示例4. 注意事项总结结论:List 的 contain

C#使用SQLite进行大数据量高效处理的代码示例

《C#使用SQLite进行大数据量高效处理的代码示例》在软件开发中,高效处理大数据量是一个常见且具有挑战性的任务,SQLite因其零配置、嵌入式、跨平台的特性,成为许多开发者的首选数据库,本文将深入探... 目录前言准备工作数据实体核心技术批量插入:从乌龟到猎豹的蜕变分页查询:加载百万数据异步处理:拒绝界面

Android中Dialog的使用详解

《Android中Dialog的使用详解》Dialog(对话框)是Android中常用的UI组件,用于临时显示重要信息或获取用户输入,本文给大家介绍Android中Dialog的使用,感兴趣的朋友一起... 目录android中Dialog的使用详解1. 基本Dialog类型1.1 AlertDialog(

Python使用自带的base64库进行base64编码和解码

《Python使用自带的base64库进行base64编码和解码》在Python中,处理数据的编码和解码是数据传输和存储中非常普遍的需求,其中,Base64是一种常用的编码方案,本文我将详细介绍如何使... 目录引言使用python的base64库进行编码和解码编码函数解码函数Base64编码的应用场景注意