【PAT】1075. PAT Judge (25)【结构体的使用】

2024-04-12 06:18
文章标签 使用 25 结构 pat 1075 judge

本文主要是介绍【PAT】1075. PAT Judge (25)【结构体的使用】,希望对大家解决编程问题提供一定的参考价值,需要的开发者们随着小编来一起学习吧!

题目描述

The ranklist of PAT is generated from the status list, which shows the scores of the submittions. This time you are supposed to generate the ranklist for PAT.

翻译:PAT的排名是根据显示提交的得分情况的状态表进行排名的,这一次你需要得出PAT的排名表。

INPUT FORMAT

Each input file contains one test case. For each case, the first line contains 3 positive integers, N (<=104), the total number of users, K (<=5), the total number of problems, and M (<=105), the total number of submittions. It is then assumed that the user id’s are 5-digit numbers from 00001 to N, and the problem id’s are from 1 to K. The next line contains K positive integers p[i] (i=1, …, K), where p[i] corresponds to the full mark of the i-th problem. Then M lines follow, each gives the information of a submittion in the following format:

user_id problem_id partial_score_obtained

where partial_score_obtained is either -1 if the submittion cannot even pass the compiler, or is an integer in the range [0, p[problem_id]]. All the numbers in a line are separated by a space.

翻译:每个输入文件包含一组测试数据。对于每组输入数据,第一行包括3个正整数N(<=10^4),用户总数,K(<=5),题目总数,和M(<=10^5),提交总数。假设用户id是一个从00001到N的5位数字,问题的编号为从1到K。第二行包括K个正整数p[i] (i=1,…k),p[i]代表第i题的满分分数。接着M行,每行按照以下格式给出一个提交记录:
user_id problem_id partial_score_obtained
如果提交不能通过编译器,则 得分为-1,否则为一个[0,p[problem_id]]的整数。一行内所有数字之间用空格隔开。

OUTPUT FORMAT

For each test case, you are supposed to output the ranklist in the following format:

rank user_id total_score s[1] … s[K]

where rank is calculated according to the total_score, and all the users with the same total_score obtain the same rank; and s[i] is the partial score obtained for the i-th problem. If a user has never submitted a solution for a problem, then “-” must be printed at the corresponding position. If a user has submitted several solutions to solve one problem, then the highest score will be counted.

The ranklist must be printed in non-decreasing order of the ranks. For those who have the same rank, users must be sorted in nonincreasing order according to the number of perfectly solved problems. And if there is still a tie, then they must be printed in increasing order of their id’s. For those who has never submitted any solution that can pass the compiler, or has never submitted any solution, they must NOT be shown on the ranklist. It is guaranteed that at least one user can be shown on the ranklist.

翻译:对于每组测试数据,你需要按照以下格式输出:
rank user_id total_score s[1] … s[K]
rank根据总分排名,所有拥有相同分数的用户获得同样的排名;s[i]代表第i题的部分得分。如果用户有一题没有提交过结果,则需要在对应位置输出“-”。如果一个用户一道题提交了多次,则输出最高的分数。
排名表必须按照排名升序输出。对于那些排名相同的人,用户必须按照完美解决题目的个数进行降序排序。如果仍然相同,则他们必须根据他们的id号进行升序输出。对于那些提交过题目未通过编译或从未提交过题目的人,他们将不会在排名中显示。数据保证至少有一个用户可以被展示在排名表上。


Sample Input:

7 4 20
20 25 25 30
00002 2 12
00007 4 17
00005 1 19
00007 2 25
00005 1 20
00002 2 2
00005 1 15
00001 1 18
00004 3 25
00002 2 25
00005 3 22
00006 4 -1
00001 2 18
00002 1 20
00004 1 15
00002 4 18
00001 3 4
00001 4 2
00005 2 -1
00004 2 0

Sample Output:

1 00002 63 20 25 - 18
2 00005 42 20 0 22 -
2 00007 42 - 25 - 17
2 00001 42 18 18 4 2
5 00004 40 15 0 25 -


解题思路

模拟题目要求即可,只要有一道题得分>=0,就参与排名。根据总分->满分题目个数->ID号大小的方式排序。

#include<iostream>
#include<cstdio>
#include<cstring>
#include<cmath>
#include<string>
#include<vector>
#include<algorithm>
#define INF 99999999
using namespace std;
int N,K,M; 
int score[10];
struct Stu{int id,sum,sco[10],flag;Stu(){sum=0;for(int i=0;i<10;i++)sco[i]=-2;flag=0;}int getSum(){for(int i=1;i<=K;i++){if(sco[i]>0)sum+=sco[i];if(sco[i]>=0&&!flag)flag++;if(sco[i]==score[i])flag++;}return flag;}bool operator<(const Stu &a)const{return sum==a.sum?(flag==a.flag?id<a.id:flag>a.flag):sum>a.sum;}
};
Stu stu[10010];
vector<Stu> ans;
int main(){scanf("%d%d%d",&N,&K,&M);for(int i=1;i<=K;i++)scanf("%d",&score[i]);int Tid,Tnum,Tscore; for(int i=0;i<M;i++){scanf("%d%d%d",&Tid,&Tnum,&Tscore);stu[Tid].id=Tid;stu[Tid].sco[Tnum]=max(stu[Tid].sco[Tnum],Tscore);}for(int i=1;i<=N;i++){if(stu[i].getSum())ans.push_back(stu[i]);}sort(ans.begin(),ans.end());int Grade=0,Score=-1;for(int i=0;i<ans.size();i++){if(ans[i].sum!=Score)Grade=i+1,Score=ans[i].sum;printf("%d %05d %d",Grade,ans[i].id,ans[i].sum);for(int j=1;j<=K;j++){if(ans[i].sco[j]>0)printf(" %d",ans[i].sco[j]);else if(ans[i].sco[j]>=-1)printf(" 0",ans[i].sco[j]);else printf(" -");}printf("\n");}return 0;
}

这篇关于【PAT】1075. PAT Judge (25)【结构体的使用】的文章就介绍到这儿,希望我们推荐的文章对编程师们有所帮助!



http://www.chinasem.cn/article/896333

相关文章

使用Python和Pyecharts创建交互式地图

《使用Python和Pyecharts创建交互式地图》在数据可视化领域,创建交互式地图是一种强大的方式,可以使受众能够以引人入胜且信息丰富的方式探索地理数据,下面我们看看如何使用Python和Pyec... 目录简介Pyecharts 简介创建上海地图代码说明运行结果总结简介在数据可视化领域,创建交互式地

Java Stream流使用案例深入详解

《JavaStream流使用案例深入详解》:本文主要介绍JavaStream流使用案例详解,本文通过实例代码给大家介绍的非常详细,对大家的学习或工作具有一定的参考借鉴价值,需要的朋友参考下吧... 目录前言1. Lambda1.1 语法1.2 没参数只有一条语句或者多条语句1.3 一个参数只有一条语句或者多

Java Spring 中 @PostConstruct 注解使用原理及常见场景

《JavaSpring中@PostConstruct注解使用原理及常见场景》在JavaSpring中,@PostConstruct注解是一个非常实用的功能,它允许开发者在Spring容器完全初... 目录一、@PostConstruct 注解概述二、@PostConstruct 注解的基本使用2.1 基本代

C#使用StackExchange.Redis实现分布式锁的两种方式介绍

《C#使用StackExchange.Redis实现分布式锁的两种方式介绍》分布式锁在集群的架构中发挥着重要的作用,:本文主要介绍C#使用StackExchange.Redis实现分布式锁的... 目录自定义分布式锁获取锁释放锁自动续期StackExchange.Redis分布式锁获取锁释放锁自动续期分布式

springboot使用Scheduling实现动态增删启停定时任务教程

《springboot使用Scheduling实现动态增删启停定时任务教程》:本文主要介绍springboot使用Scheduling实现动态增删启停定时任务教程,具有很好的参考价值,希望对大家有... 目录1、配置定时任务需要的线程池2、创建ScheduledFuture的包装类3、注册定时任务,增加、删

使用Python实现矢量路径的压缩、解压与可视化

《使用Python实现矢量路径的压缩、解压与可视化》在图形设计和Web开发中,矢量路径数据的高效存储与传输至关重要,本文将通过一个Python示例,展示如何将复杂的矢量路径命令序列压缩为JSON格式,... 目录引言核心功能概述1. 路径命令解析2. 路径数据压缩3. 路径数据解压4. 可视化代码实现详解1

Pandas透视表(Pivot Table)的具体使用

《Pandas透视表(PivotTable)的具体使用》透视表用于在数据分析和处理过程中进行数据重塑和汇总,本文就来介绍一下Pandas透视表(PivotTable)的具体使用,感兴趣的可以了解一下... 目录前言什么是透视表?使用步骤1. 引入必要的库2. 读取数据3. 创建透视表4. 查看透视表总结前言

Python 交互式可视化的利器Bokeh的使用

《Python交互式可视化的利器Bokeh的使用》Bokeh是一个专注于Web端交互式数据可视化的Python库,本文主要介绍了Python交互式可视化的利器Bokeh的使用,具有一定的参考价值,感... 目录1. Bokeh 简介1.1 为什么选择 Bokeh1.2 安装与环境配置2. Bokeh 基础2

Android使用ImageView.ScaleType实现图片的缩放与裁剪功能

《Android使用ImageView.ScaleType实现图片的缩放与裁剪功能》ImageView是最常用的控件之一,它用于展示各种类型的图片,为了能够根据需求调整图片的显示效果,Android提... 目录什么是 ImageView.ScaleType?FIT_XYFIT_STARTFIT_CENTE

Java学习手册之Filter和Listener使用方法

《Java学习手册之Filter和Listener使用方法》:本文主要介绍Java学习手册之Filter和Listener使用方法的相关资料,Filter是一种拦截器,可以在请求到达Servl... 目录一、Filter(过滤器)1. Filter 的工作原理2. Filter 的配置与使用二、Listen