【PAT】1075. PAT Judge (25)【结构体的使用】

2024-04-12 06:18
文章标签 使用 25 结构 pat 1075 judge

本文主要是介绍【PAT】1075. PAT Judge (25)【结构体的使用】,希望对大家解决编程问题提供一定的参考价值,需要的开发者们随着小编来一起学习吧!

题目描述

The ranklist of PAT is generated from the status list, which shows the scores of the submittions. This time you are supposed to generate the ranklist for PAT.

翻译:PAT的排名是根据显示提交的得分情况的状态表进行排名的,这一次你需要得出PAT的排名表。

INPUT FORMAT

Each input file contains one test case. For each case, the first line contains 3 positive integers, N (<=104), the total number of users, K (<=5), the total number of problems, and M (<=105), the total number of submittions. It is then assumed that the user id’s are 5-digit numbers from 00001 to N, and the problem id’s are from 1 to K. The next line contains K positive integers p[i] (i=1, …, K), where p[i] corresponds to the full mark of the i-th problem. Then M lines follow, each gives the information of a submittion in the following format:

user_id problem_id partial_score_obtained

where partial_score_obtained is either -1 if the submittion cannot even pass the compiler, or is an integer in the range [0, p[problem_id]]. All the numbers in a line are separated by a space.

翻译:每个输入文件包含一组测试数据。对于每组输入数据,第一行包括3个正整数N(<=10^4),用户总数,K(<=5),题目总数,和M(<=10^5),提交总数。假设用户id是一个从00001到N的5位数字,问题的编号为从1到K。第二行包括K个正整数p[i] (i=1,…k),p[i]代表第i题的满分分数。接着M行,每行按照以下格式给出一个提交记录:
user_id problem_id partial_score_obtained
如果提交不能通过编译器,则 得分为-1,否则为一个[0,p[problem_id]]的整数。一行内所有数字之间用空格隔开。

OUTPUT FORMAT

For each test case, you are supposed to output the ranklist in the following format:

rank user_id total_score s[1] … s[K]

where rank is calculated according to the total_score, and all the users with the same total_score obtain the same rank; and s[i] is the partial score obtained for the i-th problem. If a user has never submitted a solution for a problem, then “-” must be printed at the corresponding position. If a user has submitted several solutions to solve one problem, then the highest score will be counted.

The ranklist must be printed in non-decreasing order of the ranks. For those who have the same rank, users must be sorted in nonincreasing order according to the number of perfectly solved problems. And if there is still a tie, then they must be printed in increasing order of their id’s. For those who has never submitted any solution that can pass the compiler, or has never submitted any solution, they must NOT be shown on the ranklist. It is guaranteed that at least one user can be shown on the ranklist.

翻译:对于每组测试数据,你需要按照以下格式输出:
rank user_id total_score s[1] … s[K]
rank根据总分排名,所有拥有相同分数的用户获得同样的排名;s[i]代表第i题的部分得分。如果用户有一题没有提交过结果,则需要在对应位置输出“-”。如果一个用户一道题提交了多次,则输出最高的分数。
排名表必须按照排名升序输出。对于那些排名相同的人,用户必须按照完美解决题目的个数进行降序排序。如果仍然相同,则他们必须根据他们的id号进行升序输出。对于那些提交过题目未通过编译或从未提交过题目的人,他们将不会在排名中显示。数据保证至少有一个用户可以被展示在排名表上。


Sample Input:

7 4 20
20 25 25 30
00002 2 12
00007 4 17
00005 1 19
00007 2 25
00005 1 20
00002 2 2
00005 1 15
00001 1 18
00004 3 25
00002 2 25
00005 3 22
00006 4 -1
00001 2 18
00002 1 20
00004 1 15
00002 4 18
00001 3 4
00001 4 2
00005 2 -1
00004 2 0

Sample Output:

1 00002 63 20 25 - 18
2 00005 42 20 0 22 -
2 00007 42 - 25 - 17
2 00001 42 18 18 4 2
5 00004 40 15 0 25 -


解题思路

模拟题目要求即可,只要有一道题得分>=0,就参与排名。根据总分->满分题目个数->ID号大小的方式排序。

#include<iostream>
#include<cstdio>
#include<cstring>
#include<cmath>
#include<string>
#include<vector>
#include<algorithm>
#define INF 99999999
using namespace std;
int N,K,M; 
int score[10];
struct Stu{int id,sum,sco[10],flag;Stu(){sum=0;for(int i=0;i<10;i++)sco[i]=-2;flag=0;}int getSum(){for(int i=1;i<=K;i++){if(sco[i]>0)sum+=sco[i];if(sco[i]>=0&&!flag)flag++;if(sco[i]==score[i])flag++;}return flag;}bool operator<(const Stu &a)const{return sum==a.sum?(flag==a.flag?id<a.id:flag>a.flag):sum>a.sum;}
};
Stu stu[10010];
vector<Stu> ans;
int main(){scanf("%d%d%d",&N,&K,&M);for(int i=1;i<=K;i++)scanf("%d",&score[i]);int Tid,Tnum,Tscore; for(int i=0;i<M;i++){scanf("%d%d%d",&Tid,&Tnum,&Tscore);stu[Tid].id=Tid;stu[Tid].sco[Tnum]=max(stu[Tid].sco[Tnum],Tscore);}for(int i=1;i<=N;i++){if(stu[i].getSum())ans.push_back(stu[i]);}sort(ans.begin(),ans.end());int Grade=0,Score=-1;for(int i=0;i<ans.size();i++){if(ans[i].sum!=Score)Grade=i+1,Score=ans[i].sum;printf("%d %05d %d",Grade,ans[i].id,ans[i].sum);for(int j=1;j<=K;j++){if(ans[i].sco[j]>0)printf(" %d",ans[i].sco[j]);else if(ans[i].sco[j]>=-1)printf(" 0",ans[i].sco[j]);else printf(" -");}printf("\n");}return 0;
}

这篇关于【PAT】1075. PAT Judge (25)【结构体的使用】的文章就介绍到这儿,希望我们推荐的文章对编程师们有所帮助!



http://www.chinasem.cn/article/896333

相关文章

中文分词jieba库的使用与实景应用(一)

知识星球:https://articles.zsxq.com/id_fxvgc803qmr2.html 目录 一.定义: 精确模式(默认模式): 全模式: 搜索引擎模式: paddle 模式(基于深度学习的分词模式): 二 自定义词典 三.文本解析   调整词出现的频率 四. 关键词提取 A. 基于TF-IDF算法的关键词提取 B. 基于TextRank算法的关键词提取

使用SecondaryNameNode恢复NameNode的数据

1)需求: NameNode进程挂了并且存储的数据也丢失了,如何恢复NameNode 此种方式恢复的数据可能存在小部分数据的丢失。 2)故障模拟 (1)kill -9 NameNode进程 [lytfly@hadoop102 current]$ kill -9 19886 (2)删除NameNode存储的数据(/opt/module/hadoop-3.1.4/data/tmp/dfs/na

Hadoop数据压缩使用介绍

一、压缩原则 (1)运算密集型的Job,少用压缩 (2)IO密集型的Job,多用压缩 二、压缩算法比较 三、压缩位置选择 四、压缩参数配置 1)为了支持多种压缩/解压缩算法,Hadoop引入了编码/解码器 2)要在Hadoop中启用压缩,可以配置如下参数

Makefile简明使用教程

文章目录 规则makefile文件的基本语法:加在命令前的特殊符号:.PHONY伪目标: Makefilev1 直观写法v2 加上中间过程v3 伪目标v4 变量 make 选项-f-n-C Make 是一种流行的构建工具,常用于将源代码转换成可执行文件或者其他形式的输出文件(如库文件、文档等)。Make 可以自动化地执行编译、链接等一系列操作。 规则 makefile文件

使用opencv优化图片(画面变清晰)

文章目录 需求影响照片清晰度的因素 实现降噪测试代码 锐化空间锐化Unsharp Masking频率域锐化对比测试 对比度增强常用算法对比测试 需求 对图像进行优化,使其看起来更清晰,同时保持尺寸不变,通常涉及到图像处理技术如锐化、降噪、对比度增强等 影响照片清晰度的因素 影响照片清晰度的因素有很多,主要可以从以下几个方面来分析 1. 拍摄设备 相机传感器:相机传

usaco 1.3 Mixing Milk (结构体排序 qsort) and hdu 2020(sort)

到了这题学会了结构体排序 于是回去修改了 1.2 milking cows 的算法~ 结构体排序核心: 1.结构体定义 struct Milk{int price;int milks;}milk[5000]; 2.自定义的比较函数,若返回值为正,qsort 函数判定a>b ;为负,a<b;为0,a==b; int milkcmp(const void *va,c

pdfmake生成pdf的使用

实际项目中有时会有根据填写的表单数据或者其他格式的数据,将数据自动填充到pdf文件中根据固定模板生成pdf文件的需求 文章目录 利用pdfmake生成pdf文件1.下载安装pdfmake第三方包2.封装生成pdf文件的共用配置3.生成pdf文件的文件模板内容4.调用方法生成pdf 利用pdfmake生成pdf文件 1.下载安装pdfmake第三方包 npm i pdfma

零基础学习Redis(10) -- zset类型命令使用

zset是有序集合,内部除了存储元素外,还会存储一个score,存储在zset中的元素会按照score的大小升序排列,不同元素的score可以重复,score相同的元素会按照元素的字典序排列。 1. zset常用命令 1.1 zadd  zadd key [NX | XX] [GT | LT]   [CH] [INCR] score member [score member ...]

git使用的说明总结

Git使用说明 下载安装(下载地址) macOS: Git - Downloading macOS Windows: Git - Downloading Windows Linux/Unix: Git (git-scm.com) 创建新仓库 本地创建新仓库:创建新文件夹,进入文件夹目录,执行指令 git init ,用以创建新的git 克隆仓库 执行指令用以创建一个本地仓库的

【北交大信息所AI-Max2】使用方法

BJTU信息所集群AI_MAX2使用方法 使用的前提是预约到相应的算力卡,拥有登录权限的账号密码,一般为导师组共用一个。 有浏览器、ssh工具就可以。 1.新建集群Terminal 浏览器登陆10.126.62.75 (如果是1集群把75改成66) 交互式开发 执行器选Terminal 密码随便设一个(需记住) 工作空间:私有数据、全部文件 加速器选GeForce_RTX_2080_Ti