OJ第六批——Problem O: 填空题:类模板---求数组的最大值

2024-04-10 02:08

本文主要是介绍OJ第六批——Problem O: 填空题:类模板---求数组的最大值,希望对大家解决编程问题提供一定的参考价值,需要的开发者们随着小编来一起学习吧!

问题及代码:

 

Problem O: 填空题:类模板---求数组的最大值

Time Limit: 1 Sec   Memory Limit: 128 MB
Submit: 414   Solved: 304
[ Submit][ Status][ Web Board]

Description

类模板---求数组的最大值
找出一个数组中的元素的最大值,数组大小为10。(用类模板来实现)
数组元素类型作为类模板的参数。
在下面的程序段基础上完成设计,只提交begin到end部分的代码
#include <iostream> 
#include <string> 
using namespace std; 
template <class T>   
class  Array_max         //声明类模板 
{
public:                   //以下3行为成员函数原型声明 
void set_value( );    //对数组元素设置值 
T  max_value( );    //找出数组中的最大元素 
private: 
T array[10];         //T类型数组 
T max;               //max用来存放数组中的最大值 
}; 
//将程序需要的其他成份写下来,只提交begin到end部分的代码
//******************** begin ********************
______(1)_______  
void Array_max<T>::set_value( ) 
{
int i;      
for (i=0; i<10; i++)  
______(2)_______; 
______(3)________  
T Array_max<T>::max_value( ) 
{  
int i; 
_____(4)________;  //此空可能需要多行才能实现要求的功能
return max;



//********************* end ********************
int main( ) 
{  
Array_max<int>   arrmax_int; //定义对象arrmax_int,该对象中数组元素类型为整型 
arrmax_int.set_value( );      //调用arrmax_int的set_value函数,向数组元素输入数值 
cout<<arrmax_int.max_value( )<<endl;  //调用arrmax_int的max_value函数,找出数组元素中的最大值 
Array_max<double>   arrmax_double; //定义对象arrmax_double,该对象中数组元素类型为双精度型 
arrmax_double.set_value( );      //调用arrmax_double的set_value函数,向数组元素输入数值 
cout<<arrmax_double.max_value( )<<endl;  //调用arrmax_double的max_value函数,找出数组元素中的最大值 
Array_max<char>   arrmax_char; //定义对象arrmax_char,该对象中数组元素类型为字符型
arrmax_char.set_value( );      //调用arrmax_char的set_value函数,向数组元素输入数值 
cout<<arrmax_char.max_value( )<<endl;  //调用arrmax_char的max_value函数,找出数组元素中的最大值   
Array_max<string>   arrmax_string; //定义对象arrmax_string,该对象中数组元素类型为字符串型
arrmax_string.set_value( );      //调用arrmax_string的set_value函数,向数组元素输入数值 
cout<<arrmax_string.max_value( )<<endl;  //调用arrmax_string,的max_value函数,找出数组元素中的最大值 
return 0; 

Input

10个int型数据

10个double型数据

10个char型数据

10gestring型数据

Output

10个int型数据的最大值

10个double型数据的最大值

10个char型数据的最大值

10个string型数据的最大值

Sample Input

1 3 5 7 9 8 6 4 2 0
1.2 3.4 5.66 7.8 9.9 13.4 -2.5 6.7 0 -10
a b 1 2 +  - A B p Z
guo li   zhao sun zhou zhang yang lan zhai wang 

Sample Output

9
13.4
p
zhou

HINT

 

#include <iostream>  
#include <string>  
using namespace std;  
template <class T>    
class  Array_max         //声明类模板  
{public:                   //以下3行为成员函数原型声明  
void set_value( );    //对数组元素设置值  
T  max_value( );    //找出数组中的最大元素  
private:  
T array[10];         //T类型数组  
T max;               //max用来存放数组中的最大值  
};  
template <class T> 
void Array_max<T>::set_value( ) 
{ 
int i; 
for (i=0; i<10; i++) 
cin>>array[i]; 
} 
template <class T> 
T Array_max<T>::max_value( ) 
{ 
int i; 
max=array[0]; 
for(i=1;i<10;i++)  //此空可能需要多行才能实现要求的功能 
{ 
if(max<=array[i+1]) 
max=array[i+1]; 
} 
return max; 
} 
int main( )  
{   
Array_max<int>   arrmax_int; //定义对象arrmax_int,该对象中数组元素类型为整型  
arrmax_int.set_value( );      //调用arrmax_int的set_value函数,向数组元素输入数值  
cout<<arrmax_int.max_value( )<<endl;  //调用arrmax_int的max_value函数,找出数组元素中的最大值  
Array_max<double>   arrmax_double; //定义对象arrmax_double,该对象中数组元素类型为双精度型  
arrmax_double.set_value( );      //调用arrmax_double的set_value函数,向数组元素输入数值  
cout<<arrmax_double.max_value( )<<endl;  //调用arrmax_double的max_value函数,找出数组元素中的最大值  
Array_max<char>   arrmax_char; //定义对象arrmax_char,该对象中数组元素类型为字符型 
arrmax_char.set_value( );      //调用arrmax_char的set_value函数,向数组元素输入数值  
cout<<arrmax_char.max_value( )<<endl;  //调用arrmax_char的max_value函数,找出数组元素中的最大值    
Array_max<string>   arrmax_string; //定义对象arrmax_string,该对象中数组元素类型为字符串型 
arrmax_string.set_value( );      //调用arrmax_string的set_value函数,向数组元素输入数值  
cout<<arrmax_string.max_value( )<<endl;  //调用arrmax_string,的max_value函数,找出数组元素中的最大值  
return 0;  
}  


 

这篇关于OJ第六批——Problem O: 填空题:类模板---求数组的最大值的文章就介绍到这儿,希望我们推荐的文章对编程师们有所帮助!



http://www.chinasem.cn/article/889809

相关文章

csu 1446 Problem J Modified LCS (扩展欧几里得算法的简单应用)

这是一道扩展欧几里得算法的简单应用题,这题是在湖南多校训练赛中队友ac的一道题,在比赛之后请教了队友,然后自己把它a掉 这也是自己独自做扩展欧几里得算法的题目 题意:把题意转变下就变成了:求d1*x - d2*y = f2 - f1的解,很明显用exgcd来解 下面介绍一下exgcd的一些知识点:求ax + by = c的解 一、首先求ax + by = gcd(a,b)的解 这个

hdu2241(二分+合并数组)

题意:判断是否存在a+b+c = x,a,b,c分别属于集合A,B,C 如果用暴力会超时,所以这里用到了数组合并,将b,c数组合并成d,d数组存的是b,c数组元素的和,然后对d数组进行二分就可以了 代码如下(附注释): #include<iostream>#include<algorithm>#include<cstring>#include<stack>#include<que

poj3468(线段树成段更新模板题)

题意:包括两个操作:1、将[a.b]上的数字加上v;2、查询区间[a,b]上的和 下面的介绍是下解题思路: 首先介绍  lazy-tag思想:用一个变量记录每一个线段树节点的变化值,当这部分线段的一致性被破坏我们就将这个变化值传递给子区间,大大增加了线段树的效率。 比如现在需要对[a,b]区间值进行加c操作,那么就从根节点[1,n]开始调用update函数进行操作,如果刚好执行到一个子节点,

C++11第三弹:lambda表达式 | 新的类功能 | 模板的可变参数

🌈个人主页: 南桥几晴秋 🌈C++专栏: 南桥谈C++ 🌈C语言专栏: C语言学习系列 🌈Linux学习专栏: 南桥谈Linux 🌈数据结构学习专栏: 数据结构杂谈 🌈数据库学习专栏: 南桥谈MySQL 🌈Qt学习专栏: 南桥谈Qt 🌈菜鸡代码练习: 练习随想记录 🌈git学习: 南桥谈Git 🌈🌈🌈🌈🌈🌈🌈🌈🌈🌈🌈🌈🌈�

poj 1258 Agri-Net(最小生成树模板代码)

感觉用这题来当模板更适合。 题意就是给你邻接矩阵求最小生成树啦。~ prim代码:效率很高。172k...0ms。 #include<stdio.h>#include<algorithm>using namespace std;const int MaxN = 101;const int INF = 0x3f3f3f3f;int g[MaxN][MaxN];int n

hdu 1166 敌兵布阵(树状数组 or 线段树)

题意是求一个线段的和,在线段上可以进行加减的修改。 树状数组的模板题。 代码: #include <stdio.h>#include <string.h>const int maxn = 50000 + 1;int c[maxn];int n;int lowbit(int x){return x & -x;}void add(int x, int num){while

uva 10025 The ? 1 ? 2 ? ... ? n = k problem(数学)

题意是    ?  1  ?  2  ?  ...  ?  n = k 式子中给k,? 处可以填 + 也可以填 - ,问最小满足条件的n。 e.g k = 12  - 1 + 2 + 3 + 4 + 5 + 6 - 7 = 12 with n = 7。 先给证明,令 S(n) = 1 + 2 + 3 + 4 + 5 + .... + n 暴搜n,搜出当 S(n) >=

uva 1342 欧拉定理(计算几何模板)

题意: 给几个点,把这几个点用直线连起来,求这些直线把平面分成了几个。 解析: 欧拉定理: 顶点数 + 面数 - 边数= 2。 代码: #include <iostream>#include <cstdio>#include <cstdlib>#include <algorithm>#include <cstring>#include <cmath>#inc

uva 11178 计算集合模板题

题意: 求三角形行三个角三等分点射线交出的内三角形坐标。 代码: #include <iostream>#include <cstdio>#include <cstdlib>#include <algorithm>#include <cstring>#include <cmath>#include <stack>#include <vector>#include <

poj 2104 and hdu 2665 划分树模板入门题

题意: 给一个数组n(1e5)个数,给一个范围(fr, to, k),求这个范围中第k大的数。 解析: 划分树入门。 bing神的模板。 坑爹的地方是把-l 看成了-1........ 一直re。 代码: poj 2104: #include <iostream>#include <cstdio>#include <cstdlib>#include <al