本文主要是介绍POJ 2251--Dungeon Master,希望对大家解决编程问题提供一定的参考价值,需要的开发者们随着小编来一起学习吧!
题目:
Dungeon Master
Time Limit: 1000MS | Memory Limit: 65536K | |
Total Submissions: 26827 | Accepted: 10493 |
Description
You are trapped in a 3D dungeon and need to find the quickest way out! The dungeon is composed of unit cubes which may or may not be filled with rock. It takes one minute to move one unit north, south, east, west, up or down. You cannot move diagonally and the maze is surrounded by solid rock on all sides.
Is an escape possible? If yes, how long will it take?
Is an escape possible? If yes, how long will it take?
Input
The input consists of a number of dungeons. Each dungeon description starts with a line containing three integers L, R and C (all limited to 30 in size).
L is the number of levels making up the dungeon.
R and C are the number of rows and columns making up the plan of each level.
Then there will follow L blocks of R lines each containing C characters. Each character describes one cell of the dungeon. A cell full of rock is indicated by a '#' and empty cells are represented by a '.'. Your starting position is indicated by 'S' and the exit by the letter 'E'. There's a single blank line after each level. Input is terminated by three zeroes for L, R and C.
L is the number of levels making up the dungeon.
R and C are the number of rows and columns making up the plan of each level.
Then there will follow L blocks of R lines each containing C characters. Each character describes one cell of the dungeon. A cell full of rock is indicated by a '#' and empty cells are represented by a '.'. Your starting position is indicated by 'S' and the exit by the letter 'E'. There's a single blank line after each level. Input is terminated by three zeroes for L, R and C.
Output
Each maze generates one line of output. If it is possible to reach the exit, print a line of the form
where x is replaced by the shortest time it takes to escape.
If it is not possible to escape, print the line
Escaped in x minute(s).
where x is replaced by the shortest time it takes to escape.
If it is not possible to escape, print the line
Trapped!
Sample Input
3 4 5 S.... .###. .##.. ###.###### ##### ##.## ##...##### ##### #.### ####E1 3 3 S## #E# ###0 0 0
Sample Output
Escaped in 11 minute(s). Trapped!
题意:一个三维的地图,从S走到E点,求最短路,否则输出Trapped!。
思路:一个裸的最短路,只是要注意走的方向,走六个方向,前后左后以及上下,方向弄好的就不会出错了。
实现:
#include <stdio.h>
#include <string.h>
#include <iostream>
#include <algorithm>
#include <queue>
#include <math.h>
using namespace std;const int MAX = 35;
const int INF = 100000000;
int l, r, c;char _map[MAX][MAX][MAX];
int visit[MAX][MAX][MAX];//到某一点的最短路int z[3] = {1, 0, -1};
int x[4] = {-1, 0, 1, 0};
int y[4] = {0, 1, 0, -1};struct node {int z, x, y;int step;bool friend operator < (node n1, node n2) {return n1.step > n2.step;}
};node s, e;
int ss;bool bfs() {priority_queue <node>q;q.push(s);visit[s.z][s.x][s.y] = true;while(!q.empty()) {node head, tail;head = q.top();q.pop();//cout << "ok " << head.z << " " << head.x << " " << head.y << endl;if (head.z == e.z && head.x == e.x && head.y == e.y) {ss = head.step;return true;}for (int i = 0; i < 3; i++) {for (int j = 0; j < 4; j++) {if (z[i] == 0) {tail.z = head.z + z[i];tail.x = head.x + x[j];tail.y = head.y + y[j];}else {tail.x = head.x;tail.y = head.y;tail.z = head.z + z[i];}if (tail.z >= 0 && tail.z < l && tail.x >= 0 && tail.x < r && tail.y >= 0&& tail.y < c && visit[tail.z][tail.x][tail.y] > head.step + 1) {visit[tail.z][tail.x][tail.y] = head.step + 1;tail.step = head.step + 1;q.push(tail);}}}}return false;
}int main() {while(scanf("%d%d%d", &l, &r, &c) != EOF) {if (l == 0 && r == 0 && c == 0)break;for (int i = 0; i < l; i++) {for (int j = 0; j < r; j++) {scanf("%s", _map[i][j]);}}for (int i = 0; i < l; i++) {for (int j = 0; j < r; j++) {for (int k = 0; k < c; k++) {visit[i][j][k] = INF;if (_map[i][j][k] == 'S') {s.z = i;s.x = j;s.y = k;}else if (_map[i][j][k] == 'E') {e.z = i;e.x = j;e.y = k;}else if (_map[i][j][k] == '#') {visit[i][j][k] = true;}}}}if (bfs()) {printf("Escaped in %d minute(s).\n", ss);}elseprintf("Trapped!\n");}return 0;
}
这篇关于POJ 2251--Dungeon Master的文章就介绍到这儿,希望我们推荐的文章对编程师们有所帮助!