HDU6230 Palindrome —— 马拉车+树状数组

2024-04-07 01:18

本文主要是介绍HDU6230 Palindrome —— 马拉车+树状数组,希望对大家解决编程问题提供一定的参考价值,需要的开发者们随着小编来一起学习吧!

Alice like strings, especially long strings. For each string, she has a special evaluation system to judge how elegant the string is. She defines that a string S1…3n−2 is one-and-half palindromic if and only if it satisfies S[i]=S[2n−i]=S2n+i−2.For example, abcbabc is one-and-half palindromic string, and abccbaabc is not. Now, Alice has generated some long strings. She ask for your help to find how many substrings which is one-and-half palindromic.
Input
The first line is the number of test cases. For each test case, there is only one line containing a string(the length of strings is less than or equal to 500000), this string only consists of lowercase letters.
Output
For each test case, output a integer donating the number of one-and-half palindromic substrings.
Sample Input
1
ababcbabccbaabc
Sample Output
2

Hint
In the example input, there are two substrings which are one-and-half palindromic strings, a b a b abab abab and a b c b a b c abcbabc abcbabc.
他这个好像是奇数的,不知道能不能用主席树做,感觉主席树好想一点,可以直接回到过去的状态,但是禁止主席树只能用树状数组了,这个数据结构我用的比较少,所以一直在想怎么才能回到过去的状态或者可以再这个区间内直接求有几个可以匹配,最后才知道是如果j的回文半径可以到i的话,在for到i的时候直接将所有可以达到i的pos都放进去,之后再与i~j-1的半径进行比较,如果可以的话就加上去
注意ans会超int

#include<bits/stdc++.h>
using namespace std;
#define maxn 1000050
#define ll long long 
char s[maxn];
char ss[2*maxn];
int p[2*maxn];
void manacher(char s[],int len)
{int i,j,len1;for(i=0;i<2*len+2;i++)ss[i]='#';for(i=0;i<len;i++)ss[i*2+2]=s[i];len1=len*2+1;ss[0]='$';int mx=0,id=0;int ans=0;for(int i=0;i<len1;i++){p[i]=mx>i?min(p[2*id-i],mx-i ):1;while(ss[i+p[i] ]==ss[i-p[i] ] )p[i]++;if(ans<p[i])ans=p[i];if(i+p[i]>mx){mx=i+p[i];id=i;}}
}
int sum[maxn];
int mlen;
int lowbit(int x)
{return x&(-x);
}
void add(int pos)
{for(int i=pos;i<=mlen;i+=lowbit(i))sum[i]++;
}
ll query(int pos)
{ll ans=0;for(int i=pos;i>=1;i-=lowbit(i))ans=(ll)ans+sum[i];return ans;
}
vector<int>vec[500005];
int len[500005];
int main()
{int t;scanf("%d",&t);while(t--){memset(sum,0,sizeof(sum));for(int i=0;i<500005;i++)vec[i].clear();scanf("%s",s);manacher(s,strlen(s));mlen=strlen(ss);ll ans=0;for(int i=2;i<mlen;i+=2){len[i/2]=(p[i]-2)/2;vec[i/2-len[i/2]].push_back(i/2);}mlen=strlen(s);for(int i=1;i<=mlen;i++){for(int j=0;j<vec[i].size();j++){add(vec[i][j]);}ans+=query(min(len[i]+i,mlen))-query(i);}printf("%lld\n",ans);}return 0;
}

这篇关于HDU6230 Palindrome —— 马拉车+树状数组的文章就介绍到这儿,希望我们推荐的文章对编程师们有所帮助!



http://www.chinasem.cn/article/881307

相关文章

hdu2241(二分+合并数组)

题意:判断是否存在a+b+c = x,a,b,c分别属于集合A,B,C 如果用暴力会超时,所以这里用到了数组合并,将b,c数组合并成d,d数组存的是b,c数组元素的和,然后对d数组进行二分就可以了 代码如下(附注释): #include<iostream>#include<algorithm>#include<cstring>#include<stack>#include<que

hdu 1166 敌兵布阵(树状数组 or 线段树)

题意是求一个线段的和,在线段上可以进行加减的修改。 树状数组的模板题。 代码: #include <stdio.h>#include <string.h>const int maxn = 50000 + 1;int c[maxn];int n;int lowbit(int x){return x & -x;}void add(int x, int num){while

ural 1297. Palindrome dp

1297. Palindrome Time limit: 1.0 second Memory limit: 64 MB The “U.S. Robots” HQ has just received a rather alarming anonymous letter. It states that the agent from the competing «Robots Unli

C语言:柔性数组

数组定义 柔性数组 err int arr[0] = {0}; // ERROR 柔性数组 // 常见struct Test{int len;char arr[1024];} // 柔性数组struct Test{int len;char arr[0];}struct Test *t;t = malloc(sizeof(Test) + 11);strcpy(t->arr,

C 语言基础之数组

文章目录 什么是数组数组变量的声明多维数组 什么是数组 数组,顾名思义,就是一组数。 假如班上有 30 个同学,让你编程统计每个人的分数,求最高分、最低分、平均分等。如果不知道数组,你只能这样写代码: int ZhangSan_score = 95;int LiSi_score = 90;......int LiuDong_score = 100;int Zhou

计算数组的斜率,偏移,R2

模拟Excel中的R2的计算。         public bool fnCheckRear_R2(List<double[]> lRear, int iMinRear, int iMaxRear, ref double dR2)         {             bool bResult = true;             int n = 0;             dou

C# double[] 和Matlab数组MWArray[]转换

C# double[] 转换成MWArray[], 直接赋值就行             MWNumericArray[] ma = new MWNumericArray[4];             double[] dT = new double[] { 0 };             double[] dT1 = new double[] { 0,2 };

PHP7扩展开发之数组处理

前言 这次,我们将演示如何在PHP扩展中如何对数组进行处理。要实现的PHP代码如下: <?phpfunction array_concat ($arr, $prefix) {foreach($arr as $key => $val) {if (isset($prefix[$key]) && is_string($val) && is_string($prefix[$key])) {$arr[

Go 数组赋值问题

package mainimport "fmt"type Student struct {Name stringAge int}func main() {data := make(map[string]*Student)list := []Student{{Name:"a",Age:1},{Name:"b",Age:2},{Name:"c",Age:3},}// 错误 都指向了最后一个v// a

码蹄集部分题目(2024OJ赛9.4-9.8;线段树+树状数组)

1🐋🐋配对最小值(王者;树状数组) 时间限制:1秒 占用内存:64M 🐟题目思路 MT3065 配对最小值_哔哩哔哩_bilibili 🐟代码 #include<bits/stdc++.h> using namespace std;const int N=1e5+7;int a[N],b[N],c[N],n,q;struct QUERY{int l,r,id;}que