本文主要是介绍TOJ 2380 Gopher II 二分图最大匹配,希望对大家解决编程问题提供一定的参考价值,需要的开发者们随着小编来一起学习吧!
描述
The gopher family, having averted the canine threat, must face a new predator.
The are n gophers and m gopher holes, each at distinct (x, y) coordinates. A hawk arrives and if a gopher does not reach a hole in s seconds it is vulnerable to being eaten. A hole can save at most one gopher. All the gophers run at the same velocity v. The gopher family needs an escape strategy that minimizes the number of vulnerable gophers.
输入
The input contains several cases. The first line of each case contains four positive integers less than 100: n, m, s, and v. The next n lines give the coordinates of the gophers; the following m lines give the coordinates of the gopher holes. All distances are in metres; all times are in seconds; all velocities are in metres per second.
输出
Output consists of a single line for each case, giving the number of vulnerable gophers.
样例输入
2 2 5 10
1.0 1.0
2.0 2.0
100.0 100.0
20.0 20.0
样例输出
1
这道题题意比较绕...说是有n只地鼠,m个洞,老鹰的到达地面的时间s,地鼠的移动速度v,求多少只地鼠会被老鹰吃了。这个建立二分图的话,要把地鼠和洞看成两个集合。然后只有当地鼠到洞的时间少于老鹰到地面的时间才连边。
#include<stdio.h>
#include<string.h>
#include<string>
#include<math.h>
#include<vector>
#include<queue>
#include<stack>
#include<map>
#include<iostream>
#include<algorithm>
using namespace std;
int n,m,ma[505][505],vis[505],dx[505];
struct point
{ double x,y;
}G[200],H[200];
double dis(point p1,point p2)
{//计算地鼠到洞的时间 return sqrt((p2.x-p1.x)*(p2.x-p1.x)+(p2.y-p1.y)*(p2.y-p1.y));
}
int find(int i)
{for(int j=n+1;j<=n+m;j++){if(ma[i][j]&&vis[j]==0){vis[j]=1;if(dx[j]==-1||find(dx[j])){dx[j]=i;return 1;}}}return 0;
}
int main()
{int t,i,j,s,v,x,y,sum; while(scanf("%d%d%d%d",&n,&m,&s,&v)!=EOF){if(t==0)break;memset(ma,0,sizeof ma);memset(vis,0,sizeof vis);memset(dx,-1,sizeof dx);for(i=1;i<=n;i++) scanf("%lf%lf",&G[i].x,&G[i].y); for(i=1;i<=m;i++)scanf("%lf%lf",&H[i].x,&H[i].y); for(i=1;i<=n;i++){ for(j=1;j<=m;j++){ double d=dis(G[i],H[j]); if(d/v<=(double)s)//比老鹰快才安全 ma[i][n+j]=1; } } sum=0;for(i=1;i<=n;i++){memset(vis,0,sizeof vis);sum+=find(i);}printf("%d\n",n-sum);}
}
这篇关于TOJ 2380 Gopher II 二分图最大匹配的文章就介绍到这儿,希望我们推荐的文章对编程师们有所帮助!