本文主要是介绍POJ2406 Power Strings 解题报告【字符串】【KMP】,希望对大家解决编程问题提供一定的参考价值,需要的开发者们随着小编来一起学习吧!
Description
Given two strings a and b we define a*b to be their concatenation. For example, if a = “abc” and b = “def” then a*b = “abcdef”. If we think of concatenation as multiplication, exponentiation by a non-negative integer is defined in the normal way: a^0 = “” (the empty string) and a^(n+1) = a*(a^n).
Input
Each test case is a line of input representing s, a string of printable characters. The length of s will be at least 1 and will not exceed 1 million characters. A line containing a period follows the last test case.
Output
For each s you should print the largest n such that s = a^n for some string a.
Sample Input
abcd
aaaa
ababab
.
Sample Output
1
4
3
Hint
This problem has huge input, use scanf instead of cin to avoid time limit exceed.
解题报告
这道题试问我们一个串有几个循环节。循环节就是指相等的(真)前缀和(真)后缀的个数。我们知道,kmp过程中的next[i]是这个意义:0-i-1位中相等的真前后缀个数。那么next[len]就是指0-len-1位中相等的真前后缀个数。显然我们就可以写出代码了:
#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
const int N=1000000;
char s[N+5];
int next[N+5],len;
void getnext()
{int i=0,j=-1;next[0]=-1;while(i<len){if(j==-1||s[i]==s[j]){i++;j++;next[i]=j;}else j=next[j];}
}
int main()
{while(true){ scanf("%s",s);if(s[0]=='.')break;memset(next,0,sizeof(next));len=strlen(s);getnext();if(len%(len-next[len])==0)printf("%d\n",len/(len-next[len]));else printf("1\n");}return 0;
}
这篇关于POJ2406 Power Strings 解题报告【字符串】【KMP】的文章就介绍到这儿,希望我们推荐的文章对编程师们有所帮助!