本文主要是介绍六、IBM Minus One,希望对大家解决编程问题提供一定的参考价值,需要的开发者们随着小编来一起学习吧!
Problem Description
You may have heard of the book ‘2001 - A Space Odyssey’ by Arthur C. Clarke, or the film of the same name by Stanley Kubrick. In it a spaceship is sent from Earth to Saturn. The crew is put into stasis for the long flight, only two men are awake, and the ship is controlled by the intelligent computer HAL. But during the flight HAL is acting more and more strangely, and even starts to kill the crew on board. We don’t tell you how the story ends, in case you want to read the book for yourself :-)
After the movie was released and became very popular, there was some discussion as to what the name ‘HAL’ actually meant. Some thought that it might be an abbreviation for ‘Heuristic ALgorithm’. But the most popular explanation is the following: if you replace every letter in the word HAL by its successor in the alphabet, you get … IBM.
Perhaps there are even more acronyms related in this strange way! You are to write a program that may help to find this out.
Input
The input starts with the integer n on a line by itself - this is the number of strings to follow. The following n lines each contain one string of at most 50 upper-case letters.
Output
For each string in the input, first output the number of the string, as shown in the sample output. The print the string start is derived from the input string by replacing every time by the following letter in the alphabet, and replacing ‘Z’ by ‘A’.
Print a blank line after each test case.
Sample Input
2
HAL
SWERC
Sample Output
String #1
IBM
String #2
TXFSD
#include<iostream>
#include<stdio.h>
using namespace std;
int main()
{int n,i,j=0,k;
char a[50];
cin>>n;
getchar();
while(j<n)
{i=0;while((a[i]=getchar())!='\n') {if(a[i]=='Z') a[i]='A';else a[i]=a[i]+1;i++;}
cout<<"String #"<<j+1<<endl;
for(k=0;k<i;k++)cout<<a[k];cout<<endl<<endl;j++;}return 0;}
这个题注意 最后输出也需要空一行;
这篇关于六、IBM Minus One的文章就介绍到这儿,希望我们推荐的文章对编程师们有所帮助!