HDU 5723 - Abandoned country

2024-02-27 00:48
文章标签 hdu country abandoned 5723

本文主要是介绍HDU 5723 - Abandoned country,希望对大家解决编程问题提供一定的参考价值,需要的开发者们随着小编来一起学习吧!

Problem Description


An abandoned country has n(n≤100000) villages which are numbered from 1 to n. Since abandoned for a long time, the roads need to be re-built. There are m(m≤1000000) roads to be re-built, the length of each road is wi(wi≤1000000). Guaranteed that any two wi are different. The roads made all the villages connected directly or indirectly before destroyed. Every road will cost the same value of its length to rebuild. The king wants to use the minimum cost to make all the villages connected with each other directly or indirectly. After the roads are re-built, the king asks a men as messenger. The king will select any two different points as starting point or the destination with the same probability. Now the king asks you to tell him the minimum cost and the minimum expectations length the messenger will walk.


Input
The first line contains an integer T(T≤10) which indicates the number of test cases.

For each test case, the first line contains two integers n,m indicate the number of villages and the number of roads to be re-built. Next m lines, each line have three number i,j,wi, the length of a road connecting the village i and the village j is wi.


Output
output the minimum cost and minimum Expectations with two decimal places. They separated by a space.


Sample Input
1
4 6
1 2 1
2 3 2
3 4 3
4 1 4
1 3 5
2 4 6


Sample Output
6 3.33

 

题意:在一个废弃了的国家里有 n 个点和 m 条路,给出每条路的起点、终点和权值(u, v, w),建立一棵最小生成树,求出最小生成树每条边的和的值,并且求出期望。

一开始并不知道什么是期望,上网查才知道。我们先定义在建立最小生成树过程中,遍历过这条路的次数称为这条路的数次【cnt】,而一条路的贡献就是 cnt * (n - cnt) * w。所有路的贡献和,暂且用 sum 表示,期望就是 (sum * 2)/(n * (n-1))

 

#include <cstdio>
#include <vector>
#include <algorithm>
using namespace std;struct node
{int u, v, w;
};
node e[2000000 + 5];
typedef pair<int, int> PAIR;
vector <PAIR> edge[100000 + 5];int n, m;
int father[100000 + 5];
double ans2;int cmp(node a, node b)
{return a.w < b.w;
}int Find(int x)
{if (father[x] == x)return x;return father[x] = Find(father[x]);
}void Union(int x, int y)
{int fx = Find(x);int fy = Find(y);if (fx != fy)father[fx] = fy;
}long long Kruskal()
{for (int i = 1; i <= n; ++i)father[i] = i;for (int i = 0; i <= n; ++i)edge[i].clear();sort(e, e+2*m, cmp);long long res = 0;for (int i = 0; i < 2*m; ++i){int u = e[i].u;int v = e[i].v;int w = e[i].w;int fu = Find(u);int fv = Find(v);if (fu != fv){Union(u, v);res += e[i].w;edge[u].push_back(PAIR(v, w));edge[v].push_back(PAIR(u, w));}}return res;
}int DFS(int u, int father)
{int cnt = 0;int len = edge[u].size();for (int i = 0; i < len; ++i){int v = edge[u][i].first;int w = edge[u][i].second;if (father != v){int temp = DFS(v, u);cnt += temp;ans2 = ans2 + 1.0 * temp * (n - temp) * w;}}return cnt + 1;
}int main()
{int T;scanf("%d", &T);while (T--){scanf("%d%d", &n, &m);for (int i = 0; i < m; ++i){scanf("%d %d %d", &e[i].u, &e[i].v, &e[i].w);e[m + i].u = e[i].v;e[m + i].v = e[i].u;e[m + i].w = e[i].w;}long long ans1 = Kruskal();ans2 = 0;DFS(1, -1);ans2 = ans2 * 2.0 / (1.0 * n) / (n - 1.0);printf("%I64d %.2f\n", ans1, ans2);}return 0;
}


 

这篇关于HDU 5723 - Abandoned country的文章就介绍到这儿,希望我们推荐的文章对编程师们有所帮助!



http://www.chinasem.cn/article/750699

相关文章

usaco 1.3 Mixing Milk (结构体排序 qsort) and hdu 2020(sort)

到了这题学会了结构体排序 于是回去修改了 1.2 milking cows 的算法~ 结构体排序核心: 1.结构体定义 struct Milk{int price;int milks;}milk[5000]; 2.自定义的比较函数,若返回值为正,qsort 函数判定a>b ;为负,a<b;为0,a==b; int milkcmp(const void *va,c

poj 3974 and hdu 3068 最长回文串的O(n)解法(Manacher算法)

求一段字符串中的最长回文串。 因为数据量比较大,用原来的O(n^2)会爆。 小白上的O(n^2)解法代码:TLE啦~ #include<stdio.h>#include<string.h>const int Maxn = 1000000;char s[Maxn];int main(){char e[] = {"END"};while(scanf("%s", s) != EO

hdu 2093 考试排名(sscanf)

模拟题。 直接从教程里拉解析。 因为表格里的数据格式不统一。有时候有"()",有时候又没有。而它也不会给我们提示。 这种情况下,就只能它它们统一看作字符串来处理了。现在就请出我们的主角sscanf()! sscanf 语法: #include int sscanf( const char *buffer, const char *format, ... ); 函数sscanf()和

hdu 2602 and poj 3624(01背包)

01背包的模板题。 hdu2602代码: #include<stdio.h>#include<string.h>const int MaxN = 1001;int max(int a, int b){return a > b ? a : b;}int w[MaxN];int v[MaxN];int dp[MaxN];int main(){int T;int N, V;s

hdu 1754 I Hate It(线段树,单点更新,区间最值)

题意是求一个线段中的最大数。 线段树的模板题,试用了一下交大的模板。效率有点略低。 代码: #include <stdio.h>#include <string.h>#define TREE_SIZE (1 << (20))//const int TREE_SIZE = 200000 + 10;int max(int a, int b){return a > b ? a :

hdu 1166 敌兵布阵(树状数组 or 线段树)

题意是求一个线段的和,在线段上可以进行加减的修改。 树状数组的模板题。 代码: #include <stdio.h>#include <string.h>const int maxn = 50000 + 1;int c[maxn];int n;int lowbit(int x){return x & -x;}void add(int x, int num){while

hdu 3790 (单源最短路dijkstra)

题意: 每条边都有长度d 和花费p,给你起点s 终点t,要求输出起点到终点的最短距离及其花费,如果最短距离有多条路线,则输出花费最少的。 解析: 考察对dijkstra的理解。 代码: #include <iostream>#include <cstdio>#include <cstdlib>#include <algorithm>#include <cstrin

hdu 2489 (dfs枚举 + prim)

题意: 对于一棵顶点和边都有权值的树,使用下面的等式来计算Ratio 给定一个n 个顶点的完全图及它所有顶点和边的权值,找到一个该图含有m 个顶点的子图,并且让这个子图的Ratio 值在所有m 个顶点的树中最小。 解析: 因为数据量不大,先用dfs枚举搭配出m个子节点,算出点和,然后套个prim算出边和,每次比较大小即可。 dfs没有写好,A的老泪纵横。 错在把index在d

hdu 1102 uva 10397(最小生成树prim)

hdu 1102: 题意: 给一个邻接矩阵,给一些村庄间已经修的路,问最小生成树。 解析: 把已经修的路的权值改为0,套个prim()。 注意prim 最外层循坏为n-1。 代码: #include <iostream>#include <cstdio>#include <cstdlib>#include <algorithm>#include <cstri

hdu 1285(拓扑排序)

题意: 给各个队间的胜负关系,让排名次,名词相同按从小到大排。 解析: 拓扑排序是应用于有向无回路图(Direct Acyclic Graph,简称DAG)上的一种排序方式,对一个有向无回路图进行拓扑排序后,所有的顶点形成一个序列,对所有边(u,v),满足u 在v 的前面。该序列说明了顶点表示的事件或状态发生的整体顺序。比较经典的是在工程活动上,某些工程完成后,另一些工程才能继续,此时