CF1003B Binary String Constructing

2024-02-19 14:32

本文主要是介绍CF1003B Binary String Constructing,希望对大家解决编程问题提供一定的参考价值,需要的开发者们随着小编来一起学习吧!

题目描述

You are given three integers a a a , b b b and x x x . Your task is to construct a binary string s s s of length n=a+b n = a + b n=a+b such that there are exactly a a a zeroes, exactly b b b ones and exactly x x x indices i i i (where 1≤i<n 1 \le i < n 1≤i<n ) such that si≠si+1 s_i \ne s_{i + 1} si​≠si+1​ . It is guaranteed that the answer always exists.

For example, for the string "01010" there are four indices i i i such that 1≤i<n 1 \le i < n 1≤i<n and si≠si+1 s_i \ne s_{i + 1} si​≠si+1​ ( i=1,2,3,4 i = 1, 2, 3, 4 i=1,2,3,4 ). For the string "111001" there are two such indices i i i ( i=3,5 i = 3, 5 i=3,5 ).

Recall that binary string is a non-empty sequence of characters where each character is either 0 or 1.

输入输出格式

输入格式:

 

The first line of the input contains three integers a a a , b b b and x x x ( 1≤a,b≤100,1≤x<a+b) 1 \le a, b \le 100, 1 \le x < a + b) 1≤a,b≤100,1≤x<a+b) .

 

输出格式:

 

Print only one string s s s , where s s s is any binary string satisfying conditions described above. It is guaranteed that the answer always exists.

 

输入输出样例

输入样例#1: 复制

2 2 1

输出样例#1: 复制

1100

输入样例#2: 复制

3 3 3

输出样例#2: 复制

101100

输入样例#3: 复制

5 3 6

输出样例#3: 复制

01010100

说明

All possible answers for the first example:

  • 1100;
  • 0011.

All possible answers for the second example:

  • 110100;
  • 101100;
  • 110010;
  • 100110;
  • 011001;
  • 001101;
  • 010011;
  • 001011.

思路:对于x,x/2对0和1(n对0和1交错出现可以提供2*n-1个符合题意的ai),然后将剩余的0和剩余的1连续输出(提供1个符合条件的ai)若X为偶数输出顺序与原来相同,否则相反,这样就刚好是x个符合条件的ai了,需要注意的是,我们要优先将个数多的放在前面,例如,有10个1,5个0的话,我们先输出x/2个“10”,否则,输出x/2个“01”)

   


#include "iostream"using namespace std;int main(){int a,b,x,n;char u,v;cin>>a>>b>>x;n=a+b;if(a>b) u='0',v='1';else {u='1',v='0';swap(a,b);}for(int i=0;i<x/2;i++) {cout<<u<<v;a--,b--;}if(x%2==0){while(b--) cout<<v;while(a--) cout<<u;}else{while(a--) cout<<u;while(b--) cout<<v;}return 0;}

 

 

以上代码非本人所写,

下面的代码存在错输暂存

#include<cstdio>
#include<cmath>
#include<algorithm>
#include<string>
#include<iostream>
using namespace std;
int a[2],x;
int main()
{string str="";scanf("%d%d%d",&a[0],&a[1],&x);if(x%2==0){if(a[0]<a[1]){while(a[1]--){a[0]--;str=str+"1";if(a[0]>=0)str=str+"0";}}else if(a[0]>=a[1]){while((a[0]--)>=0){a[1]--;if(a[0]==a[1]&&a[1]==0){str=str+"1";str=str+"0";break;}if(a[0]>=0)str=str+"0";if(a[1]>=0)str=str+"1";}}}else{if(a[0]<a[1]){while(a[0]--||a[1]--){str=str+"1";if(a[0]==1){str=str+"1";a[1]--;}if(a[0]>=0)str=str+"0";}}else if(a[0]>=a[1]){while((a[0]--)>=0){a[1]--;if(a[0]>0)str=str+"0";if(a[1]==1){str=str+"0";a[0]--;}if(a[1]>=0)str=str+"1";}}}cout<<str<<endl;return 0;
}

 

这篇关于CF1003B Binary String Constructing的文章就介绍到这儿,希望我们推荐的文章对编程师们有所帮助!



http://www.chinasem.cn/article/724971

相关文章

uva 575 Skew Binary(位运算)

求第一个以(2^(k+1)-1)为进制的数。 数据不大,可以直接搞。 代码: #include <stdio.h>#include <string.h>const int maxn = 100 + 5;int main(){char num[maxn];while (scanf("%s", num) == 1){if (num[0] == '0')break;int len =

string字符会调用new分配堆内存吗

gcc的string默认大小是32个字节,字符串小于等于15直接保存在栈上,超过之后才会使用new分配。

226 Invert Binary Tree

//226 Invert Binary Tree//算法思路:主要使用递归算法public class Solution {public TreeNode invertTree(TreeNode root) {//1 出口 空节点if (root==null)return null;//2 递归 调用自己TreeNode left = root.left;TreeNode right = ro

hdu2072(string的应用)

单词数 Time Limit: 1000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others) Total Submission(s): 25447    Accepted Submission(s): 5957 Problem Description lily的好朋友xiaoou333最近很空,他

【UVA】10739 - String to Palindrome(动态规划)

比较水的动态规划 dp[i][j] 将原串 i ~ j 之内的字符转化为回文字符所需要的最小操作次数 其中删除操作和添加操作本质上是一样的。 三个状态转移方程: dp[i][j] = min(dp[i][j] ,dp[i + 1][j]); dp[i][j] = min(dp[i][j] ,dp[i + 1][j - 1]); dp[i][j] = min(dp[i][j] ,dp[

理解String的compareTo()方法返回值

compareTo()的返回值是整型,它是先比较对应字符的大小(ASCII码顺序), 如果第一个字符和参数的第一个字符不等,结束比较,返回他们之间的差值。 如果第一个字符和参数的第一个字符相等,则以第二个字符和参数的第二个字符作比较, 以此类推,直至比较的字符或被比较的字符有一方全比较完,这时就比较字符的长度。 我们可以通过阅读源码加深对compareTo()的理解: comp

【JavaScript】基本数据类型与引用数据类型区别(及为什么String、Boolean、Number基本数据类型会有属性和方法?)

基本数据类型   JavaScript基本数据类型包括:undefined、null、number、boolean、string。基本数据类型是按值访问的,就是说我们可以操作保存在变量中的实际的值。 1)基本数据类型的值是不可变的 任何方法都无法改变一个基本类型的值,比如一个字符串: var name = "change";name.substr();//hangconsole.log

leetcode#541. Reverse String II

题目 Given a string and an integer k, you need to reverse the first k characters for every 2k characters counting from the start of the string. If there are less than k characters left, reverse all of

Java中Map取值转String Null值处理

Map<String, Object> 直接取值转String String value = (String)map.get("key") 当map.get(“key”)为Null值时会报错。 使用String类的valueOf静态方法可以解决这个问题 String value = String.valueOf(map.get("key"))