nyoj218 Dinner

2024-02-16 11:48
文章标签 nyoj218 dinner

本文主要是介绍nyoj218 Dinner,希望对大家解决编程问题提供一定的参考价值,需要的开发者们随着小编来一起学习吧!

Dinner

时间限制: 100 ms  |  内存限制: 65535 KB
难度: 1
描述
Little A is one member of ACM team. He had just won the gold in World Final. To celebrate, he decided to invite all to have one meal. As bowl, knife and other tableware is not enough in the kitchen, Little A goes to take backup tableware in warehouse. There are many boxes in warehouse, one box contains only one thing, and each box is marked by the name of things inside it. For example, if "basketball" is written on the box, which means the box contains only basketball. With these marks, Little A wants to find out the tableware easily. So, the problem for you is to help him, find out all the tableware from all boxes in the warehouse.
输入
There are many test cases. Each case contains one line, and one integer N at the first, N indicates that there are N boxes in the warehouse. Then N strings follow, each string is one name written on the box.
输出
For each test of the input, output all the name of tableware.
样例输入
3 basketball fork chopsticks
2 bowl letter
样例输出
fork chopsticks
bowl
 
代码:
 
#include<stdio.h>
#include<string.h>
int main()
{
	int i,n;
	char str[100][100];
	while(scanf("%d",&n)!=EOF)
	{
		for(i=0;i<n;i++)
		scanf("%s",str[i]);
		for(i=0;i<n;i++)
		{
			if(strcmp(str[i],"fork")==0)	printf("fork ");
			if(strcmp(str[i],"chopsticks")==0)	printf("chopsticks ");
			if(strcmp(str[i],"bowl")==0)	printf("bowl ");
			if(strcmp(str[i],"knife")==0)	printf("knife ");
		}
		printf("\n");
	}
	return 0;
}
 
//何来贪心???!!

这篇关于nyoj218 Dinner的文章就介绍到这儿,希望我们推荐的文章对编程师们有所帮助!



http://www.chinasem.cn/article/714443

相关文章

洛谷p2994题解 [USACO10OCT] Dinner Time S

题目描述 Farmer John's N (1 <= N <= 1,000) cows conveniently numbered 1..N are participating in the IOI in Bulgaria. The cows like the Bulgarian sun and are enjoying their holiday. All seems well. This

NYOJ 218题 Dinner

题目中竟然有提示,我没看到,苦苦想了这么多表示餐具的英文单词,而且还wa了。 不过,发现一个好玩的事情。输入的时候按照样例输入3 basketball fork chopsticks,然后程序输出fork chopsticks;如果把空格换成回车,那么,在输入fork时,立即输出fork,在输入chopsticks时,立即输出一个chopsticks。