本文主要是介绍北邮机试 | bupt oj | Python List 0273,希望对大家解决编程问题提供一定的参考价值,需要的开发者们随着小编来一起学习吧!
题目链接:
https://blog.csdn.net/TQCAI666/article/details/86767987?tdsourcetag=s_pctim_aiomsg#Problem_D_Python_List_399
题目描述
在Python中,List (列表)是一种非常重要的数据结构。它与C/C++/Java中的数组有些类似,但支持添加新元素时的动态扩展。在这个问题中,你需要处理如下的几种对List的操作。
L=[]: 将名字为L的List清空。在这里,List 的名字是长度为1到10之间
的字符串(只包括大小写字母)。如果L原来不存在,这个语句相当于定义了一个名字为L的空列表。
L.append(x):向L的末端插入元素x。为方便起见,这里的x只会是[0, 65536]之间的整数。
L.sort():将L中的元素按升序排序。
L[id]:返回L中下标为id(id≥0)的值。下标是从0开始计数的。
给定若干Python语句,你的任务是对于每个形如L[id]的语句,输出它返回的值。
输入格式
输入数据包含多组测试数据。请注意各组测试数据之间是相互独立的。输入的第一行是一个整数T(T≤100),表示测试数据的组数。
每组测试数据第一行是语句的数量N (N≤100)。接下来N行,每行一个python语句。测试数据保证只会出现上述四种语句,语句中间不会出现空格。一个List在被使用前一定会被先定义。
输出格式
对于每个查询,输出查找的L[id]的值。如果id超出了当前List 的下标范围,;输出一行ERROR。
样例输入
2
5
a=[]
a.append(0)
a.append(1)
a[0]
a[1]
8
lista=[]
lista.append(123)
lista.append(65)
lista[0]
lista.sort()
lista[0]
listb=[]
listb[0]
样例输出
0
1
123
65
ERROR
我的题解是看了大佬的答案后,自己照着思路写的
#include<bits/stdc++.h>
using namespace std;
map<string,vector<int> > nameList;
void init(string str){int pos = str.find("=");string name = str.substr(0,pos);nameList[name]=vector<int>();
}
void append(string str){int pos=str.find(".");int len=str.length();string name = str.substr(0,pos);//xx.append()string s = str.substr(pos+8,len-2-(pos+8)+1);int num;sscanf(s.c_str(),"%d",&num);nameList[name].push_back(num);
}
void _sort(string str){int pos = str.find(".");string name = str.substr(0,pos);sort(nameList[name].begin(),nameList[name].end());
}
void index(string str){int pos=str.find("[");string name = str.substr(0,pos);int len = str.length();if(nameList.count(name)){string s = str.substr(pos+1,len-2-(pos+1)+1);unsigned int idx;sscanf(s.c_str(),"%d",&idx);//vector<int> &v=nameList[name];if( idx>=0 && idx<nameList[name].size()){cout<<nameList[name][idx]<<endl;}else{cout<<"ERROR"<<endl;}}else{cout<<"ERROR"<<endl;}
}
int main(){int t,n;cin>>t;while(t--){cin>>n;while(n--){string str;cin>>str;if(str.find("=[]")!=string::npos){init(str);}else if(str.find(".append(")!=string::npos){append(str);}else if(str.find(".sort(")!=string::npos){_sort(str);}else{index(str);}}}return 0;
}
这篇关于北邮机试 | bupt oj | Python List 0273的文章就介绍到这儿,希望我们推荐的文章对编程师们有所帮助!