(POJ 1990)MooFest 树状数组 求一个数和他前面的所有数的值的差值之和

2024-02-05 02:18

本文主要是介绍(POJ 1990)MooFest 树状数组 求一个数和他前面的所有数的值的差值之和,希望对大家解决编程问题提供一定的参考价值,需要的开发者们随着小编来一起学习吧!

MooFest
Time Limit: 1000MS Memory Limit: 30000K
Total Submissions: 7716 Accepted: 3474
Description

Every year, Farmer John’s N (1 <= N <= 20,000) cows attend “MooFest”,a social gathering of cows from around the world. MooFest involves a variety of events including haybale stacking, fence jumping, pin the tail on the farmer, and of course, mooing. When the cows all stand in line for a particular event, they moo so loudly that the roar is practically deafening. After participating in this event year after year, some of the cows have in fact lost a bit of their hearing.

Each cow i has an associated “hearing” threshold v(i) (in the range 1..20,000). If a cow moos to cow i, she must use a volume of at least v(i) times the distance between the two cows in order to be heard by cow i. If two cows i and j wish to converse, they must speak at a volume level equal to the distance between them times max(v(i),v(j)).

Suppose each of the N cows is standing in a straight line (each cow at some unique x coordinate in the range 1..20,000), and every pair of cows is carrying on a conversation using the smallest possible volume.

Compute the sum of all the volumes produced by all N(N-1)/2 pairs of mooing cows.
Input

  • Line 1: A single integer, N

  • Lines 2..N+1: Two integers: the volume threshold and x coordinate for a cow. Line 2 represents the first cow; line 3 represents the second cow; and so on. No two cows will stand at the same location.
    Output

  • Line 1: A single line with a single integer that is the sum of all the volumes of the conversing cows.
    Sample Input

4
3 1
2 5
2 6
4 3
Sample Output

57
Source

USACO 2004 U S Open

题意:
有n只牛在数轴上排成一排,每只牛都在两个属性v,x
v表示说话的声音,x表示牛的位置
当两只牛i,j要进行交谈时,他们产生的声音是 dis(xi,xj)*max(vi,vj) : dis表示两个值的差的绝对值
问你要是任意两只牛进行交谈,他们总共产生的声音为多少?

分析:

由于两只牛说话的声音是max(vi,vj),所以我们可以按照v的升序来将牛排序,那么就可以保证当牛i和他前面的牛进行交谈时,是以vi来交谈的

我们现在只需要求出i和在他前面的所有的牛的位置的差值的总和就可以

我们将前面的牛分为两类:在前面且x比xi小的,和在前面x不小于xi的
我们假设
cnt为前面x比xi小的牛的个数
presume为前面x比xi小的牛的x的总和
total[i-1]表示前面i-1只牛的x的总和
那么i牛和在它前面且x比xi小的牛的差值的总和为 cnt * xi - presum
并且我们知道前面x不比xi小的牛的个数为 i-1 - cnt
i牛和在它前面且x不比xi小的牛的差值的总和为 total[i-1] - presum - (i-1 - cnt) * xi)
所以牛i产生的声音为 cnt * xi - presum + total[i-1] - presum - (i-1 - cnt) * xi) * vi

所以我们只需要用树状数组来维护 cnt 和 presume 即可

AC代码:

#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
#include <cmath>
using namespace std;const int maxn = 20010;
int c[maxn],d[maxn],total[maxn];
int n;struct Node
{int v,x;
}node[maxn];int lowbit(int x)
{return x & (-x);
}void update(int x)
{int t = x;while( x <= maxn){c[x]++;d[x] += t;x += lowbit(x);}
}int getsum_c(int x)
{int sum = 0;while(x > 0){sum += c[x];x -= lowbit(x);}return sum;
}int getsum_d(int x)
{int sum = 0;while(x >0){sum += d[x];x -= lowbit(x);}return sum;
}int cmp(Node a,Node b)
{return a.v < b.v;
}int main()
{scanf("%d",&n);memset(c,0,sizeof(c));memset(d,0,sizeof(d));memset(total,0,sizeof(total));for(int i=0;i<n;i++) scanf("%d%d",&node[i].v,&node[i].x);sort(node,node+n,cmp);long long ans = 0;for(int i=0;i<n;i++){if(i == 0){total[i] = node[i].x;update(node[i].x);}else{total[i] = total[i-1] + node[i].x;int cnt = getsum_c(node[i].x);int presum = getsum_d(node[i].x);ans += (1LL * node[i].v * (cnt * node[i].x - presum + total[i-1] - presum - (i - cnt) * node[i].x));update(node[i].x);}}printf("%lld",ans);return 0;
}

这篇关于(POJ 1990)MooFest 树状数组 求一个数和他前面的所有数的值的差值之和的文章就介绍到这儿,希望我们推荐的文章对编程师们有所帮助!



http://www.chinasem.cn/article/679485

相关文章

JAVA中整型数组、字符串数组、整型数和字符串 的创建与转换的方法

《JAVA中整型数组、字符串数组、整型数和字符串的创建与转换的方法》本文介绍了Java中字符串、字符数组和整型数组的创建方法,以及它们之间的转换方法,还详细讲解了字符串中的一些常用方法,如index... 目录一、字符串、字符数组和整型数组的创建1、字符串的创建方法1.1 通过引用字符数组来创建字符串1.2

vue如何监听对象或者数组某个属性的变化详解

《vue如何监听对象或者数组某个属性的变化详解》这篇文章主要给大家介绍了关于vue如何监听对象或者数组某个属性的变化,在Vue.js中可以通过watch监听属性变化并动态修改其他属性的值,watch通... 目录前言用watch监听深度监听使用计算属性watch和计算属性的区别在vue 3中使用watchE

hdu2241(二分+合并数组)

题意:判断是否存在a+b+c = x,a,b,c分别属于集合A,B,C 如果用暴力会超时,所以这里用到了数组合并,将b,c数组合并成d,d数组存的是b,c数组元素的和,然后对d数组进行二分就可以了 代码如下(附注释): #include<iostream>#include<algorithm>#include<cstring>#include<stack>#include<que

poj 3974 and hdu 3068 最长回文串的O(n)解法(Manacher算法)

求一段字符串中的最长回文串。 因为数据量比较大,用原来的O(n^2)会爆。 小白上的O(n^2)解法代码:TLE啦~ #include<stdio.h>#include<string.h>const int Maxn = 1000000;char s[Maxn];int main(){char e[] = {"END"};while(scanf("%s", s) != EO

hdu 2602 and poj 3624(01背包)

01背包的模板题。 hdu2602代码: #include<stdio.h>#include<string.h>const int MaxN = 1001;int max(int a, int b){return a > b ? a : b;}int w[MaxN];int v[MaxN];int dp[MaxN];int main(){int T;int N, V;s

poj 1511 Invitation Cards(spfa最短路)

题意是给你点与点之间的距离,求来回到点1的最短路中的边权和。 因为边很大,不能用原来的dijkstra什么的,所以用spfa来做。并且注意要用long long int 来存储。 稍微改了一下学长的模板。 stack stl 实现代码: #include<stdio.h>#include<stack>using namespace std;const int M

poj 3259 uva 558 Wormholes(bellman最短路负权回路判断)

poj 3259: 题意:John的农场里n块地,m条路连接两块地,w个虫洞,虫洞是一条单向路,不但会把你传送到目的地,而且时间会倒退Ts。 任务是求你会不会在从某块地出发后又回来,看到了离开之前的自己。 判断树中是否存在负权回路就ok了。 bellman代码: #include<stdio.h>const int MaxN = 501;//农场数const int

poj 1258 Agri-Net(最小生成树模板代码)

感觉用这题来当模板更适合。 题意就是给你邻接矩阵求最小生成树啦。~ prim代码:效率很高。172k...0ms。 #include<stdio.h>#include<algorithm>using namespace std;const int MaxN = 101;const int INF = 0x3f3f3f3f;int g[MaxN][MaxN];int n

poj 1287 Networking(prim or kruscal最小生成树)

题意给你点与点间距离,求最小生成树。 注意点是,两点之间可能有不同的路,输入的时候选择最小的,和之前有道最短路WA的题目类似。 prim代码: #include<stdio.h>const int MaxN = 51;const int INF = 0x3f3f3f3f;int g[MaxN][MaxN];int P;int prim(){bool vis[MaxN];

poj 2349 Arctic Network uva 10369(prim or kruscal最小生成树)

题目很麻烦,因为不熟悉最小生成树的算法调试了好久。 感觉网上的题目解释都没说得很清楚,不适合新手。自己写一个。 题意:给你点的坐标,然后两点间可以有两种方式来通信:第一种是卫星通信,第二种是无线电通信。 卫星通信:任何两个有卫星频道的点间都可以直接建立连接,与点间的距离无关; 无线电通信:两个点之间的距离不能超过D,无线电收发器的功率越大,D越大,越昂贵。 计算无线电收发器D