本文主要是介绍【HDU5747 BestCoder Round 84A】【贪心 细节】Aaronson m范围最少数量2的幂凑成n,希望对大家解决编程问题提供一定的参考价值,需要的开发者们随着小编来一起学习吧!
Aaronson
Accepts: 607
Submissions: 1869
Time Limit: 4000/2000 MS (Java/Others)
Memory Limit: 131072/131072 K (Java/Others)
问题描述
给出一个不定方程x0+2x1+4x2+...+2mxm=n, 找出一组解(x0,x1,x2,...,xm), 使得i=0∑mxi最小, 并且每个xi (0≤i≤m)都是非负的.
输入描述
输入包含多组数据, 第一行包含一个整数T (1≤T≤105)表示测试数据组数. 对于每组数据:第一行包含两个整数n和m (0≤n,m≤109).
输出描述
对于每组数据, 输出i=0∑mxi的最小值.
输入样例
10 1 2 3 2 5 2 10 2 10 3 10 4 13 5 20 4 11 11 12 3
输出样例
1 2 2 3 2 2 3 2 3 2
#include<stdio.h>
#include<iostream>
#include<string.h>
#include<string>
#include<ctype.h>
#include<math.h>
#include<set>
#include<map>
#include<vector>
#include<queue>
#include<bitset>
#include<algorithm>
#include<time.h>
using namespace std;
void fre() { freopen("c://test//input.in", "r", stdin); freopen("c://test//output.out", "w", stdout); }
#define MS(x,y) memset(x,y,sizeof(x))
#define MC(x,y) memcpy(x,y,sizeof(x))
#define MP(x,y) make_pair(x,y)
#define ls o<<1
#define rs o<<1|1
typedef long long LL;
typedef unsigned long long UL;
typedef unsigned int UI;
template <class T1, class T2>inline void gmax(T1 &a, T2 b) { if (b>a)a = b; }
template <class T1, class T2>inline void gmin(T1 &a, T2 b) { if (b<a)a = b; }
const int N = 0, M = 0, Z = 1e9 + 7, ms63 = 0x3f3f3f3f;
int casenum, casei;
int n, m;
int b[30];
int main()
{for (int i = 0; i < 30; ++i)b[i] = 1 << i;scanf("%d", &casenum);for (casei = 1; casei <= casenum; ++casei){scanf("%d%d", &n, &m);gmin(m, 29);int ans = 0;for (int i = 0; i <= m; ++i)if (n&b[i]){++ans;n ^= b[i];}ans += n / b[m];printf("%d\n", ans);}return 0;
}
/*
【trick&&吐槽】
m的范围如此之大,细节一定别写错了>.<【题意】
给出方程——
x[0]*(2^0)+x[1]*(2^1)+...x[m]*(2^m)==n
我们希望找到一组{x[0],x[1],...,x[m]}
使得{x[]}非负,且∑{x[0]+x[1]+...+x[m]}尽可能小,并输出这个和【类型】
贪心 细节【分析】
对于这道题目。
显然如果m够大,我们直接按照二进制位上的1做划分即可。
如果m不够大,我们用最大的2的幂次(即2^m)做划分。【时间复杂度&&优化】
O(log(n))*/
这篇关于【HDU5747 BestCoder Round 84A】【贪心 细节】Aaronson m范围最少数量2的幂凑成n的文章就介绍到这儿,希望我们推荐的文章对编程师们有所帮助!