本文主要是介绍codeup-How Many Tables,希望对大家解决编程问题提供一定的参考价值,需要的开发者们随着小编来一起学习吧!
题目描述
Today is Ignatius' birthday. He invites a lot of friends. Now it's dinner time. Ignatius wants to know how many tables he needs at least. You have to notice that not all the friends know each other, and all the friends do not want to stay with strangers.
One important rule for this problem is that if I tell you A knows B, and B knows C, that means A, B, C know each other, so they can stay in one table.
For example: If I tell you A knows B, B knows C, and D knows E, so A, B, C can stay in one table, and D, E have to stay in the other one. So Ignatius needs 2 tables at least.
输入
The input starts with an integer T(1<=T<=25) which indicate the number of test cases. Then T test cases follow. Each test case starts with two integers N and M(1<=N,M<=1000). N indicates the number of friends, the friends are marked from 1 to N. Then M lines follow. Each line consists of two integers A and B(A!=B), that means friend A and friend B know each other. There will be a blank line between two cases.
输出
For each test case, just output how many tables Ignatius needs at least. Do NOT print any blanks.
样例输入
2
6 4
1 2
2 3
3 4
1 4
8 10
1 2
2 3
5 6
7 5
4 6
3 6
6 7
2 5
2 4
4 3
样例输出
3
2
#include<cstdio>
int find(int x);
void pre(int x);
void Union(int a,int b);
int pn[1010];
bool isRoot[1010];
int main()
{int n,m,i,j,t;int a,b;scanf("%d",&t);for(j=0;j<t;j++){int cnt;cnt=0;scanf("%d%d",&n,&m);pre(n);for(i=1;i<=m;i++){scanf("%d%d",&a,&b);Union(a,b);} for(i=1;i<=n;i++){isRoot[find(i)]=true;}for(i=1;i<=n;i++){if(isRoot[i]==true)cnt++;} printf("%d\n",cnt); }return 0;
}
void pre(int x)
{int i;for(i=1;i<=x;i++){pn[i]=i;isRoot[i]=false;}
}
int find(int x)
{int r,z;r=x;while(r!=pn[r]){r=pn[r];}while(x!=pn[x]){z=x;x=pn[x];pn[z]=r;}return r;
}
void Union(int a,int b)
{int fa,fb;fa=find(a);fb=find(b);if(fa!=fb){pn[fb]=fa;}
}
这篇关于codeup-How Many Tables的文章就介绍到这儿,希望我们推荐的文章对编程师们有所帮助!