codeup-How Many Tables

2024-01-13 20:08
文章标签 many codeup tables

本文主要是介绍codeup-How Many Tables,希望对大家解决编程问题提供一定的参考价值,需要的开发者们随着小编来一起学习吧!

题目描述

Today is Ignatius' birthday. He invites a lot of friends. Now it's dinner time. Ignatius wants to know how many tables he needs at least. You have to notice that not all the friends know each other, and all the friends do not want to stay with strangers.

One important rule for this problem is that if I tell you A knows B, and B knows C, that means A, B, C know each other, so they can stay in one table.

For example: If I tell you A knows B, B knows C, and D knows E, so A, B, C can stay in one table, and D, E have to stay in the other one. So Ignatius needs 2 tables at least.

输入

The input starts with an integer T(1<=T<=25) which indicate the number of test cases. Then T test cases follow. Each test case starts with two integers N and M(1<=N,M<=1000). N indicates the number of friends, the friends are marked from 1 to N. Then M lines follow. Each line consists of two integers A and B(A!=B), that means friend A and friend B know each other. There will be a blank line between two cases.

输出

For each test case, just output how many tables Ignatius needs at least. Do NOT print any blanks.

样例输入

2
6 4
1 2
2 3
3 4
1 4
8 10
1 2
2 3
5 6
7 5
4 6
3 6
6 7
2 5
2 4
4 3

样例输出

3
2
#include<cstdio>
int find(int x);
void pre(int x);
void Union(int a,int b);
int pn[1010];
bool isRoot[1010];
int main() 
{int n,m,i,j,t;int a,b;scanf("%d",&t);for(j=0;j<t;j++){int cnt;cnt=0;scanf("%d%d",&n,&m);pre(n);for(i=1;i<=m;i++){scanf("%d%d",&a,&b);Union(a,b);}	for(i=1;i<=n;i++){isRoot[find(i)]=true;}for(i=1;i<=n;i++){if(isRoot[i]==true)cnt++;}	printf("%d\n",cnt);	}return 0;
}
void pre(int x)
{int i;for(i=1;i<=x;i++){pn[i]=i;isRoot[i]=false;}		
}
int find(int x)
{int r,z;r=x;while(r!=pn[r]){r=pn[r];}while(x!=pn[x]){z=x;x=pn[x];pn[z]=r;}return r;
}
void Union(int a,int b)
{int fa,fb;fa=find(a);fb=find(b);if(fa!=fb){pn[fb]=fa;}
}



这篇关于codeup-How Many Tables的文章就介绍到这儿,希望我们推荐的文章对编程师们有所帮助!



http://www.chinasem.cn/article/602637

相关文章

uva 10061 How many zero's and how many digits ?(不同进制阶乘末尾几个0)+poj 1401

题意是求在base进制下的 n!的结果有几位数,末尾有几个0。 想起刚开始的时候做的一道10进制下的n阶乘末尾有几个零,以及之前有做过的一道n阶乘的位数。 当时都是在10进制下的。 10进制下的做法是: 1. n阶位数:直接 lg(n!)就是得数的位数。 2. n阶末尾0的个数:由于2 * 5 将会在得数中以0的形式存在,所以计算2或者计算5,由于因子中出现5必然出现2,所以直接一

【HDU】How Many Answers Are Wrong(带权并查集)

num[i]代表i到根节点的值 这道题一开始竟然以为是线段树= =!后来发现线段树无法进行子区间的维护 #include<cstdio>#include<cstring>#include<algorithm>using namespace std;const int maxn = 222222;int fa[maxn],num[maxn];int find_father(int

【0323】Postgres内核之 hash table sequentially search(seq_scan_tables、num_seq_scans)

0. seq scan tracking 我们在这里跟踪活跃的 hash_seq_search() 扫描。 需要这种机制是因为如果扫描正在进行时发生桶分裂(bucket split),它可能会访问两次相同的条目,甚至完全错过某些条目(如果它正在访问同一个分裂的桶中的条目)。因此,如果正在向表中插入数据,我们希望抑制桶分裂。 在当前的使用中,这种情况非常罕见,因此只需将分裂推迟到下一次插入即可。

kubernetes Pod failed to create fsnotify watcher: too many open files

fs.nr_open: 控制单个进程可以打开的文件描述符的最大数量。单个进程的文件描述符限制可以通过 ulimit 命令来设置。 /proc/sys/fs/nr_open 是一个系统级别的全局参数,表示系统中单个进程能够打开的文件描述符总数的限制。/proc/sys/fs/file-max 系统级别,当前系统可打开的最大数量/etc/security/limits.conf 用户级别,指定用户

for 出错 ValueError: too many values to unpack (expected 2) 遍历多个变量

贼简单的代码示例 for [i,j] in [range(3),range(3)]:print(i,j) 输出: ValueError: too many values to unpack (expected 2) 正确示例 for i,j in zip(range(3),range(3)):print(i,j) 输出: 0 0 1 1 2 2 原因:后面zip()包装了两个lis

Host '10.10.120.174' is blocked beacuse of many connection errors;

Host '10.10.120.174' is blocked beacuse of many connection errors;unblock with 'mysqldamin flush-hosts' #使用清楚缓存的方法,这样就会把计数清理掉,进入mysql控制台,执行:flush hosts; /usr/bin/mysqladmin  -u jiaobo -puukkgg  flus

nginx 出错:socket() failed (24: Too many open files) while connecting to upstream

1. 错误描述 通过nginx负载两个节点的rabbitmq 当用java代码创建超过500个连接时(我的机器默认只能创建这么多),出现错误: com.rabbitmq.client.ShutdownSignalException: connection errorjava.net.SocketException: Software caused connection abort: recv

DBA_TABLES ALL_TABLES USER_TABLES

DBA_TABLES ALL_TABLES USER_TABLES DBA_TABLES >= ALL_TABLES >= USER_TABLES DBA_TABLES意为DBA拥有的或可以访问的所有的关系表。 ALL_TABLES意为某一用户拥有的或可以访问的所有的关系表。 USER_TABLES意为某一用户所拥有的所有的关系表。 由上可知,当某一用户本身就为数据库DBA时,DBA_

【并查集】 HDU 1213 How Many Tables

HDU 1213 How Many Tables 纯粹的并查集 #include <iostream>#include <string>#include <algorithm>#include <math.h>#include <stdio.h>#include <stdlib.h>using namespace std;int father[1111];int get_fa(

es集群重新分片报错Too many open files解决

现象 查看es集群状态 后面所有操作均在开发工具中操作, 命令行是 curl -XGET -uelastic:password http://ip:9200/_cluster/health GET _cluster/health 查看解释 GET /_cluster/allocation/explain 查看es日志 [WARN ][o.e.c.r.a.AllocationS