本文主要是介绍并差集 ,结构体 畅通工程再续,希望对大家解决编程问题提供一定的参考价值,需要的开发者们随着小编来一起学习吧!
畅通工程再续
Time Limit : 2000/1000ms (Java/Other) Memory Limit : 32768/32768K (Java/Other)
Total Submission(s) : 3 Accepted Submission(s) : 2
Problem Description
相信大家都听说一个“百岛湖”的地方吧,百岛湖的居民生活在不同的小岛中,当他们想去其他的小岛时都要通过划小船来实现。现在政府决定大力发展百岛湖,发展首先要解决的问题当然是交通问题,政府决定实现百岛湖的全畅通!经过考察小组RPRush对百岛湖的情况充分了解后,决定在符合条件的小岛间建上桥,所谓符合条件,就是2个小岛之间的距离不能小于10米,也不能大于1000米。当然,为了节省资金,只要求实现任意2个小岛之间有路通即可。其中桥的价格为 100元/米。
Input
输入包括多组数据。输入首先包括一个整数T(T <= 200),代表有T组数据。 每组数据首先是一个整数C(C <= 100),代表小岛的个数,接下来是C组坐标,代表每个小岛的坐标,这些坐标都是 0 <= x, y <= 1000的整数。
Output
每组输入数据输出一行,代表建桥的最小花费,结果保留一位小数。如果无法实现工程以达到全部畅通,输出”oh!”.
Sample Input
2
2
10 10
20 20
3
1 1
2 2
1000 1000
Sample Output
1414.2
oh!
Author
8600
Source
2008浙大研究生复试热身赛(2)——全真模拟
#include<stdio.h>
#include<iostream>
#include<algorithm>
#include<math.h>
using namespace std;
struct node
{int x1,y1;double length;
} land[102*102];
int x[102],y[102];
int root[102];
int num[102];
bool cmp(node a,node b)
{return a.length<b.length;
}
int find_root(int son)
{if(root[son]!=son){root[son]=find_root(root[son]);}return root[son];
}
int main()
{int times,c;scanf("%d",×);while(times--){scanf("%d",&c);for(int i=1; i<=c; i++){scanf("%d%d",&x[i],&y[i]);}for(int i=1; i<=c; i++){num[i]=1;root[i]=i;}int n=1;for(int i=1; i<c; i++){for(int j=i+1; j<=c; j++){land[n].x1=i;land[n].y1=j;land[n].length=sqrt((x[i]-x[j])*(x[i]-x[j])+(y[i]-y[j])*(y[i]-y[j]));n++;}}sort(land+1,land+n,cmp);int fx,fy;double money=0;for(int i=1; i<n; i++){if(land[i].length>=10&&land[i].length<=1000){fx=find_root(land[i].x1);fy=find_root(land[i].y1);if(fx!=fy){money+=land[i].length*100;root[fx]=fy;num[fy]+=num[fx];}if(num[fy]>=c||num[fx]>=c){break;}}}if(num[fy]>=c||num[fx]>=c){printf("%.1lf\n",money);}else{printf("oh!\n");}}return 0;
}
这篇关于并差集 ,结构体 畅通工程再续的文章就介绍到这儿,希望我们推荐的文章对编程师们有所帮助!