本文主要是介绍sincerit-杭电oj 1237 简单计算器,希望对大家解决编程问题提供一定的参考价值,需要的开发者们随着小编来一起学习吧!
1237 简单计算器
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 26856 Accepted Submission(s): 9741
Problem Description
读入一个只包含 +, -, *, / 的非负整数计算表达式,计算该表达式的值。
Input
测试输入包含若干测试用例,每个测试用例占一行,每行不超过200个字符,整数和运算符之间用一个空格分隔。没有非法表达式。当一行中只有0时输入结束,相应的结果不要输出。
Output
对每个测试用例输出1行,即该表达式的值,精确到小数点后2位。
Sample Input
1 + 2
4 + 2 * 5 - 7 / 11
0
Sample Output
3.00
13.36
#include <iostream>
#include <cstring>
#include <iomanip>
#include <stdio.h>
#include <stack>
using namespace std;
int main() {double x;char sign;while (scanf("%lf", &x)) {stack<double> num;num.push(x);char ch;ch = getchar(); if (x == 0 && ch == '\n') break; // 特殊情况 0 + 1所以要加上ch=='\n'的判断 scanf("%c", &sign);getchar();while (scanf("%lf", &x)) {if (sign == '+') {num.push(x);} else if (sign == '-') {num.push(-x);} else if (sign == '*') {double temp = num.top();num.pop();num.push(temp * x);} else if (sign == '/') {double t = num.top();num.pop();num.push(t*1.0 / x);}ch = getchar(); // 结束时数字后面有一个换行 if (ch == '\n') break;scanf("%c", &sign);getchar();}double sum = 0.0;while (num.size()) {sum += num.top();num.pop();}//cout << fixed << setprecision(2) << sum << "\n";printf("%.2f\n", sum);}return 0;
}
原先两个栈模拟的不知道哪里错了
#include <iostream>
#include <stdio.h>
#include <stack>
#include <cstring>
#include <iomanip>
double cal(double x, double y, char ch) {if (ch == '+') return y + x; else if (ch == '-') return y - x;else if (ch == '*') return y * x; else return y / x;// 入栈再出来的数据刚好相反是y/x 不是x/y
}
int compare(char a, char b) {if (a == '#') return 1;else if (b == '*' || b == '/') {if (a == '+' || a == '-') return 1;}return 0;
}
using namespace std;
int main() {string str;while (getline(cin, str)) {if (str == "0") break;stack<char> sign;sign.push('#');stack<double> num;int k = 0;for (int i = 0; i < str.size(); i++) {if (str[i] >= '0' && str[i] <= '9') {k = k * 10 + str[i] - '0';} else if (str[i] == ' ') {//cout << k << "\n";num.push(k*1.0);k = 0;} else {if (compare(sign.top(), str[i]) == 1) {sign.push(str[i]);} else {double x = num.top();num.pop();double y = num.top();num.pop();num.push(cal(x, y, sign.top()));sign.pop();sign.push(str[i]); // 计算完了之后再把当前符号入栈 }i++; // 符号后面的空格要跳过去 }}num.push(k*1.0); // 最后一个数据还在k中 while (sign.size() > 1) {double a = num.top();num.pop();double b = num.top();num.pop();num.push(cal(a, b, sign.top()));sign.pop();}//cout << fixed << setprecision(2) << num.top() << "\n";printf("%.2f\n", num.top());}return 0;
}
这篇关于sincerit-杭电oj 1237 简单计算器的文章就介绍到这儿,希望我们推荐的文章对编程师们有所帮助!