HDU 1796 How many integers can you find

2023-12-15 18:08
文章标签 find many hdu integers 1796

本文主要是介绍HDU 1796 How many integers can you find,希望对大家解决编程问题提供一定的参考价值,需要的开发者们随着小编来一起学习吧!

链接:http://acm.hdu.edu.cn/showproblem.php?pid=1796


How many integers can you find

Time Limit: 12000/5000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 5612    Accepted Submission(s): 1608


Problem Description

Now you get a number N, and a M-integers set, you should find out how many integers which are small than N, that they can divided exactly by any integers in the set. For example, N=12, and M-integer set is {2,3}, so there is another set {2,3,4,6,8,9,10}, all the integers of the set can be divided exactly by 2 or 3. As a result, you just output the number 7.

Input

There are a lot of cases. For each case, the first line contains two integers N and M. The follow line contains the M integers, and all of them are different from each other. 0<N<2^31,0<M<=10, and the M integer are non-negative and won’t exceed 20.

Output

For each case, output the number.


Sample Input

  
12 2 2 3

Sample Output

  
7

Author
wangye

Source
2008 “Insigma International Cup” Zhejiang Collegiate Programming Contest - Warm Up(4)

Recommend
wangye   |   We have carefully selected several similar problems for you:  1793 1794 1797 1795 1798

大意——给定一个数n和一个具有m个元素的m-集合,要你找出有多少个正整数小于n,并且这些正整数要能被m-集合中的至少一个元素整除。其中0<n<2^31,0<m<=10。

思路——不难发现这是一个裸的简单容斥原理题。容斥原理公式如下图所示:

因此,我们需要找出各个子集的计数,然后按照公式计算。因为是一步一步深入探索,所以可以用深搜实现容斥原理,只是在搜索的过程中要加上符号判断,从而得到正确的结果。

复杂度分析——时间复杂度:O(m+2^cnt),空间复杂度:O(m)

附上AC代码:

#include <iostream>
#include <cstdio>
#include <string>
#include <cmath>
#include <iomanip>
#include <ctime>
#include <climits>
#include <cstdlib>
#include <cstring>
#include <algorithm>
#include <queue>
#include <vector>
#include <set>
#include <map>
//#pragma comment(linker, "/STACK:102400000, 102400000")
using namespace std;
typedef unsigned int li;
typedef long long ll;
typedef unsigned long long ull;
typedef long double ld;
const double pi = acos(-1.0);
const double e = exp(1.0);
const double eps = 1e-8;
const int maxm = 15; // 集合最大计数
int num[maxm]; // m个数的集合
int n, m, cnt; // 给定数n,集合计数m,不为零的m集合计数
int ans; // 最后所求结果int gcd(int a, int b); // 求最大公约数
int lcm(int a, int b); // 求最小公倍数
void dfs(int index, int common, int sign); // 利用深搜展现容斥原理int main()
{ios::sync_with_stdio(false);while (~scanf("%d%d", &n, &m)){int x; // 集合元素cnt = 0;while (m--){scanf("%d", &x);if (0 == x) // 集合元素可能含有零,丢弃零continue;num[cnt++] = x; // 不为零的元素存入集合}ans = 0; // 初始化最后所求结果for (int i=0; i<cnt; i++)dfs(i, num[i], 1); // 枚举m集合中非零元素进行深搜printf("%d\n", ans);}return 0;
}int gcd(int a, int b)
{ // 欧几里得算法/辗转相除法return b ? gcd(b, a%b) : a;
}int lcm(int a, int b)
{ // 这样写,有利于防止中间过程溢出return a/gcd(a, b)*b;
}void dfs(int index, int common, int sign)
{ // 集合元素的索引,最小公倍数,符号判断(容斥公式中的奇数项加偶数项减)common = lcm(num[index], common);if (sign & 1) // 奇数项加ans += (n-1)/common; // 小于n的数,所以用n-1else // 偶数项减ans -= (n-1)/common;for (int i=index+1; i<cnt; ++i)dfs(i, common, sign+1); // 一层是找出一个元素的子集最小公倍数的计数// 两层是找出两个元素的子集最小公倍数的计数// 以此类推,所有子集最小公倍数的计数都找出
}


这篇关于HDU 1796 How many integers can you find的文章就介绍到这儿,希望我们推荐的文章对编程师们有所帮助!



http://www.chinasem.cn/article/497369

相关文章

usaco 1.3 Mixing Milk (结构体排序 qsort) and hdu 2020(sort)

到了这题学会了结构体排序 于是回去修改了 1.2 milking cows 的算法~ 结构体排序核心: 1.结构体定义 struct Milk{int price;int milks;}milk[5000]; 2.自定义的比较函数,若返回值为正,qsort 函数判定a>b ;为负,a<b;为0,a==b; int milkcmp(const void *va,c

poj 3974 and hdu 3068 最长回文串的O(n)解法(Manacher算法)

求一段字符串中的最长回文串。 因为数据量比较大,用原来的O(n^2)会爆。 小白上的O(n^2)解法代码:TLE啦~ #include<stdio.h>#include<string.h>const int Maxn = 1000000;char s[Maxn];int main(){char e[] = {"END"};while(scanf("%s", s) != EO

hdu 2093 考试排名(sscanf)

模拟题。 直接从教程里拉解析。 因为表格里的数据格式不统一。有时候有"()",有时候又没有。而它也不会给我们提示。 这种情况下,就只能它它们统一看作字符串来处理了。现在就请出我们的主角sscanf()! sscanf 语法: #include int sscanf( const char *buffer, const char *format, ... ); 函数sscanf()和

hdu 2602 and poj 3624(01背包)

01背包的模板题。 hdu2602代码: #include<stdio.h>#include<string.h>const int MaxN = 1001;int max(int a, int b){return a > b ? a : b;}int w[MaxN];int v[MaxN];int dp[MaxN];int main(){int T;int N, V;s

uva 10061 How many zero's and how many digits ?(不同进制阶乘末尾几个0)+poj 1401

题意是求在base进制下的 n!的结果有几位数,末尾有几个0。 想起刚开始的时候做的一道10进制下的n阶乘末尾有几个零,以及之前有做过的一道n阶乘的位数。 当时都是在10进制下的。 10进制下的做法是: 1. n阶位数:直接 lg(n!)就是得数的位数。 2. n阶末尾0的个数:由于2 * 5 将会在得数中以0的形式存在,所以计算2或者计算5,由于因子中出现5必然出现2,所以直接一

hdu 1754 I Hate It(线段树,单点更新,区间最值)

题意是求一个线段中的最大数。 线段树的模板题,试用了一下交大的模板。效率有点略低。 代码: #include <stdio.h>#include <string.h>#define TREE_SIZE (1 << (20))//const int TREE_SIZE = 200000 + 10;int max(int a, int b){return a > b ? a :

hdu 1166 敌兵布阵(树状数组 or 线段树)

题意是求一个线段的和,在线段上可以进行加减的修改。 树状数组的模板题。 代码: #include <stdio.h>#include <string.h>const int maxn = 50000 + 1;int c[maxn];int n;int lowbit(int x){return x & -x;}void add(int x, int num){while

hdu 3790 (单源最短路dijkstra)

题意: 每条边都有长度d 和花费p,给你起点s 终点t,要求输出起点到终点的最短距离及其花费,如果最短距离有多条路线,则输出花费最少的。 解析: 考察对dijkstra的理解。 代码: #include <iostream>#include <cstdio>#include <cstdlib>#include <algorithm>#include <cstrin

hdu 2489 (dfs枚举 + prim)

题意: 对于一棵顶点和边都有权值的树,使用下面的等式来计算Ratio 给定一个n 个顶点的完全图及它所有顶点和边的权值,找到一个该图含有m 个顶点的子图,并且让这个子图的Ratio 值在所有m 个顶点的树中最小。 解析: 因为数据量不大,先用dfs枚举搭配出m个子节点,算出点和,然后套个prim算出边和,每次比较大小即可。 dfs没有写好,A的老泪纵横。 错在把index在d

hdu 1102 uva 10397(最小生成树prim)

hdu 1102: 题意: 给一个邻接矩阵,给一些村庄间已经修的路,问最小生成树。 解析: 把已经修的路的权值改为0,套个prim()。 注意prim 最外层循坏为n-1。 代码: #include <iostream>#include <cstdio>#include <cstdlib>#include <algorithm>#include <cstri