本文主要是介绍UVa 10034 - Freckles (最小生成树模板题),希望对大家解决编程问题提供一定的参考价值,需要的开发者们随着小编来一起学习吧!
链接:
http://uva.onlinejudge.org/index.php?option=com_onlinejudge&Itemid=8&category=24&page=show_problem&problem=975
题目:
Problem A: Freckles
Consider Dick's back to be a plane with freckles at various (x,y) locations. Your job is to tell Richie how to connect the dots so as to minimize the amount of ink used. Richie connects the dots by drawing straight lines between pairs, possibly lifting the pen between lines. When Richie is done there must be a sequence of connected lines from any freckle to any other freckle.
Input
The input begins with a single positive integer on a line by itself indicating the number of the cases following, each of them as described below. This line is followed by a blank line, and there is also a blank line between two consecutive inputs.The first line contains 0 < n <= 100, the number of freckles on Dick's back. For each freckle, a line follows; each following line contains two real numbers indicating the (x,y) coordinates of the freckle.
Output
For each test case, the output must follow the description below. The outputs of two consecutive cases will be separated by a blank line.Your program prints a single real number to two decimal places: the minimum total length of ink lines that can connect all the freckles.
Sample Input
13 1.0 1.0 2.0 2.0 2.0 4.0
Sample Output
3.41
分析与总结:
赤裸裸的最小生成树,模板题
代码:
1. Kruskal
#include<cstdio>
#include<cstring>
#include<cmath>
#include<algorithm>
using namespace std;
#define N 105
double coord[N][2], w[N][N];
int n, pos;
int f[N*N], rank[N*N];struct Edge{int u, v;double val;friend bool operator<(const Edge&a,const Edge&b){return a.val < b.val;}
}arr[N*N];inline double getDist(double x1,double y1,double x2,double y2){return sqrt((x1-x2)*(x1-x2)+(y1-y2)*(y1-y2));
}void init(){for(int i=0; i<N*N; ++i)f[i]=i, rank[i]=0;
}
int find(int x){int i,j=x;while(j!=f[j]) j=f[j];while(x!=j){i=f[x]; f[x]=j; x=i;}return j;
}
bool Union(int x,int y){int a=find(x),b=find(y);if(a==b)return false;if(rank[a]>rank[b])f[b]=a;else{if(rank[a]==rank[b])++rank[b];f[a] = b;}return true;
}int main(){int T;scanf("%d",&T);while(T--){scanf("%d",&n);for(int i=1; i<=n; ++i)scanf("%lf%lf",&coord[i][0],&coord[i][1]);pos = 0;for(int i=1; i<=n; ++i){for(int j=i+1; j<=n; ++j){arr[pos].u=i, arr[pos].v=j;arr[pos++].val = getDist(coord[i][0],coord[i][1],coord[j][0],coord[j][1]);}}double ans=0;init();sort(arr, arr+pos);for(int i=0; i<pos; ++i){if(Union(arr[i].u, arr[i].v))ans += arr[i].val;}printf("%.2f\n", ans);if(T)puts("");} return 0;
}
2.Prim
#include<cstdio>
#include<cstring>
#include<cmath>
#define N 105
double coord[N][2], w[N][N], minCost[N];
int n, pre[N], hash[N];inline double getDist(double x1,double y1,double x2,double y2){return sqrt((x1-x2)*(x1-x2)+(y1-y2)*(y1-y2));
}double Prim(){memset(hash, 0, sizeof(hash));hash[1] = 1;for(int i=1; i<=n; ++i){minCost[i] = w[1][i];pre[i] = 1;}double sum=0;for(int i=1; i<n; ++i){int u=-1;for(int j=1; j<=n; ++j)if(!hash[j]){if(u==-1||minCost[j]<minCost[u])u=j;}sum += w[pre[u]][u];hash[u] = 1;for(int j=1; j<=n; ++j)if(!hash[j]){if(minCost[j]>w[u][j]){minCost[j] = w[u][j];pre[j] = u;}}}return sum;
}
int main(){int T;scanf("%d",&T);while(T--){scanf("%d",&n);for(int i=1; i<=n; ++i)scanf("%lf%lf",&coord[i][0],&coord[i][1]);memset(w, 0, sizeof(w));for(int i=1; i<=n; ++i)for(int j=1; j<=n; ++j)if(i!=j)w[i][j] = getDist(coord[i][0],coord[i][1],coord[j][0],coord[j][1]);printf("%.2f\n", Prim());if(T) printf("\n");} return 0;
}
—— 生命的意义,在于赋予它意义。
原创 http://blog.csdn.net/shuangde800 , By D_Double (转载请标明)
这篇关于UVa 10034 - Freckles (最小生成树模板题)的文章就介绍到这儿,希望我们推荐的文章对编程师们有所帮助!