本文主要是介绍1081 Rational Sum (20 分),希望对大家解决编程问题提供一定的参考价值,需要的开发者们随着小编来一起学习吧!
1081 Rational Sum (20 分)
Given N rational numbers in the form numerator/denominator, you are supposed to calculate their sum.
Input Specification:
Each input file contains one test case. Each case starts with a positive integer N (≤100), followed in the next line N rational numbers a1/b1 a2/b2 … where all the numerators and denominators are in the range of long int. If there is a negative number, then the sign must appear in front of the numerator.
Output Specification:
For each test case, output the sum in the simplest form integer numerator/denominator where integer is the integer part of the sum, numerator < denominator, and the numerator and the denominator have no common factor. You must output only the fractional part if the integer part is 0.
Sample Input 1:
5
2/5 4/15 1/30 -2/60 8/3
Sample Output 1:
3 1/3
Sample Input 2:
2
4/3 2/3
Sample Output 2:
2
Sample Input 3:
3
1/3 -1/6 1/8
Sample Output 3:
7/24
#include<bits/stdc++.h>
using namespace std;
typedef long long ll;
ll gcb(ll a, ll b) {return b == 0 ? a : gcb(b, a % b);
}
void func(ll a, ll b) {bool flag = ((a < 0 && b > 0) || (a > 0 && b < 0));a = abs(a); b = abs(b);ll x = a / b;printf("%s", flag ? "-" : "");if (x != 0) printf("%lld", x);if (a % b == 0) {if (x == 0) printf("0");return ;}if (x != 0) printf(" ");a = a - x * b;printf("%lld/%lld", a, b);
}
int main () {int n;scanf("%d", &n);ll a = 0, b = 1, c, d;for (int i = 0; i < n; i++) {scanf("%lld/%lld", &c, &d);a = a * d + c * b;b = b * d;ll t = gcb(a, b);a /= t;b /= t;}func(a, b);
}
这篇关于1081 Rational Sum (20 分)的文章就介绍到这儿,希望我们推荐的文章对编程师们有所帮助!