POJ_1503

2023-11-29 17:58
文章标签 poj 1503

本文主要是介绍POJ_1503,希望对大家解决编程问题提供一定的参考价值,需要的开发者们随着小编来一起学习吧!

一.题目

Integer Inquiry
Time Limit: 1000MS
Memory Limit: 10000K

Description

One of the first users of BIT's new supercomputer was Chip Diller. He extended his exploration of powers of 3 to go from 0 to 333 and he explored taking various sums of those numbers. 
``This supercomputer is great,'' remarked Chip. ``I only wish Timothy were here to see these results.'' (Chip moved to a new apartment, once one became available on the third floor of the Lemon Sky apartments on Third Street.) 

Input

The input will consist of at most 100 lines of text, each of which contains a single VeryLongInteger. Each VeryLongInteger will be 100 or fewer characters in length, and will only contain digits (no VeryLongInteger will be negative). 

The final input line will contain a single zero on a line by itself. 

Output

Your program should output the sum of the VeryLongIntegers given in the input.

Sample Input

123456789012345678901234567890
123456789012345678901234567890
123456789012345678901234567890
0

Sample Output

370370367037037036703703703670


二.解题技巧

    这道题是一个简单的无符号大数字相加,通过模拟手算就可以实现,主要技巧在于需要将输入的大数字按位逆序放在vector或数组中,也就是将个位的数字放在下标为0的位置,将十位上的数字放在下标为1的位置,这样子放置的话,发现结果有进位的时候,只要在vector或者数组后面添加一位就可以了。


三.实现代码

#include <iostream>
#include <string>
#include <vector>using namespace std;class Highprecision
{private:std::vector<signed char> Element;Highprecision();void ConvertString(const std::string& InputString);void ConvertInteger(long InputInteger);public:Highprecision(const std::string& InputString);Highprecision(long InputInteger);Highprecision(const Highprecision& InputHighrecision);// supported operatorfriend std::ostream& operator << (std::ostream& OutputStrem,Highprecision& OutputHighprecision);Highprecision operator + (const Highprecision& Rhs);Highprecision& operator = (const Highprecision& Rhs);
};Highprecision::Highprecision():Element()
{
}void Highprecision::ConvertString(const std::string &InputString)
{if (!Element.empty()){Element.clear();}int Length = InputString.size();const char* Array = InputString.c_str();signed char Tmp = 0;for (int Index = 1; Index <= Length; Index++){Tmp = (*(Array + Length - Index)) - '0';Element.push_back(Tmp);}
}void Highprecision::ConvertInteger(long InputInteger)
{if (!Element.empty()){Element.clear();}unsigned char Value = 0;while(true){Value = InputInteger % 10;Element.push_back(Value);InputInteger = InputInteger / 10;if (InputInteger == 0){break;}}
}Highprecision::Highprecision(const std::string &InputString):Element()
{ConvertString(InputString);
}Highprecision::Highprecision(long InputInteger) : Element()
{ConvertInteger(InputInteger);
}Highprecision::Highprecision(const Highprecision &InputHighrecision) :Element(InputHighrecision.Element)
{
}std::ostream& operator <<(std::ostream &OutputStream, Highprecision &OutputHighprecision)
{std::vector<signed char> Element = OutputHighprecision.Element;int Size = Element.size();signed char Tmp = 0;for (int Index = 1; Index <= Size; Index++){Tmp = Element[Size - Index] + '0';OutputStream << Tmp;}return OutputStream;
}Highprecision Highprecision::operator +(const Highprecision &Rhs)
{signed char LValue = 0;signed char RValue = 0;signed char Carry = 0;int LSize = Element.size();int RSize = Rhs.Element.size();const std::vector<signed char>& RElement = Rhs.Element;signed char TmpResult = 0;Highprecision Result;std::vector<signed char>& ResultElement = Result.Element;for (int Index = 0; (Index < LSize) || (Index < RSize); Index++){if (Index < LSize){LValue = Element[Index];}if (Index < RSize){RValue = RElement[Index];}TmpResult = LValue + RValue + Carry;Carry = TmpResult / 10;TmpResult = TmpResult % 10;ResultElement.push_back(TmpResult);LValue = 0;RValue = 0;}if (Carry > 0){ResultElement.push_back(Carry);}return Result;}Highprecision &Highprecision::operator =(const Highprecision &Rhs)
{if (&Rhs == this){return *this;}Element = Rhs.Element;return *this;}int main()
{Highprecision Result(0);std::string InputString;while(true){cin >> InputString;if ((InputString.size() == 1) && (InputString[0] == '0')){break;}Highprecision Input(InputString);Result = Result + Input;}cout << Result;return 0;
}



四.体会

    这个题目还是比较基础的,只要有了思路,剩下来的就是执行力了。


 

版权所有,欢迎转载,转载请注明出处,谢谢微笑



这篇关于POJ_1503的文章就介绍到这儿,希望我们推荐的文章对编程师们有所帮助!



http://www.chinasem.cn/article/433788

相关文章

poj 3974 and hdu 3068 最长回文串的O(n)解法(Manacher算法)

求一段字符串中的最长回文串。 因为数据量比较大,用原来的O(n^2)会爆。 小白上的O(n^2)解法代码:TLE啦~ #include<stdio.h>#include<string.h>const int Maxn = 1000000;char s[Maxn];int main(){char e[] = {"END"};while(scanf("%s", s) != EO

hdu 2602 and poj 3624(01背包)

01背包的模板题。 hdu2602代码: #include<stdio.h>#include<string.h>const int MaxN = 1001;int max(int a, int b){return a > b ? a : b;}int w[MaxN];int v[MaxN];int dp[MaxN];int main(){int T;int N, V;s

poj 1511 Invitation Cards(spfa最短路)

题意是给你点与点之间的距离,求来回到点1的最短路中的边权和。 因为边很大,不能用原来的dijkstra什么的,所以用spfa来做。并且注意要用long long int 来存储。 稍微改了一下学长的模板。 stack stl 实现代码: #include<stdio.h>#include<stack>using namespace std;const int M

poj 3259 uva 558 Wormholes(bellman最短路负权回路判断)

poj 3259: 题意:John的农场里n块地,m条路连接两块地,w个虫洞,虫洞是一条单向路,不但会把你传送到目的地,而且时间会倒退Ts。 任务是求你会不会在从某块地出发后又回来,看到了离开之前的自己。 判断树中是否存在负权回路就ok了。 bellman代码: #include<stdio.h>const int MaxN = 501;//农场数const int

poj 1258 Agri-Net(最小生成树模板代码)

感觉用这题来当模板更适合。 题意就是给你邻接矩阵求最小生成树啦。~ prim代码:效率很高。172k...0ms。 #include<stdio.h>#include<algorithm>using namespace std;const int MaxN = 101;const int INF = 0x3f3f3f3f;int g[MaxN][MaxN];int n

poj 1287 Networking(prim or kruscal最小生成树)

题意给你点与点间距离,求最小生成树。 注意点是,两点之间可能有不同的路,输入的时候选择最小的,和之前有道最短路WA的题目类似。 prim代码: #include<stdio.h>const int MaxN = 51;const int INF = 0x3f3f3f3f;int g[MaxN][MaxN];int P;int prim(){bool vis[MaxN];

poj 2349 Arctic Network uva 10369(prim or kruscal最小生成树)

题目很麻烦,因为不熟悉最小生成树的算法调试了好久。 感觉网上的题目解释都没说得很清楚,不适合新手。自己写一个。 题意:给你点的坐标,然后两点间可以有两种方式来通信:第一种是卫星通信,第二种是无线电通信。 卫星通信:任何两个有卫星频道的点间都可以直接建立连接,与点间的距离无关; 无线电通信:两个点之间的距离不能超过D,无线电收发器的功率越大,D越大,越昂贵。 计算无线电收发器D

poj 1502 MPI Maelstrom(单源最短路dijkstra)

题目真是长得头疼,好多生词,给跪。 没啥好说的,英语大水逼。 借助字典尝试翻译了一下,水逼直译求不喷 Description: BIT他们的超级计算机最近交货了。(定语秀了一堆词汇那就省略吧再见) Valentine McKee的研究顾问Jack Swigert,要她来测试一下这个系统。 Valentine告诉Swigert:“因为阿波罗是一个分布式共享内存的机器,所以它的内存访问

uva 10061 How many zero's and how many digits ?(不同进制阶乘末尾几个0)+poj 1401

题意是求在base进制下的 n!的结果有几位数,末尾有几个0。 想起刚开始的时候做的一道10进制下的n阶乘末尾有几个零,以及之前有做过的一道n阶乘的位数。 当时都是在10进制下的。 10进制下的做法是: 1. n阶位数:直接 lg(n!)就是得数的位数。 2. n阶末尾0的个数:由于2 * 5 将会在得数中以0的形式存在,所以计算2或者计算5,由于因子中出现5必然出现2,所以直接一

poj 3159 (spfa差分约束最短路) poj 1201

poj 3159: 题意: 每次给出b比a多不多于c个糖果,求n最多比1多多少个糖果。 解析: 差分约束。 这个博客讲差分约束讲的比较好: http://www.cnblogs.com/void/archive/2011/08/26/2153928.html 套个spfa。 代码: #include <iostream>#include <cstdio>#i