ZOJ 1516 Uncle Tom's Inherited Land (二分图匹配)

2023-11-21 21:18

本文主要是介绍ZOJ 1516 Uncle Tom's Inherited Land (二分图匹配),希望对大家解决编程问题提供一定的参考价值,需要的开发者们随着小编来一起学习吧!

题目链接:http://acm.zju.edu.cn/onlinejudge/showProblem.do?problemCode=1516

Your old uncle Tom inherited a piece of land from his great-great-uncle. Originally, the property had been in the shape of a rectangle. A long time ago, however, his great-great-uncle decided to divide the land into a grid of small squares. He turned some of the squares into ponds, for he loved to hunt ducks and wanted to attract them to his property. (You cannot be sure, for you have not been to the place, but he may have made so many ponds that the land may now consist of several disconnected islands.)

Your uncle Tom wants to sell the inherited land, but local rules now regulate property sales. Your uncle has been informed that, at his great-great-uncle's request, a law has been passed which establishes that property can only be sold in rectangular lots the size of two squares of your uncle's property. Furthermore, ponds are not salable property.

Your uncle asked your help to determine the largest number of properties he could sell (the remaining squares will become recreational parks).


Input


Input will include several test cases. The first line of a test case contains two integers N and M, representing, respectively, the number of rows and columns of the land (1 <= N, M <= 100). The second line will contain an integer K indicating the number of squares that have been turned into ponds ( (N x M) - K <= 50). Each of the next K lines contains two integers X and Y describing the position of a square which was turned into a pond (1 <= X <= N and 1 <= Y <= M). The end of input is indicated by N = M = 0.


<b< dd="">

Output


For each test case in the input your program should produce one line of output, containing an integer value representing the maximum number of properties which can be sold.


<b< dd="">

Sample Input

4 4
6
1 1
1 4
2 2
4 1
4 2
4 4
4 3
4
4 2
3 2
2 2
3 1
0 0


<b< dd="">

Sample Output

4
3


   题意:n*m的土地上,求有多少1*2 或者 2*1 的块数 ,池塘不能算在内.

   思路:每一个不是池塘的土地,都可以跟他的上下左右四个方向上不是池塘的块构成一个1*2或者2*1的长方形块,把所有连通的块存起来,构成一个二部图,剩下的就是求最大匹配.

#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
#define MAXN 110
int g[MAXN][MAXN];
int mp[MAXN][MAXN];
int node[MAXN][MAXN];
int cx[MAXN],cy[MAXN];
int sx[MAXN],sy[MAXN];
int vis[MAXN];
int n,m,num,ans;
int dir[4][2]= {0,1,1,0,0,-1,-1,0};
void bulid()
{int i,j,k;num=1;for(i=1; i<=n; i++)for(j=1; j<=m; j++){if(!mp[i][j])node[i][j]=num++;}for(i=1; i<=n; i++)for(j=1; j<=m; j++){if(!mp[i][j]){for(k=0; k<4; k++){int tx=i+dir[k][0];int ty=j+dir[k][1];if(tx>=1&&tx<=n&&ty>=1&&ty<=m&&mp[tx][ty]==0){g[node[i][j]][node[tx][ty]]=1;g[node[tx][ty]][node[i][j]]=1;}}}}
}
int path(int u)
{sx[u]=1;int v;for(v=1; v<=num; v++){if(g[u][v]&&!sy[v]){sy[v]=1;if(!cy[v]||path(cy[v])){cx[u]=v;cy[v]=u;return 1;}}}return 0;
}
int MaxMatch()
{int i;ans=0;memset(cx,0,sizeof(cx));memset(cy,0,sizeof(cy));for(i=1; i<=num; i++){if(!cx[i]){memset(sx,0,sizeof(sx));memset(sy,0,sizeof(sy));ans+=path(i);}}return 0;
}
int main()
{int i,j,k,u,v;while(~scanf("%d%d",&n,&m)&&n+m){memset(mp,0,sizeof(mp));memset(g,0,sizeof(g));memset(node,0,sizeof(node));scanf("%d",&k);for(i=0; i<k; i++){scanf("%d%d",&u,&v);mp[u][v]=1;}bulid();MaxMatch();printf("%d\n",ans/2);}return 0;
}

这篇关于ZOJ 1516 Uncle Tom's Inherited Land (二分图匹配)的文章就介绍到这儿,希望我们推荐的文章对编程师们有所帮助!



http://www.chinasem.cn/article/405157

相关文章

详解nginx 中location和 proxy_pass的匹配规则

《详解nginx中location和proxy_pass的匹配规则》location是Nginx中用来匹配客户端请求URI的指令,决定如何处理特定路径的请求,它定义了请求的路由规则,后续的配置(如... 目录location 的作用语法示例:location /www.chinasem.cntestproxy

Nginx中location实现多条件匹配的方法详解

《Nginx中location实现多条件匹配的方法详解》在Nginx中,location指令用于匹配请求的URI,虽然location本身是基于单一匹配规则的,但可以通过多种方式实现多个条件的匹配逻辑... 目录1. 概述2. 实现多条件匹配的方式2.1 使用多个 location 块2.2 使用正则表达式

golang字符串匹配算法解读

《golang字符串匹配算法解读》文章介绍了字符串匹配算法的原理,特别是Knuth-Morris-Pratt(KMP)算法,该算法通过构建模式串的前缀表来减少匹配时的不必要的字符比较,从而提高效率,在... 目录简介KMP实现代码总结简介字符串匹配算法主要用于在一个较长的文本串中查找一个较短的字符串(称为

C++使用栈实现括号匹配的代码详解

《C++使用栈实现括号匹配的代码详解》在编程中,括号匹配是一个常见问题,尤其是在处理数学表达式、编译器解析等任务时,栈是一种非常适合处理此类问题的数据结构,能够精确地管理括号的匹配问题,本文将通过C+... 目录引言问题描述代码讲解代码解析栈的状态表示测试总结引言在编程中,括号匹配是一个常见问题,尤其是在

关于Gateway路由匹配规则解读

《关于Gateway路由匹配规则解读》本文详细介绍了SpringCloudGateway的路由匹配规则,包括基本概念、常用属性、实际应用以及注意事项,路由匹配规则决定了请求如何被转发到目标服务,是Ga... 目录Gateway路由匹配规则一、基本概念二、常用属性三、实际应用四、注意事项总结Gateway路由

hdu2241(二分+合并数组)

题意:判断是否存在a+b+c = x,a,b,c分别属于集合A,B,C 如果用暴力会超时,所以这里用到了数组合并,将b,c数组合并成d,d数组存的是b,c数组元素的和,然后对d数组进行二分就可以了 代码如下(附注释): #include<iostream>#include<algorithm>#include<cstring>#include<stack>#include<que

hdu2289(简单二分)

虽说是简单二分,但是我还是wa死了  题意:已知圆台的体积,求高度 首先要知道圆台体积怎么求:设上下底的半径分别为r1,r2,高为h,V = PI*(r1*r1+r1*r2+r2*r2)*h/3 然后以h进行二分 代码如下: #include<iostream>#include<algorithm>#include<cstring>#include<stack>#includ

【Prometheus】PromQL向量匹配实现不同标签的向量数据进行运算

✨✨ 欢迎大家来到景天科技苑✨✨ 🎈🎈 养成好习惯,先赞后看哦~🎈🎈 🏆 作者简介:景天科技苑 🏆《头衔》:大厂架构师,华为云开发者社区专家博主,阿里云开发者社区专家博主,CSDN全栈领域优质创作者,掘金优秀博主,51CTO博客专家等。 🏆《博客》:Python全栈,前后端开发,小程序开发,人工智能,js逆向,App逆向,网络系统安全,数据分析,Django,fastapi

poj 2976 分数规划二分贪心(部分对总体的贡献度) poj 3111

poj 2976: 题意: 在n场考试中,每场考试共有b题,答对的题目有a题。 允许去掉k场考试,求能达到的最高正确率是多少。 解析: 假设已知准确率为x,则每场考试对于准确率的贡献值为: a - b * x,将贡献值大的排序排在前面舍弃掉后k个。 然后二分x就行了。 代码: #include <iostream>#include <cstdio>#incl

poj 3104 二分答案

题意: n件湿度为num的衣服,每秒钟自己可以蒸发掉1个湿度。 然而如果使用了暖炉,每秒可以烧掉k个湿度,但不计算蒸发了。 现在问这么多的衣服,怎么烧事件最短。 解析: 二分答案咯。 代码: #include <iostream>#include <cstdio>#include <cstdlib>#include <algorithm>#include <c