zoj 2106 Tick and Tick(比较好的数学题目,代码特麻烦,注意精度)

2023-11-08 12:08

本文主要是介绍zoj 2106 Tick and Tick(比较好的数学题目,代码特麻烦,注意精度),希望对大家解决编程问题提供一定的参考价值,需要的开发者们随着小编来一起学习吧!

1、http://acm.zju.edu.cn/onlinejudge/showProblem.do?problemId=1106

2、题目大意:

一个钟的三个指针在不停的转动,他们已经厌烦了这样,当他们互相的距离角度大于等于D时,他们会很开心,问一天之中他们happy的时间占总时间的概率。
我觉得这是在解不等式,我原来使用的暴力破解,毫无疑问失败了;我们只要找到某一分钟内,他们happy的时间,然后钟每过12个小时相当于43200秒复原一次。因此总时间就是43200白秒,只要求出在这43200的happy时间,答案就知道了;
假设现在的时钟是h小时,m分钟,s秒,给定的角度为degree;则列出happy的不等式有
时针到0时刻的角度的实际值为hw = (h+m/60+s/3600)*30,分针的角度mw = (m+s/60)*6,秒针的角度为sw = s*6;则他们都happy的条件为
degree<|hw -mw|<360 - degree;<1>
degree<|hw - sw|<360 - defgree;<2>
degree<|sw - mw|<360 - degree ;<3>
解这三个不等式即可得到s的区间,把区间的最大值减去最小值就是happy的时间,把每小时每分钟的happy时间再叠加,就是总的happy时间了,再除以总时间的百分比并保留三个小数就是答案。

3、题目:

Tick and Tick

Time Limit: 2 Seconds      Memory Limit: 65536 KB

The three hands of the clock are rotating every second and meeting each other many times everyday. Finally, they get bored of this and each of them would like to stay away from the other two. A hand is happy if it is at least D degrees from any of the rest. You are to calculate how much time in a day that all the hands are happy.


Input

The input contains many test cases. Each of them has a single line with a real number D between 0 and 120, inclusively. The input is terminated with a D of -1.


Output

For each D, print in a single line the percentage of time in a day that all of the hands are happy, accurate up to 3 decimal places.


Sample Input

0
120
90
-1


Sample Output

100.000
0.000
6.251


4、AC代码:

#include<stdio.h>
#include<algorithm>
using namespace std;
#define INF 0x7fffffff
double D;
struct node
{double l;double r;
}s[3][2];
node interval(double a,double b)//解方程D<=|a*s-b|<=360-D
{node p;if(a>0){p.l=(D-b)/a;p.r=(360-D-b)/a;}else{p.l=(360-D-b)/a;p.r=(D-b)/a;}if(p.l>=p.r){p.l=0;p.r=0;}if(p.l<0)p.l=0;if(p.r>60)p.r=60;return p;
}node jiao(node a,node b)
{node p;p.l=max(a.l,b.l);p.r=min(a.r,b.r);if(p.l>=p.r) p.l=p.r=0;return p;
}
double solve(int h,int m)
{double a,b;/*时针与分针的角度处理解方程式 D<=|hw-mw|<=360-Dhw=(h+m/60+s/3600)*30mw=(m+s/60)*6*/a=1.0/120.0-1.0/10.0;b=30*h+m/2.0-6.0*m;s[0][0]=interval(a,b);s[0][1]=interval(-a,-b);/*时针与秒针的角度处理解方程式 D<=|hw-sw|<=360-Dhw=(h+m/60+s/3600)*30sw=s*6*/a=1.0/120-6.0;b=30*h+m/2.0;s[1][0]=interval(a,b);s[1][1]=interval(-a,-b);/*分针与秒针的角度处理解方程式 D<=|mw-sw|<=360-Dmw=(m+s/3600)*30sw=s*6*/a=0.1-6;b=6*m;s[2][0]=interval(a,b);s[2][1]=interval(-a,-b);//两个绝对值出来的区间取并集,三个并集之间取交集node s1;double res=0;for(int i=0;i<2;i++)for(int j=0;j<2;j++)for(int k=0;k<2;k++){s1=jiao(jiao(s[0][i],s[1][j]),s[2][k]);res+=s1.r-s1.l;}return res;
}
int main()
{while(scanf("%lf",&D)!=EOF){if(D==-1)break;double ans=0;for(int i=0;i<12;i++){for(int j=0;j<60;j++)ans+=solve(i,j);//i小时j分钟}printf("%.3f\n",100.0*ans/(60*60*12));}return 0;
}

其中的合并取交集参考网上代码,自己写的错了

错的代码:

#include<stdio.h>
#include<algorithm>
using namespace std;
#define INF 0x7fffffff
double D;
struct node
{double l;double r;
}s[3][2];
node interval(double a,double b)//解方程D<=|a*s-b|<=360-D
{node p;if(a>0){p.l=(D-b)/a;p.r=(360-D-b)/a;}else{p.l=(360-D-b)/a;p.r=(D-b)/a;}if(p.l>=p.r){p.l=0;p.r=0;}if(p.l<0)p.l=0;if(p.r>60)p.r=60;return p;
}
node jiao(node a,node b)
{node p;p.l=max(a.l,b.l);p.r=min(a.r,b.r);if(p.l>=p.r) p.l=p.r=0;return p;
}
double solve(int h,int m)
{double a,b;/*时针与分针的角度处理解方程式 D<=|hw-mw|<=360-Dhw=(h+m/60+s/3600)*30mw=(m+s/60)*6*/a=1.0/120-1.0/10.0;b=30*h+m/2.0-6.0*m;s[0][0]=interval(a,b);s[0][1]=interval(-a,-b);/*时针与秒针的角度处理解方程式 D<=|hw-sw|<=360-Dhw=(h+m/60+s/3600)*30sw=s*6*/a=1.0/120-6;b=30*h+m/2.0;s[1][0]=interval(a,b);s[1][1]=interval(-a,-b);/*分针与秒针的角度处理解方程式 D<=|mw-sw|<=360-Dmw=(m+s/3600)*30sw=s*6*/a=0.1-6;b=6.0*m;s[2][0]=interval(a,b);s[2][1]=interval(-a,-b);//两个绝对值出来的区间取并集,三个并集之间取交集node s1[20];int k=0;for(int i=0;i<3;i++){if((s[i][0].r>=s[i][1].l) || (s[i][1].r>=s[i][0].l) ){s1[k].l=max(s[i][0].l,s[i][1].l);s1[k].r=max(s[i][0].r,s[i][1].r);k++;}else if(s[i][0].l>=s[i][1].l && s[i][0].r<=s[i][1].r){s1[k]=s[i][1];k++;}else if(s[i][1].l>=s[i][0].l && s[i][1].r<=s[i][0].r){s1[k]=s[i][0];k++;}else{s1[k]=s[i][0];k++;s1[k]=s[i][1];k++;}}node s2=s1[0];for(int i=1;i<k;i++){s2=jiao(s2,s1[i]);}double anss;anss=s2.r-s2.l;return anss;
}
int main()
{while(scanf("%lf",&D)!=EOF){if(D==-1)break;double ans=0;for(int i=0;i<12;i++){for(int j=0;j<60;j++)ans+=solve(i,j);//i小时j分钟}printf("%.3f\n",100.0*ans/(60*60*12));}return 0;
}



这篇关于zoj 2106 Tick and Tick(比较好的数学题目,代码特麻烦,注意精度)的文章就介绍到这儿,希望我们推荐的文章对编程师们有所帮助!



http://www.chinasem.cn/article/369748

相关文章

百度/小米/滴滴/京东,中台架构比较

小米中台建设实践 01 小米的三大中台建设:业务+数据+技术 业务中台--从业务说起 在中台建设中,需要规范化的服务接口、一致整合化的数据、容器化的技术组件以及弹性的基础设施。并结合业务情况,判定是否真的需要中台。 小米参考了业界优秀的案例包括移动中台、数据中台、业务中台、技术中台等,再结合其业务发展历程及业务现状,整理了中台架构的核心方法论,一是企业如何共享服务,二是如何为业务提供便利。

活用c4d官方开发文档查询代码

当你问AI助手比如豆包,如何用python禁止掉xpresso标签时候,它会提示到 这时候要用到两个东西。https://developers.maxon.net/论坛搜索和开发文档 比如这里我就在官方找到正确的id描述 然后我就把参数标签换过来

购买磨轮平衡机时应该注意什么问题和技巧

在购买磨轮平衡机时,您应该注意以下几个关键点: 平衡精度 平衡精度是衡量平衡机性能的核心指标,直接影响到不平衡量的检测与校准的准确性,从而决定磨轮的振动和噪声水平。高精度的平衡机能显著减少振动和噪声,提高磨削加工的精度。 转速范围 宽广的转速范围意味着平衡机能够处理更多种类的磨轮,适应不同的工作条件和规格要求。 振动监测能力 振动监测能力是评估平衡机性能的重要因素。通过传感器实时监

poj 1258 Agri-Net(最小生成树模板代码)

感觉用这题来当模板更适合。 题意就是给你邻接矩阵求最小生成树啦。~ prim代码:效率很高。172k...0ms。 #include<stdio.h>#include<algorithm>using namespace std;const int MaxN = 101;const int INF = 0x3f3f3f3f;int g[MaxN][MaxN];int n

uva 10014 Simple calculations(数学推导)

直接按照题意来推导最后的结果就行了。 开始的时候只做到了第一个推导,第二次没有继续下去。 代码: #include<stdio.h>int main(){int T, n, i;double a, aa, sum, temp, ans;scanf("%d", &T);while(T--){scanf("%d", &n);scanf("%lf", &first);scanf

uva 10025 The ? 1 ? 2 ? ... ? n = k problem(数学)

题意是    ?  1  ?  2  ?  ...  ?  n = k 式子中给k,? 处可以填 + 也可以填 - ,问最小满足条件的n。 e.g k = 12  - 1 + 2 + 3 + 4 + 5 + 6 - 7 = 12 with n = 7。 先给证明,令 S(n) = 1 + 2 + 3 + 4 + 5 + .... + n 暴搜n,搜出当 S(n) >=

uva 11044 Searching for Nessy(小学数学)

题意是给出一个n*m的格子,求出里面有多少个不重合的九宫格。 (rows / 3) * (columns / 3) K.o 代码: #include <stdio.h>int main(){int ncase;scanf("%d", &ncase);while (ncase--){int rows, columns;scanf("%d%d", &rows, &col

【生成模型系列(初级)】嵌入(Embedding)方程——自然语言处理的数学灵魂【通俗理解】

【通俗理解】嵌入(Embedding)方程——自然语言处理的数学灵魂 关键词提炼 #嵌入方程 #自然语言处理 #词向量 #机器学习 #神经网络 #向量空间模型 #Siri #Google翻译 #AlexNet 第一节:嵌入方程的类比与核心概念【尽可能通俗】 嵌入方程可以被看作是自然语言处理中的“翻译机”,它将文本中的单词或短语转换成计算机能够理解的数学形式,即向量。 正如翻译机将一种语言

计算机毕业设计 大学志愿填报系统 Java+SpringBoot+Vue 前后端分离 文档报告 代码讲解 安装调试

🍊作者:计算机编程-吉哥 🍊简介:专业从事JavaWeb程序开发,微信小程序开发,定制化项目、 源码、代码讲解、文档撰写、ppt制作。做自己喜欢的事,生活就是快乐的。 🍊心愿:点赞 👍 收藏 ⭐评论 📝 🍅 文末获取源码联系 👇🏻 精彩专栏推荐订阅 👇🏻 不然下次找不到哟~Java毕业设计项目~热门选题推荐《1000套》 目录 1.技术选型 2.开发工具 3.功能

数论ZOJ 2562

题意:给定一个数N,求小于等于N的所有数当中,约数最多的一个数,如果存在多个这样的数,输出其中最大的一个。 分析:反素数定义:对于任何正整数x,其约数的个数记做g(x).例如g(1)=1,g(6)=4.如果某个正整数x满足:对于任意i(0<i<x),都有g(i)<g(x),则称x为反素数。 性质一:一个反素数的质因子必然是从2开始连续的质数。 性质二:p=2^t1*3^t2*5^t3*7