poj 3321 Apple Tree(树状数组+dfs)中等难度

2023-11-08 11:48

本文主要是介绍poj 3321 Apple Tree(树状数组+dfs)中等难度,希望对大家解决编程问题提供一定的参考价值,需要的开发者们随着小编来一起学习吧!

1、http://poj.org/problem?id=3321

2、题目大意:

有一棵树,有n个叉,由n-1条枝条连接,每个叉上最多有一个苹果,假设原来每个叉上都有苹果,现在要对这棵苹果树进行m个操作,其中这m个操作由两种操作组成,C x表示如果x点有苹果就摘掉,没有苹果就长一个,Q x是查询以x结点为根的树有多少个苹果,这道题目看上去好像是普通的树状数组的题目,但是没有顺序,我们需要先按照根搜索一遍,确定每棵子树的起始点和结束点,这样就可以转换成树状数组的题目了,

这道题目有个问题,用vector建树会超时,需要静态建树

3、题目:

Apple Tree
Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 17308 Accepted: 5255

Description

There is an apple tree outside of kaka's house. Every autumn, a lot of apples will grow in the tree. Kaka likes apple very much, so he has been carefully nurturing the big apple tree.

The tree has N forks which are connected by branches. Kaka numbers the forks by 1 to N and the root is always numbered by 1. Apples will grow on the forks and two apple won't grow on the same fork. kaka wants to know how many apples are there in a sub-tree, for his study of the produce ability of the apple tree.

The trouble is that a new apple may grow on an empty fork some time and kaka may pick an apple from the tree for his dessert. Can you help kaka?

Input

The first line contains an integer N (N ≤ 100,000) , which is the number of the forks in the tree.
The following N - 1 lines each contain two integers u and v, which means fork u and fork v are connected by a branch.
The next line contains an integer M (M ≤ 100,000).
The following M lines each contain a message which is either
"C x" which means the existence of the apple on fork x has been changed. i.e. if there is an apple on the fork, then Kaka pick it; otherwise a new apple has grown on the empty fork.
or
"Q x" which means an inquiry for the number of apples in the sub-tree above the fork x, including the apple (if exists) on the fork x
Note the tree is full of apples at the beginning

Output

For every inquiry, output the correspond answer per line.

Sample Input

3
1 2
1 3
3
Q 1
C 2
Q 1

Sample Output

3
2

Source

POJ Monthly--2007.08.05, Huang, Jinsong

 

4、Ac代码:

#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
#define N 100005
int s[N];
int e[N];
int cnt,n,edge=0;
int visit[N];
int c[N];
int v[N],next[N],head[N];
void add(int x,int y)
{v[edge]=y;next[edge]=head[x];head[x]=edge++;
}
void dfs(int u)
{s[u]=++cnt;for(int i=head[u];i!=-1;i=next[i]){int vv=v[i];dfs(vv);}e[u]=cnt;
}
int lowbit(int i)
{return i&(-i);
}
void update(int x,int v)
{for(int i=x; i<=n; i+=lowbit(i)){c[i]+=v;}
}
int getsum(int x)
{int sum=0;for(int i=x; i>0; i-=lowbit(i)){sum+=c[i];}return sum;
}
int main()
{int a,b,m;char ch[3];while(scanf("%d",&n)!=EOF){cnt=0;edge=0;memset(head,-1,sizeof(head));memset(c,0,sizeof(c));memset(visit,0,sizeof(visit));for(int i=1;i<=n;i++){update(i,1);}for(int i=1;i<n;i++){scanf("%d%d",&a,&b);add(a,b);}dfs(1);scanf("%d",&m);for(int i=1; i<=m; i++){scanf("%s%d",ch,&a);if(ch[0]=='Q'){int ans=getsum(e[a])-getsum(s[a]-1);printf("%d\n",ans);}else if(ch[0]=='C'){int v=s[a];if(visit[v]==1){update(v,1);visit[v]=0;}else{update(v,-1);visit[v]=1;}}}}return 0;
}
/*
3
1 2
1 3
3
Q 1
C 2
Q 3
3
1 2
1 3
3
Q 1
C 2
Q 1*/


 

链表建树的超时代码:

#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
#include<vector>
#define N 100005
vector<int> adj[N];
int s[N];
int e[N];
int cnt,n;
int visit[N];
int c[N];
void dfs(int v,int f)
{//printf("v=%d\n",v);s[v]=++cnt;for(int i=0; i<adj[v].size(); i++){int vv=adj[v][i];if(vv!=f)dfs(vv,v);}e[v]=cnt;return ;
}
int lowbit(int i)
{return i&(-i);
}
void update(int x,int v)
{for(int i=x; i<=n; i+=lowbit(i)){c[i]+=v;}
}
int getsum(int x)
{int sum=0;for(int i=x; i>0; i-=lowbit(i)){sum+=c[i];// printf("i=%d %d %d\n",i,c[i],sum);}return sum;
}
int main()
{int a,b,m;char ch[3];while(scanf("%d",&n)!=EOF){cnt=0;memset(c,0,sizeof(c));memset(visit,0,sizeof(visit));for(int i=0;i<=n;i++)adj[i].clear();for(int i=1; i<n; i++){scanf("%d%d",&a,&b);//printf("ab=%d %d \n",a,b);adj[a].push_back(b);adj[b].push_back(a);}memset(s,0,sizeof(s));memset(e,0,sizeof(e));dfs(1,-1);scanf("%d",&m);for(int i=1; i<=n; i++){update(i,1);}for(int i=1; i<=m; i++){scanf("%s%d",ch,&a);if(ch[0]=='Q'){//printf("a=%d\n",a);int ans=getsum(e[a])-getsum(s[a]-1);printf("%d\n",ans);}else if(ch[0]=='C'){int v=s[a];if(visit[v]==1){update(v,1);visit[v]=0;}else{update(v,-1);visit[v]=1;}}}}return 0;
}


 

这篇关于poj 3321 Apple Tree(树状数组+dfs)中等难度的文章就介绍到这儿,希望我们推荐的文章对编程师们有所帮助!



http://www.chinasem.cn/article/369648

相关文章

hdu2241(二分+合并数组)

题意:判断是否存在a+b+c = x,a,b,c分别属于集合A,B,C 如果用暴力会超时,所以这里用到了数组合并,将b,c数组合并成d,d数组存的是b,c数组元素的和,然后对d数组进行二分就可以了 代码如下(附注释): #include<iostream>#include<algorithm>#include<cstring>#include<stack>#include<que

poj 3974 and hdu 3068 最长回文串的O(n)解法(Manacher算法)

求一段字符串中的最长回文串。 因为数据量比较大,用原来的O(n^2)会爆。 小白上的O(n^2)解法代码:TLE啦~ #include<stdio.h>#include<string.h>const int Maxn = 1000000;char s[Maxn];int main(){char e[] = {"END"};while(scanf("%s", s) != EO

hdu 2602 and poj 3624(01背包)

01背包的模板题。 hdu2602代码: #include<stdio.h>#include<string.h>const int MaxN = 1001;int max(int a, int b){return a > b ? a : b;}int w[MaxN];int v[MaxN];int dp[MaxN];int main(){int T;int N, V;s

poj 1511 Invitation Cards(spfa最短路)

题意是给你点与点之间的距离,求来回到点1的最短路中的边权和。 因为边很大,不能用原来的dijkstra什么的,所以用spfa来做。并且注意要用long long int 来存储。 稍微改了一下学长的模板。 stack stl 实现代码: #include<stdio.h>#include<stack>using namespace std;const int M

poj 3259 uva 558 Wormholes(bellman最短路负权回路判断)

poj 3259: 题意:John的农场里n块地,m条路连接两块地,w个虫洞,虫洞是一条单向路,不但会把你传送到目的地,而且时间会倒退Ts。 任务是求你会不会在从某块地出发后又回来,看到了离开之前的自己。 判断树中是否存在负权回路就ok了。 bellman代码: #include<stdio.h>const int MaxN = 501;//农场数const int

poj 1258 Agri-Net(最小生成树模板代码)

感觉用这题来当模板更适合。 题意就是给你邻接矩阵求最小生成树啦。~ prim代码:效率很高。172k...0ms。 #include<stdio.h>#include<algorithm>using namespace std;const int MaxN = 101;const int INF = 0x3f3f3f3f;int g[MaxN][MaxN];int n

poj 1287 Networking(prim or kruscal最小生成树)

题意给你点与点间距离,求最小生成树。 注意点是,两点之间可能有不同的路,输入的时候选择最小的,和之前有道最短路WA的题目类似。 prim代码: #include<stdio.h>const int MaxN = 51;const int INF = 0x3f3f3f3f;int g[MaxN][MaxN];int P;int prim(){bool vis[MaxN];

poj 2349 Arctic Network uva 10369(prim or kruscal最小生成树)

题目很麻烦,因为不熟悉最小生成树的算法调试了好久。 感觉网上的题目解释都没说得很清楚,不适合新手。自己写一个。 题意:给你点的坐标,然后两点间可以有两种方式来通信:第一种是卫星通信,第二种是无线电通信。 卫星通信:任何两个有卫星频道的点间都可以直接建立连接,与点间的距离无关; 无线电通信:两个点之间的距离不能超过D,无线电收发器的功率越大,D越大,越昂贵。 计算无线电收发器D

poj 1502 MPI Maelstrom(单源最短路dijkstra)

题目真是长得头疼,好多生词,给跪。 没啥好说的,英语大水逼。 借助字典尝试翻译了一下,水逼直译求不喷 Description: BIT他们的超级计算机最近交货了。(定语秀了一堆词汇那就省略吧再见) Valentine McKee的研究顾问Jack Swigert,要她来测试一下这个系统。 Valentine告诉Swigert:“因为阿波罗是一个分布式共享内存的机器,所以它的内存访问

uva 10061 How many zero's and how many digits ?(不同进制阶乘末尾几个0)+poj 1401

题意是求在base进制下的 n!的结果有几位数,末尾有几个0。 想起刚开始的时候做的一道10进制下的n阶乘末尾有几个零,以及之前有做过的一道n阶乘的位数。 当时都是在10进制下的。 10进制下的做法是: 1. n阶位数:直接 lg(n!)就是得数的位数。 2. n阶末尾0的个数:由于2 * 5 将会在得数中以0的形式存在,所以计算2或者计算5,由于因子中出现5必然出现2,所以直接一