hdu 3251 Being a Hero

2023-11-08 11:32
文章标签 hdu hero 3251

本文主要是介绍hdu 3251 Being a Hero,希望对大家解决编程问题提供一定的参考价值,需要的开发者们随着小编来一起学习吧!

题目:

Being a Hero

Time Limit: 20000/10000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 678    Accepted Submission(s): 213
Special Judge


Problem Description
You are the hero who saved your country. As promised, the king will give you some cities of the country, and you can choose which ones to own!

But don't get too excited. The cities you take should NOT be reachable from the capital -- the king does not want to accidentally enter your area. In order to satisfy this condition, you have to destroy some roads. What's worse, you have to pay for that -- each road is associated with some positive cost. That is, your final income is the total value of the cities you take, minus the total cost of destroyed roads.

Note that each road is a unidirectional, i.e only one direction is available. Some cities are reserved for the king, so you cannot take any of them even if they're unreachable from the capital. The capital city is always the city number 1.

Input
The first line contains a single integer T (T <= 20), the number of test cases. Each case begins with three integers n, m, f (1 <= f < n <= 1000, 1 <= m < 100000), the number of cities, number of roads, and number of cities that you can take. Cities are numbered 1 to n. Each of the following m lines contains three integers u, v, w, denoting a road from city u to city v, with cost w. Each of the following f lines contains two integers u and w, denoting an available city u, with value w.

Output
For each test case, print the case number and the best final income in the first line. In the second line, print e, the number of roads you should destroy, followed by e integers, the IDs of the destroyed roads. Roads are numbered 1 to m in the same order they appear in the input. If there are more than one solution, any one will do.

Sample Input
  
2 4 4 2 1 2 2 1 3 3 3 2 4 2 4 1 2 3 4 4 4 4 2 1 2 2 1 3 3 3 2 1 2 4 1 2 3 4 4

Sample Output
  
Case 1: 3 1 4 Case 2: 4 2 1 3
代码:(只解决第一步)

#include<iostream>
#include<stdio.h>
#include<string.h>
using namespace std;
const int nMax = 2505;
const int INF = 0x7fffffff;
int queue[nMax];//建立层次图时使用到的队列
int dis[nMax];//各节点在层次图中对应的层次数
struct Edge//邻接表,包括:边的起点、边的权值、起点相同的下一条边
{int v, w, next;Edge() {}Edge(int v, int w, int next):v(v), w(w), next(next) {}
} adj[8 * nMax];
int V[nMax];//V[u]表示起点为u的第一条边,与Edge结合使用,从而实现邻接表的效果
int cnt;
int s, t;int min(int a, int b)
{return a < b ? a : b;
}void add(int u, int v, int w)//向邻接表中添加 u - > v 结构
{adj[cnt] = Edge(v, w, V[u]);V[u] = cnt ++;adj[cnt] = Edge(u, 0, V[v]);V[v] = cnt ++;
}int bfs()//建层次图
{int front, rear;int v;memset(dis, 0, sizeof(dis));front = rear = 0;dis[s] = 1;queue[front ++] = s;while(rear < front){int u = queue[rear ++];for(int i = V[u]; i != -1; i = adj[i].next)//与u相连的边if(adj[i].w && dis[v = adj[i].v] == 0)//可通行并且 v 之间没有被访问过{dis[v] = dis[u] + 1;if(v == t) return 1;queue[front ++] = v;}}return 0;
}int dfs(int u, int limit = INF)//返回从u出发到t,增广路经的最小边
{if(u == t) return limit;int count = 0;for(int i = V[u]; i != -1; i = adj[i].next)//与u 相连的边{int v = adj[i].v;if((dis[v] == dis[u] + 1) && adj[i].w)//根据层次的关系,找到的路径就为最短路径{int z = dfs(v, min(limit - count, adj[i].w));if(z > 0)//增广路经的最小边不为0,即v到t可通行{count += z;adj[i].w -= z;adj[i ^ 1].w += z;//改为adj[i + 1] += z  , 会超时!}elsedis[v] = -1;//效果等同于删除与v相关的所有边}}return count;
}
int dinic()
{int ans = 0;while(bfs())//直到搜索不到增广路经为止{int tt=dfs(s);ans += tt;}return ans;
}
void init()
{cnt = 0;memset(V, -1, sizeof(V));
}
int main()
{int T;int n,m,f;int uu,vv,ww;//freopen("F://ACMInput/input.txt","r",stdin);scanf("%d",&T);for(int k=1;k<=T;k++){scanf("%d%d%d",&n,&m,&f);init();for(int i=1;i<=m;i++){scanf("%d%d%d",&uu,&vv,&ww);add(uu,vv,ww);}int sum=0;for(int i=1;i<=f;i++){scanf("%d%d",&uu,&ww);sum+=ww;add(uu,n+1,ww);}s=1;t=n+1;int ss[1000];int ans=dinic();printf("Case %d: %d\n",k,sum-ans);}return 0;
}


这篇关于hdu 3251 Being a Hero的文章就介绍到这儿,希望我们推荐的文章对编程师们有所帮助!



http://www.chinasem.cn/article/369574

相关文章

usaco 1.3 Mixing Milk (结构体排序 qsort) and hdu 2020(sort)

到了这题学会了结构体排序 于是回去修改了 1.2 milking cows 的算法~ 结构体排序核心: 1.结构体定义 struct Milk{int price;int milks;}milk[5000]; 2.自定义的比较函数,若返回值为正,qsort 函数判定a>b ;为负,a<b;为0,a==b; int milkcmp(const void *va,c

poj 3974 and hdu 3068 最长回文串的O(n)解法(Manacher算法)

求一段字符串中的最长回文串。 因为数据量比较大,用原来的O(n^2)会爆。 小白上的O(n^2)解法代码:TLE啦~ #include<stdio.h>#include<string.h>const int Maxn = 1000000;char s[Maxn];int main(){char e[] = {"END"};while(scanf("%s", s) != EO

hdu 2093 考试排名(sscanf)

模拟题。 直接从教程里拉解析。 因为表格里的数据格式不统一。有时候有"()",有时候又没有。而它也不会给我们提示。 这种情况下,就只能它它们统一看作字符串来处理了。现在就请出我们的主角sscanf()! sscanf 语法: #include int sscanf( const char *buffer, const char *format, ... ); 函数sscanf()和

hdu 2602 and poj 3624(01背包)

01背包的模板题。 hdu2602代码: #include<stdio.h>#include<string.h>const int MaxN = 1001;int max(int a, int b){return a > b ? a : b;}int w[MaxN];int v[MaxN];int dp[MaxN];int main(){int T;int N, V;s

hdu 1754 I Hate It(线段树,单点更新,区间最值)

题意是求一个线段中的最大数。 线段树的模板题,试用了一下交大的模板。效率有点略低。 代码: #include <stdio.h>#include <string.h>#define TREE_SIZE (1 << (20))//const int TREE_SIZE = 200000 + 10;int max(int a, int b){return a > b ? a :

hdu 1166 敌兵布阵(树状数组 or 线段树)

题意是求一个线段的和,在线段上可以进行加减的修改。 树状数组的模板题。 代码: #include <stdio.h>#include <string.h>const int maxn = 50000 + 1;int c[maxn];int n;int lowbit(int x){return x & -x;}void add(int x, int num){while

hdu 3790 (单源最短路dijkstra)

题意: 每条边都有长度d 和花费p,给你起点s 终点t,要求输出起点到终点的最短距离及其花费,如果最短距离有多条路线,则输出花费最少的。 解析: 考察对dijkstra的理解。 代码: #include <iostream>#include <cstdio>#include <cstdlib>#include <algorithm>#include <cstrin

hdu 2489 (dfs枚举 + prim)

题意: 对于一棵顶点和边都有权值的树,使用下面的等式来计算Ratio 给定一个n 个顶点的完全图及它所有顶点和边的权值,找到一个该图含有m 个顶点的子图,并且让这个子图的Ratio 值在所有m 个顶点的树中最小。 解析: 因为数据量不大,先用dfs枚举搭配出m个子节点,算出点和,然后套个prim算出边和,每次比较大小即可。 dfs没有写好,A的老泪纵横。 错在把index在d

hdu 1102 uva 10397(最小生成树prim)

hdu 1102: 题意: 给一个邻接矩阵,给一些村庄间已经修的路,问最小生成树。 解析: 把已经修的路的权值改为0,套个prim()。 注意prim 最外层循坏为n-1。 代码: #include <iostream>#include <cstdio>#include <cstdlib>#include <algorithm>#include <cstri

hdu 1285(拓扑排序)

题意: 给各个队间的胜负关系,让排名次,名词相同按从小到大排。 解析: 拓扑排序是应用于有向无回路图(Direct Acyclic Graph,简称DAG)上的一种排序方式,对一个有向无回路图进行拓扑排序后,所有的顶点形成一个序列,对所有边(u,v),满足u 在v 的前面。该序列说明了顶点表示的事件或状态发生的整体顺序。比较经典的是在工程活动上,某些工程完成后,另一些工程才能继续,此时