ACM-ICPC2018 沈阳赛区网络预赛-D-Made In Heaven8

2023-11-08 06:21

本文主要是介绍ACM-ICPC2018 沈阳赛区网络预赛-D-Made In Heaven8,希望对大家解决编程问题提供一定的参考价值,需要的开发者们随着小编来一起学习吧!

A*算法:
A*,启发式搜索,是一种较为有效的搜索方法。
我们在搜索的时候,很多时候在当前状态,已经不是最优解了,但是我们却继续求解;这个就是暴力搜索浪费时间的原因。
我们在有些时候,往往可以根据一些信息推断出继续搜索是一种劣解。
所以如果能够判断出来的话,就可以不继续了,以达到节省运行时间的目的。
估价函数:
为了提高搜索效率,我们可以对未来可能产生的代价进行预估。我们设计一个估价函数,以任意状态输入,计算出从该状态到目标状态所需代价的估计值。
在搜索时,我们总沿着当前代价+未来估价最小的状态进行搜索。

估价函数需要满足:
  设当前状态state到目标函数所需代价的估计值为f(state)
  设在未来的搜索中,实际求出的从当前状态state到目标状态的最小代价为g(state)
  对于任意的state,应该有f(state)<=g(state)
也就是说,估价函数的估值不能大于未来实际代价,估价比实际代价更优。
第K短路:
根据估价函数的设计准则,在第K短路中从x到T的估计距离f(x)应该不大于第K短路中从x到T的实际距离g(x),于是,我们可以把估价函数f(x)定为从x到T的最短路径长度,这样不但能保证f(x)<=g(x),还能顺应g(x)的实际变化趋势。
实现过程:
1.预处理f(x),在反向图上以T为起点求到每个点的最短路
2.定义堆,维护{p,g,h},p是某一个点,g是估价,h是实际,那么g+h更小的点p会优先访问
3.取出堆顶元素u扩展,如果节点v被取出的次数尚未达到k,就把新的{v,g,h+length(u,v)}插入堆中
4.重复第2-3步,直到第K次取出终点T,此时走过的路径长度就是第K短路因为估价函数的作用,图中很多节点访问次数远小于K 

 

One day in the jail, F·F invites Jolyne Kujo (JOJO in brief) to play tennis with her. However, Pucci the father somehow knows it and wants to stop her. There are NN spots in the jail and MM roads connecting some of the spots. JOJO finds that Pucci knows the route of the former (K-1)(K1)-th shortest path. If Pucci spots JOJO in one of these K-1K1 routes, Pucci will use his stand Whitesnake and put the disk into JOJO's body, which means JOJO won't be able to make it to the destination. So, JOJO needs to take the KK-th quickest path to get to the destination. What's more, JOJO only has TT units of time, so she needs to hurry.

JOJO starts from spot SS, and the destination is numbered EE. It is possible that JOJO's path contains any spot more than one time. Please tell JOJO whether she can make arrive at the destination using no more than TT units of time.

Input

There are at most 5050 test cases.

The first line contains two integers NN and M(1 \leq N \leq 1000, 0 \leq M \leq 10000)(1N1000,0M10000). Stations are numbered from 11 to NN.

The second line contains four numbers S, E, KS,E,K and TT ( 1 \leq S,E \leq N1S,EN, S \neq ESE, 1 \leq K \leq 100001K10000, 1 \leq T \leq 1000000001T100000000 ).

Then MM lines follows, each line containing three numbers U, VU,V and W(1 \leq U,V \leq N, 1 \leq W \leq 1000)(1U,VN,1W1000) . It shows that there is a directed road from UU-th spot to VV-th spot with time WW.

It is guaranteed that for any two spots there will be only one directed road from spot AA to spot B(1 \leq A,B \leq N, A \neq B)(1A,BN,AB), but it is possible that both directed road <A,B><A,B> and directed road <B,A><B,A>exist.

All the test cases are generated randomly.

Output

One line containing a sentence. If it is possible for JOJO to arrive at the destination in time, output "yareyaredawa" (without quote), else output "Whitesnake!" (without quote).

样例输入

2 2

1 2 2 14

1 2 5

2 1 4

样例输出

yareyaredawa

#include <bits/stdc++.h>
using namespace std;
const int N=1005;
const int M=100005;
inline int read()
{int x=0,f=1;char ch=getchar();while (ch<'0' || ch>'9'){if (ch=='-') f=-1;ch=getchar();}while (ch>='0' && ch<='9'){x=x*10+ch-'0';ch=getchar();}return x*f;
}
int n,m,sta,en,kth,T,Ecnt,Eoppcnt;
int dist[N];
int times[N];
bool vis[N];
struct Edge{int to,next,val;}E[M],Eopp[M];//Eopp means Eopposite
int last[N],last_opp[N];
struct A_Star_node{int p,g,h;bool operator < (A_Star_node x)const{return x.g+x.h<g+h;}
};//means point  and a_Star:f(x)=g(x)+h(x);
priority_queue<A_Star_node>Q;
inline void add(int u,int v,int w)
{Ecnt++;E[Ecnt].next=last[u];E[Ecnt].to=v;E[Ecnt].val=w;last[u]=Ecnt;
}
inline void add_opposite(int u,int v,int w)
{Eoppcnt++;Eopp[Eoppcnt].next=last_opp[u];Eopp[Eoppcnt].to=v;Eopp[Eoppcnt].val=w;last_opp[u]=Eoppcnt;
}
void dij(int s,int e)
{memset(vis,0,sizeof(vis));memset(dist,127,sizeof(dist));int mi;dist[e]=0;for (int i=1;i<=n;i++){mi=0;for (int j=1;j<=n;j++)if (!vis[j] && dist[mi]>dist[j])    mi=j;vis[mi]=1;for (int x=last_opp[mi];x;x=Eopp[x].next)dist[Eopp[x].to]=min(dist[Eopp[x].to],dist[mi]+Eopp[x].val);}
}
int A_Star(int s,int e)
{A_Star_node t1,tmp;memset(times,0,sizeof(times));while (!Q.empty()) Q.pop();t1.g=t1.h=0; t1.p=s;Q.push(t1);while (!Q.empty()){t1=Q.top();    Q.pop();times[t1.p]++;if (times[t1.p]<=kth && t1.h>T) return -1;//K短路之前的路已经比要求的时间长了,一定是不合法的方案if (times[t1.p]==kth && t1.p==e) return t1.h;if (times[t1.p]>kth) continue;for (int i=last[t1.p];i;i=E[i].next){tmp.p=E[i].to;tmp.g=dist[E[i].to];tmp.h=E[i].val+t1.h;Q.push(tmp);}}return -1;
}
int main()
{while (scanf("%d%d",&n,&m)!=EOF){sta=read(); en=read(); kth=read(); T=read();int x,y,z;memset(last,0,sizeof(last));memset(last_opp,0,sizeof(last_opp));Ecnt=0;Eoppcnt=0;while (m--){x=read(); y=read(); z=read();add(x,y,z);add_opposite(y,x,z);}dij(sta,en);if (sta==en) kth++;int ans=A_Star(sta,en);if (ans==-1||ans>T) puts("Whitesnake!");else puts("yareyaredawa");}return 0;
}
View Code

 

转载于:https://www.cnblogs.com/tetew/p/9610212.html

这篇关于ACM-ICPC2018 沈阳赛区网络预赛-D-Made In Heaven8的文章就介绍到这儿,希望我们推荐的文章对编程师们有所帮助!



http://www.chinasem.cn/article/368333

相关文章

SSID究竟是什么? WiFi网络名称及工作方式解析

《SSID究竟是什么?WiFi网络名称及工作方式解析》SID可以看作是无线网络的名称,类似于有线网络中的网络名称或者路由器的名称,在无线网络中,设备通过SSID来识别和连接到特定的无线网络... 当提到 Wi-Fi 网络时,就避不开「SSID」这个术语。简单来说,SSID 就是 Wi-Fi 网络的名称。比如

Java实现任务管理器性能网络监控数据的方法详解

《Java实现任务管理器性能网络监控数据的方法详解》在现代操作系统中,任务管理器是一个非常重要的工具,用于监控和管理计算机的运行状态,包括CPU使用率、内存占用等,对于开发者和系统管理员来说,了解这些... 目录引言一、背景知识二、准备工作1. Maven依赖2. Gradle依赖三、代码实现四、代码详解五

认识、理解、分类——acm之搜索

普通搜索方法有两种:1、广度优先搜索;2、深度优先搜索; 更多搜索方法: 3、双向广度优先搜索; 4、启发式搜索(包括A*算法等); 搜索通常会用到的知识点:状态压缩(位压缩,利用hash思想压缩)。

Linux 网络编程 --- 应用层

一、自定义协议和序列化反序列化 代码: 序列化反序列化实现网络版本计算器 二、HTTP协议 1、谈两个简单的预备知识 https://www.baidu.com/ --- 域名 --- 域名解析 --- IP地址 http的端口号为80端口,https的端口号为443 url为统一资源定位符。CSDNhttps://mp.csdn.net/mp_blog/creation/editor

ASIO网络调试助手之一:简介

多年前,写过几篇《Boost.Asio C++网络编程》的学习文章,一直没机会实践。最近项目中用到了Asio,于是抽空写了个网络调试助手。 开发环境: Win10 Qt5.12.6 + Asio(standalone) + spdlog 支持协议: UDP + TCP Client + TCP Server 独立的Asio(http://www.think-async.com)只包含了头文件,不依

poj 3181 网络流,建图。

题意: 农夫约翰为他的牛准备了F种食物和D种饮料。 每头牛都有各自喜欢的食物和饮料,而每种食物和饮料都只能分配给一头牛。 问最多能有多少头牛可以同时得到喜欢的食物和饮料。 解析: 由于要同时得到喜欢的食物和饮料,所以网络流建图的时候要把牛拆点了。 如下建图: s -> 食物 -> 牛1 -> 牛2 -> 饮料 -> t 所以分配一下点: s  =  0, 牛1= 1~

poj 3068 有流量限制的最小费用网络流

题意: m条有向边连接了n个仓库,每条边都有一定费用。 将两种危险品从0运到n-1,除了起点和终点外,危险品不能放在一起,也不能走相同的路径。 求最小的费用是多少。 解析: 抽象出一个源点s一个汇点t,源点与0相连,费用为0,容量为2。 汇点与n - 1相连,费用为0,容量为2。 每条边之间也相连,费用为每条边的费用,容量为1。 建图完毕之后,求一条流量为2的最小费用流就行了

poj 2112 网络流+二分

题意: k台挤奶机,c头牛,每台挤奶机可以挤m头牛。 现在给出每只牛到挤奶机的距离矩阵,求最小化牛的最大路程。 解析: 最大值最小化,最小值最大化,用二分来做。 先求出两点之间的最短距离。 然后二分匹配牛到挤奶机的最大路程,匹配中的判断是在这个最大路程下,是否牛的数量达到c只。 如何求牛的数量呢,用网络流来做。 从源点到牛引一条容量为1的边,然后挤奶机到汇点引一条容量为m的边

配置InfiniBand (IB) 和 RDMA over Converged Ethernet (RoCE) 网络

配置InfiniBand (IB) 和 RDMA over Converged Ethernet (RoCE) 网络 服务器端配置 在服务器端,你需要确保安装了必要的驱动程序和软件包,并且正确配置了网络接口。 安装 OFED 首先,安装 Open Fabrics Enterprise Distribution (OFED),它包含了 InfiniBand 所需的驱动程序和库。 sudo

【机器学习】高斯网络的基本概念和应用领域

引言 高斯网络(Gaussian Network)通常指的是一个概率图模型,其中所有的随机变量(或节点)都遵循高斯分布 文章目录 引言一、高斯网络(Gaussian Network)1.1 高斯过程(Gaussian Process)1.2 高斯混合模型(Gaussian Mixture Model)1.3 应用1.4 总结 二、高斯网络的应用2.1 机器学习2.2 统计学2.3