本文主要是介绍POJ 1101 Sticks,希望对大家解决编程问题提供一定的参考价值,需要的开发者们随着小编来一起学习吧!
题目大意:输入N个数,表示以将若干个长度为L的木棒分为N个长度如下的小段,求最小的L。。。
Description
George took sticks of the same length and cut them randomly until all parts became at most 50 units long. Now he wants to return sticks to the original state, but he forgot how many sticks he had originally and how long they were originally. Please help him and design a program which computes the smallest possible original length of those sticks. All lengths expressed in units are integers greater than zero.
Input
The input contains blocks of 2 lines. The first line contains the number of sticks parts after cutting, there are at most 64 sticks. The second line contains the lengths of those parts separated by the space. The last line of the file contains zero.
Output
The output should contains the smallest possible length of original sticks, one per line.
Sample Input
9 5 2 1 5 2 1 5 2 1 4 1 2 3 4 0
Sample Output
6 5
/*其实dfs学的不是很好,这段代码还是看了北大讲座的ppt写的~这的一道经典的dfs,有不少的剪枝。。。*/
#include<stdio.h>
#include<string.h>
#include<algorithm>
#define M 100
using namespace std;
int n,Mlen,a[M],mark[M];
int cmp(int a,int b){
return a>b;
}
int dfs(int N,int now){
int i,j;
if(N==0 && now==0){
return 1;
}
if(now==0){
now=Mlen;
}
for(i=0;i<n;i++){
if(!mark[i] && a[i]<=now){
if(i>0){
if(!mark[i-1] && a[i-1]==a[i]) continue;//对于相等的就可以省去搜索
}
mark[i]=1;
if(dfs(N-1,now-a[i]))return 1;//dfs的还原。。。
else {
mark[i]=0;
if(a[i]==now || now==Mlen) return 0;
}
}
}
return 0;
}
int main(){
int i,j,sum;
while(scanf("%d",&n),n){
sum=0;
for(i=0;i<n;i++){
scanf("%d",&a[i]);
sum+=a[i];
}
sort(a,a+n,cmp);
for(i=a[0];i<=sum/2;i++){
if(sum%i==0){
for(j=0;j<n;j++){
mark[j]=0;
}
Mlen=i;
if(dfs(n,Mlen)){
printf("%d\n",Mlen);
break;
}
}
}
if(i>sum/2)printf("%d\n",sum);
}
return 0;
}
这篇关于POJ 1101 Sticks的文章就介绍到这儿,希望我们推荐的文章对编程师们有所帮助!