本文主要是介绍HLJUOJ1120(数学问题),希望对大家解决编程问题提供一定的参考价值,需要的开发者们随着小编来一起学习吧!
士兵报数
Submit: 59 Solved: 16
[ Submit][ Status][ Web Board]
Description
N个站成一列的士兵和一个整数M,士兵编号是1 --- N。每次士兵按编号从小到大的顺序依次报数,如果报的数不是M的倍数,则该士兵出列。这样重复几次直到剩下的士兵的数量小于M为止。问最后剩下的士兵有几个,他们的编号分别是多少。
Input
多组测试数据。
每组数据包含两个数N,M。
N<=1000000000
M<=1000
当n=0,m=0时结束
Output
每组测试数据输出两行。
第一行一个数t,代表剩下的士兵数。
第二行t个数,代表剩下的士兵的编号,升序排列。
Sample Input
10 3
8 3
0 0
Sample Output
1
9
2
3 6
解题思路:
这里题意补充下,数据保证n > m。不断地n / m,直到小于m为止。这时最后小于m的n为剩的人数。接下来我们需要关注最开始的那个人的编号,我们前面在出的时候记录做除法的次数,最开始的编号就是m ^ cnt,补充下,这里不要用pow,自己手动模拟下,不然100 50这组数据过不了。
完整代码:
#include <functional>
#include <algorithm>
#include <iostream>
#include <fstream>
#include <sstream>
#include <iomanip>
#include <numeric>
#include <cstring>
#include <climits>
#include <cassert>
#include <complex>
#include <cstdio>
#include <string>
#include <vector>
#include <bitset>
#include <queue>
#include <stack>
#include <cmath>
#include <ctime>
#include <list>
#include <set>
#include <map>
using namespace std;#pragma comment(linker, "/STACK:102400000,102400000")typedef long long LL;
typedef double DB;
typedef unsigned uint;
typedef unsigned long long uLL;/** Constant List .. **/ //{const int MOD = int(1e9)+7;
const int INF = 0x3f3f3f3f;
const LL INFF = 0x3f3f3f3f3f3f3f3fLL;
const DB EPS = 1e-9;
const DB OO = 1e20;
const DB PI = acos(-1.0); //M_PI;
const int maxn = 1000000001;
//int g[maxn];
//int s[maxn];int start;
int main()
{#ifdef DoubleQfreopen("in.txt","r",stdin);#endifint n , m;while(~scanf("%d%d",&n,&m)){if(n == 0 && m == 0)break;int temp = n;int cnt = 0;while(temp >= m){cnt++;temp /= m;}printf("%d\n" , temp % m);
/*int temp2=pow(m,cnt);cout << m << " " << cnt << " " << temp2<< endl;cout << temp2 <<endl;//cout << m << " " << cnt << " " << pow(m , cnt) << endl;
*/int temp2 = 1;for(int i = 0 ; i < cnt ; i ++)temp2 *= m;int temp3 = temp2;for(int i = 1 ; i <= temp % m ; i ++){if(i == 1){printf("%d" , temp2 );temp2 += temp3;}else{printf(" %d" , temp2);temp2 += temp3;}}printf("\n");// cout << endl;}
}
这篇关于HLJUOJ1120(数学问题)的文章就介绍到这儿,希望我们推荐的文章对编程师们有所帮助!