本文主要是介绍NYOJ 16 矩形嵌套,希望对大家解决编程问题提供一定的参考价值,需要的开发者们随着小编来一起学习吧!
OJ题目 : http://acm.nyist.net/JudgeOnline/problem.php?pid=16
描述
- 输入
- 第一行是一个正正数N(0<N<10),表示测试数据组数,
每组测试数据的第一行是一个正正数n,表示该组测试数据中含有矩形的个数(n<=1000)
随后的n行,每行有两个数a,b(0<a,b<100),表示矩形的长和宽 输出 - 每组测试数据都输出一个数,表示最多符合条件的矩形数目,每组输出占一行 样例输入
-
1 10 1 2 2 4 5 8 6 10 7 9 3 1 5 8 12 10 9 7 2 2
样例输出 -
5
//最长单调序列
#include <iostream>
#include <string>
#include <string.h>
#include <map>
#include <stdio.h>
#include <algorithm>
#include <queue>
#include <vector>
#include <math.h>
#include <set>
#define Max(a,b) ((a)>(b)?(a):(b))
#define Min(a,b) ((a)<(b)?(a):(b))
#define SWAP(a , b){ int temp = a; a = b; b = temp;}using namespace std;
int N;
int dp[1001];
struct rectangle
{int length;//长int width;//宽rectangle(){};rectangle(int x,int y):length(x),width(y){if(length < width)SWAP(length,width);}bool friend operator<(const rectangle & A,const rectangle & B){return (A.width < B.width && A.length < B.length);}
}rec[1001];int cmp(const rectangle & A , const rectangle & B)
{if(A.length == B.length)return A.width < B.width;elsereturn A.length < B.length;
}int solve()
{sort(rec + 1,rec + 1 + N , cmp);for(int i = 1;i <= N;i++){dp[i] = 1;for(int j = 1;j < i;j++){if(rec[j] < rec[i])dp[i] = Max(dp[i] , dp[j] + 1);}}return *max_element(dp + 1, dp + 1 + N);
}int main()
{int T;cin >> T;while(T--){memset(rec,0,sizeof(rec));memset(dp,-1,sizeof(dp));cin >> N;int a , b;for(int i = 1; i <= N;i++){cin >> a >> b;rec[i] = rectangle(a,b);}cout << solve() << endl;}return 0;
}
这篇关于NYOJ 16 矩形嵌套的文章就介绍到这儿,希望我们推荐的文章对编程师们有所帮助!