八数码问题——HDU 1043

2024-09-05 04:32
文章标签 hdu 1043 数码 问题

本文主要是介绍八数码问题——HDU 1043,希望对大家解决编程问题提供一定的参考价值,需要的开发者们随着小编来一起学习吧!

对应杭电题目: 点击打开链接


The 15-puzzle has been around for over 100 years; even if you don't know it by that name, you've seen it. It is constructed with 15 sliding tiles, each with a number from 1 to 15 on it, and all packed into a 4 by 4 frame with one tile missing. Let's call the missing tile 'x'; the object of the puzzle is to arrange the tiles so that they are ordered as:
 1  2  3  45  6  7  89 10 11 12
13 14 15  x

where the only legal operation is to exchange 'x' with one of the tiles with which it shares an edge. As an example, the following sequence of moves solves a slightly scrambled puzzle:
 1  2  3  4     1  2  3  4     1  2  3  4     1  2  3  45  6  7  8     5  6  7  8     5  6  7  8     5  6  7  89  x 10 12     9 10  x 12     9 10 11 12     9 10 11 12
13 14 11 15    13 14 11 15    13 14  x 15    13 14 15  xr->            d->            r->

The letters in the previous row indicate which neighbor of the 'x' tile is swapped with the 'x' tile at each step; legal values are 'r','l','u' and 'd', for right, left, up, and down, respectively.

Not all puzzles can be solved; in 1870, a man named Sam Loyd was famous for distributing an unsolvable version of the puzzle, and
frustrating many people. In fact, all you have to do to make a regular puzzle into an unsolvable one is to swap two tiles (not counting the missing 'x' tile, of course).

In this problem, you will write a program for solving the less well-known 8-puzzle, composed of tiles on a three by three
arrangement.

Input

You will receive, several descriptions of configuration of the 8 puzzle. One description is just a list of the tiles in their initial positions, with the rows listed from top to bottom, and the tiles listed from left to right within a row, where the tiles are represented by numbers 1 to 8, plus 'x'. For example, this puzzle

1 2 3
x 4 6
7 5 8

is described by this list:

1 2 3 x 4 6 7 5 8

Output

You will print to standard output either the word ``unsolvable'', if the puzzle has no solution, or a string consisting entirely of the letters 'r', 'l', 'u' and 'd' that describes a series of moves that produce a solution. The string should include no spaces and start at the beginning of the line. Do not print a blank line between cases.

Sample Input

    
2 3 4 1 5 x 7 6 8

Sample Output

    
ullddrurdllurdruldr
康拓展开判重,反向BFS
#include<cstdio>
#include<cstdlib>
#include<cmath>
#include<map>
#include<queue>
#include<stack>
#include<vector>
#include<algorithm>
#include<cstring>
#include<string>
#include<iostream>
const int MAXN=500000+10;
const int MAXNHASH=500000+10;
using namespace std;
typedef int State[9];
State st[MAXN];
int goal[9];
int vis[370000];
int fact[9];
int fa[MAXN];
int dir[MAXN];
int codestart,codeend;
const int dx[]={-1,1,0,0};
const int dy[]={0,0,-1,1};
char cal[5]="durl";void init_lookup_table()
{fact[0]=1;for(int i=1; i<9; i++){fact[i]=fact[i-1]*i;}
}int Code(State &s)
{int code=0;for(int i=0; i<9; i++){int cnt=0;for(int j=i+1; j<9; j++){if(s[j]<s[i]) cnt++; }code+=fact[8-i]*cnt;}return code;
}void bfs()
{memset(fa,0,sizeof(fa));memset(vis,0,sizeof(vis));int front=1, rear=2;while(front<rear){//cout<<front<<endl;State& s=st[front];//if(memcmp(goal, s, sizeof(s))==0) return front;int z;for(z=0; z<9; z++) if(!s[z]) break;int x=z/3, y=z%3;for(int i=0; i<4; i++){int newx=x+dx[i];int newy=y+dy[i];int newz=newx*3+newy;if(newx>=0 && newx<3 && newy>=0 && newy<3){State&t =st[rear];memcpy(t,s,sizeof(s));t[newz]=s[z];t[z]=s[newz];int code=Code(t);int code1=Code(s);if(!vis[code]){vis[code]=1;fa[code]=code1;dir[code]=i;rear++;}}}front++;}
}void print(int num)
{if(num!=codeend){cout<<cal[dir[num]];print(fa[num]);}
}int main()
{//freopen("in.txt","r",stdin);init_lookup_table();char ch;for(int i=0; i<8; i++) st[1][i]=i+1;st[1][8]=0;codeend=Code(st[1]);vis[codeend]=1;bfs();while(cin>>ch){if(ch=='x') goal[0]=ch-120;else goal[0]=ch-'0';for(int i=1; i<9; i++){cin>>ch;if(ch=='x') goal[i]=ch-120;else goal[i]=ch-'0';}codestart=Code(goal);if(vis[codestart]){print(codestart);cout<<endl;}else cout<<"unsolvable"<<endl;}return 0;
}


这篇关于八数码问题——HDU 1043的文章就介绍到这儿,希望我们推荐的文章对编程师们有所帮助!



http://www.chinasem.cn/article/1137952

相关文章

好题——hdu2522(小数问题:求1/n的第一个循环节)

好喜欢这题,第一次做小数问题,一开始真心没思路,然后参考了网上的一些资料。 知识点***********************************无限不循环小数即无理数,不能写作两整数之比*****************************(一开始没想到,小学没学好) 此题1/n肯定是一个有限循环小数,了解这些后就能做此题了。 按照除法的机制,用一个函数表示出来就可以了,代码如下

hdu1043(八数码问题,广搜 + hash(实现状态压缩) )

利用康拓展开将一个排列映射成一个自然数,然后就变成了普通的广搜题。 #include<iostream>#include<algorithm>#include<string>#include<stack>#include<queue>#include<map>#include<stdio.h>#include<stdlib.h>#include<ctype.h>#inclu

usaco 1.3 Mixing Milk (结构体排序 qsort) and hdu 2020(sort)

到了这题学会了结构体排序 于是回去修改了 1.2 milking cows 的算法~ 结构体排序核心: 1.结构体定义 struct Milk{int price;int milks;}milk[5000]; 2.自定义的比较函数,若返回值为正,qsort 函数判定a>b ;为负,a<b;为0,a==b; int milkcmp(const void *va,c

购买磨轮平衡机时应该注意什么问题和技巧

在购买磨轮平衡机时,您应该注意以下几个关键点: 平衡精度 平衡精度是衡量平衡机性能的核心指标,直接影响到不平衡量的检测与校准的准确性,从而决定磨轮的振动和噪声水平。高精度的平衡机能显著减少振动和噪声,提高磨削加工的精度。 转速范围 宽广的转速范围意味着平衡机能够处理更多种类的磨轮,适应不同的工作条件和规格要求。 振动监测能力 振动监测能力是评估平衡机性能的重要因素。通过传感器实时监

poj 3974 and hdu 3068 最长回文串的O(n)解法(Manacher算法)

求一段字符串中的最长回文串。 因为数据量比较大,用原来的O(n^2)会爆。 小白上的O(n^2)解法代码:TLE啦~ #include<stdio.h>#include<string.h>const int Maxn = 1000000;char s[Maxn];int main(){char e[] = {"END"};while(scanf("%s", s) != EO

hdu 2093 考试排名(sscanf)

模拟题。 直接从教程里拉解析。 因为表格里的数据格式不统一。有时候有"()",有时候又没有。而它也不会给我们提示。 这种情况下,就只能它它们统一看作字符串来处理了。现在就请出我们的主角sscanf()! sscanf 语法: #include int sscanf( const char *buffer, const char *format, ... ); 函数sscanf()和

hdu 2602 and poj 3624(01背包)

01背包的模板题。 hdu2602代码: #include<stdio.h>#include<string.h>const int MaxN = 1001;int max(int a, int b){return a > b ? a : b;}int w[MaxN];int v[MaxN];int dp[MaxN];int main(){int T;int N, V;s

hdu 1754 I Hate It(线段树,单点更新,区间最值)

题意是求一个线段中的最大数。 线段树的模板题,试用了一下交大的模板。效率有点略低。 代码: #include <stdio.h>#include <string.h>#define TREE_SIZE (1 << (20))//const int TREE_SIZE = 200000 + 10;int max(int a, int b){return a > b ? a :

hdu 1166 敌兵布阵(树状数组 or 线段树)

题意是求一个线段的和,在线段上可以进行加减的修改。 树状数组的模板题。 代码: #include <stdio.h>#include <string.h>const int maxn = 50000 + 1;int c[maxn];int n;int lowbit(int x){return x & -x;}void add(int x, int num){while

缓存雪崩问题

缓存雪崩是缓存中大量key失效后当高并发到来时导致大量请求到数据库,瞬间耗尽数据库资源,导致数据库无法使用。 解决方案: 1、使用锁进行控制 2、对同一类型信息的key设置不同的过期时间 3、缓存预热 1. 什么是缓存雪崩 缓存雪崩是指在短时间内,大量缓存数据同时失效,导致所有请求直接涌向数据库,瞬间增加数据库的负载压力,可能导致数据库性能下降甚至崩溃。这种情况往往发生在缓存中大量 k