本文主要是介绍SDUT2797_电影节(并查集)(模板),希望对大家解决编程问题提供一定的参考价值,需要的开发者们随着小编来一起学习吧!
电影节
Time Limit: 1000MS Memory limit: 65536K
题目描述
某届电影节评选电影,共有两部电影进入最后评选环节,有n名观众,每个人有一次投票的机会,每个人都按照规则投给其中一部电影。为了了解情况,记者随机询问了一些人,一共询问了m次,特别神奇的是,记者每次都询问两个人,而且这两个人都把票投给了同一部电影,观众编号为1~n。
输入
多组输入,每组第一行是两个整数n,m (2 <= n <=100000,0 <= m < n/2),接下来m行数据,表示m次询问,每行数据有两个整数a,b代表观众的编号(1 <= a,b <= n),观众a和观众b投票给了同一部电影,接下来一行是两个整数c,d(1 <= c,d <= n)。
输出
对于每一组输入,输出一行,如果观众c和观众d投票给同一部电影,输出”same”,如果不能确定,输出”not sure”。
示例输入
5 2 1 2 2 3 1 3 5 2 1 2 3 4 1 4 5 2 1 2 3 4 2 5
示例输出
same not sure not sure
解题报告
并查集学习,水题。。。
并查集模板
void bin(int x,int y)//并
{int xx=find(x);int yy=find(y);if(xx!=yy){B[xx]=yy;}
}
int find(int x)//查(路径压缩递归式)
{if(B[x]!=x){B[x]=find(B[x]);//递归容易栈溢出}return B[x];
}
int find(int x)//查(路径压缩非递归式)
{
int r=x,i=x,j;
while(B[r]!=r)
r=B[r];
while(i!=r)
{
j=B[i];
B[i]=r;
i=j;
}
return r;
}
int find(int x)//查(非路径压缩)
{int r=x;while(B[r]!=r){r=B[r];}return r;
}
#include <iostream>
#include <stdio.h>
using namespace std;
int B[200000];
int find(int x)
{if(B[x]!=x){B[x]=find(B[x]);}return B[x];
}
void bin(int x,int y)
{int xx=find(x);int yy=find(y);if(xx!=yy){B[xx]=yy;}
}
int main()
{int n,m;int i,j;int a,b;int c,d;while(~scanf("%d%d",&n,&m)){for(i=1;i<=n;i++)B[i]=i;for(i=1;i<=m;i++){scanf("%d%d",&a,&b);bin(a,b);}scanf("%d%d",&c,&d);if(find(c)==find(d))printf("same\n");else printf("not sure\n");}return 0;
}
这篇关于SDUT2797_电影节(并查集)(模板)的文章就介绍到这儿,希望我们推荐的文章对编程师们有所帮助!