本文主要是介绍2014.1.13 杭电习题 二维字符串中出现数量最多的字符串,希望对大家解决编程问题提供一定的参考价值,需要的开发者们随着小编来一起学习吧!
Let the Balloon Rise
Time Limit : 2000/1000ms (Java/Other) Memory Limit : 65536/32768K (Java/Other)
Total Submission(s) : 15 Accepted Submission(s) : 6
Font: Times New Roman | Verdana | Georgia
Font Size: ← →
Problem Description
Contest time again! How excited it is to see balloons floating around. But to tell you a secret, the judges' favorite time is guessing the most popular problem. When the contest is over, they will count the balloons of each color and find the result.
This year, they decide to leave this lovely job to you.
This year, they decide to leave this lovely job to you.
Input
Input contains multiple test cases. Each test case starts with a number N (0 < N <= 1000) -- the total number of balloons distributed. The next N lines contain one color each. The color of a balloon is a string of up to 15 lower-case letters.
A test case with N = 0 terminates the input and this test case is not to be processed.
A test case with N = 0 terminates the input and this test case is not to be processed.
Output
For each case, print the color of balloon for the most popular problem on a single line. It is guaranteed that there is a unique solution for each test case.
Sample Input
5 green red blue red red 3 pink orange pink 0
Sample Output
red pink
Author
Source
ZJCPC2004
#include<iostream>
using namespace std;
int main()
{
int n;
while(cin>>n&&n!=0)
{
char str[1000][100];
int i,j,max=0;
int k=0;
int c[1000]={0};
c[0]=1;
getchar();
for(i=0;i<n;i++)
{
gets(str[i]);
for(j=0;j<i;j++)
if(strcmp(str[i],str[j])==0) //比较两个字符串是否相等
c[j]++;
}
for(i=0;i<n;i++)
if(c[i]>max)
{
max=c[i];
k=i;
}
puts(str[k]);
}
return 0;
}
这篇关于2014.1.13 杭电习题 二维字符串中出现数量最多的字符串的文章就介绍到这儿,希望我们推荐的文章对编程师们有所帮助!