本文主要是介绍【加权并查集】【只需要写merge其他直接模板】,希望对大家解决编程问题提供一定的参考价值,需要的开发者们随着小编来一起学习吧!
Language: 食物链
Description 动物王国中有三类动物A,B,C,这三类动物的食物链构成了有趣的环形。A吃B, B吃C,C吃A。 现有N个动物,以1-N编号。每个动物都是A,B,C中的一种,但是我们并不知道它到底是哪一种。 有人用两种说法对这N个动物所构成的食物链关系进行描述: 第一种说法是"1 X Y",表示X和Y是同类。 第二种说法是"2 X Y",表示X吃Y。 此人对N个动物,用上述两种说法,一句接一句地说出K句话,这K句话有的是真的,有的是假的。当一句话满足下列三条之一时,这句话就是假话,否则就是真话。 1) 当前的话与前面的某些真的话冲突,就是假话; 2) 当前的话中X或Y比N大,就是假话; 3) 当前的话表示X吃X,就是假话。 你的任务是根据给定的N(1 <= N <= 50,000)和K句话(0 <= K <= 100,000),输出假话的总数。 Input 第一行是两个整数N和K,以一个空格分隔。 以下K行每行是三个正整数 D,X,Y,两数之间用一个空格隔开,其中D表示说法的种类。 若D=1,则表示X和Y是同类。 若D=2,则表示X吃Y。 Output 只有一个整数,表示假话的数目。 Sample Input 100 7 1 101 1 2 1 2 2 2 3 2 3 3 1 1 3 2 3 1 1 5 5 Sample Output 3 Source Noi 01 |
[Submit] [Go Back] [Status] [Discuss]
#include <iostream>
#include <cstring>
#include <cmath>
#include <queue>
#include <stack>
#include <list>
#include <map>
#include <set>
#include <string>
#include <cstdlib>
#include <cstdio>
#include <algorithm>
using namespace std;#define rep(i,a,n) for (int i=a;i<n;i++)
#define per(i,a,n) for (int i=n-1;i>=a;i--)
#define mp push_backint n,k;
const int maxn = 50100;
int F[maxn];
int r[maxn];
int find(int x)
{if(F[x] == -1) return x;int t = find(F[x]);r[x] = (r[x] + r[F[x]]) % 3;return F[x] = t;
}
void merge(int x,int y,int d)
{int fx = find(x);int fy = find(y);F[fy] = fx;r[fy] = (r[x] - r[y] + 3 + (d-1)) % 3;
}
int main()
{while(scanf("%d%d",&n,&k) != EOF){for(int i=1;i<=n;i++) F[i] = -1,r[i] = 0;int ans = 0;while(k--){int d,x,y;scanf("%d%d%d",&d,&x,&y);if(x > n || y >n || (d == 2 && x == y)){ans ++;continue;}int t1=find(x);int t2=find(y);if(t1 == t2){if(d == 1 && r[x] != r[y]) ans ++;if(d == 2 && (r[x] + 1) % 3 != r[y]) ans++;}else{merge(x,y,d);}}printf("%d\n",ans);}return 0;
}
这篇关于【加权并查集】【只需要写merge其他直接模板】的文章就介绍到这儿,希望我们推荐的文章对编程师们有所帮助!