本文主要是介绍Hdu 5323 2015多校对抗赛三,希望对大家解决编程问题提供一定的参考价值,需要的开发者们随着小编来一起学习吧!
Solve this interesting problem
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)Total Submission(s): 2029 Accepted Submission(s): 617
Problem Description
Have you learned something about segment tree? If not, don’t worry, I will explain it for you.
Segment Tree is a kind of binary tree, it can be defined as this:
- For each node u in Segment Tree, u has two values: Lu and Ru .
- If Lu=Ru , u is a leaf node.
- If Lu≠Ru , u has two children x and y,with Lx=Lu , Rx=⌊Lu+Ru2⌋ , Ly=⌊Lu+Ru2⌋+1 , Ry=Ru .
Here is an example of segment tree to do range query of sum.
Given two integers L and R, Your task is to find the minimum non-negative n satisfy that: A Segment Tree with root node's value Lroot=0 and Rroot=n contains a node u with Lu=L and Ru=R .
Segment Tree is a kind of binary tree, it can be defined as this:
- For each node u in Segment Tree, u has two values: Lu and Ru .
- If Lu=Ru , u is a leaf node.
- If Lu≠Ru , u has two children x and y,with Lx=Lu , Rx=⌊Lu+Ru2⌋ , Ly=⌊Lu+Ru2⌋+1 , Ry=Ru .
Here is an example of segment tree to do range query of sum.
Given two integers L and R, Your task is to find the minimum non-negative n satisfy that: A Segment Tree with root node's value Lroot=0 and Rroot=n contains a node u with Lu=L and Ru=R .
Input
The input consists of several test cases.
Each test case contains two integers L and R, as described above.
0≤L≤R≤109
LR−L+1≤2015
Each test case contains two integers L and R, as described above.
0≤L≤R≤109
LR−L+1≤2015
Output
For each test, output one line contains one integer. If there is no such n, just output -1.
Sample Input
6 7 10 13 10 11
Sample Output
7 -1 12
Author
ZSTU
给定一个区间 [l,r] ,求一个最小的线段树存在此区间节点,输出最小线段树大小即可。
暴力搜索,对于一个区间节点,他的父亲节点可能存在四种状态:
(l,2*r-l); (l,2*r-l+1);
(2*l-1-r,r); (2*l-2-r,r);
剪枝有:答案剪枝,区间可行性剪枝(线段树右节点长度不能大于左节点长度)
#include<iostream>
#include<cstdio>
#include<cmath>
#include<algorithm>
using namespace std;
#define LL long long
#define inf 1000000000000ll
LL ans;
void dfs(LL l,LL r)
{if(ans<=r)return;if(l==0) {if(ans>r)ans=r;return;}if(r-l+1>l) return;dfs(2*l-1-r,r);dfs(2*l-2-r,r);dfs(l,2*r-l);dfs(l,2*r-l+1);
}
int main()
{LL l,r;while(~scanf("%lld%lld",&l,&r)){ans = inf;dfs(l,r);if(ans == inf) puts("-1");else printf("%lld\n",ans);}
}
这篇关于Hdu 5323 2015多校对抗赛三的文章就介绍到这儿,希望我们推荐的文章对编程师们有所帮助!