hdu 5318 2015多校对抗赛三

2024-08-31 12:48
文章标签 2015 hdu 多校 对抗赛 5318

本文主要是介绍hdu 5318 2015多校对抗赛三,希望对大家解决编程问题提供一定的参考价值,需要的开发者们随着小编来一起学习吧!

The Goddess Of The Moon

Time Limit: 6000/3000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 842    Accepted Submission(s): 373


Problem Description
Chang’e (嫦娥) is a well-known character in Chinese ancient mythology. She’s the goddess of the Moon. There are many tales about Chang'e, but there's a well-known story regarding the origin of the Mid-Autumn Moon Festival. In a very distant past, ten suns had risen together to the heavens, thus causing hardship for the people. The archer Yi shot down nine of them and was given the elixir of immortality as a reward, but he did not consume it as he did not want to gain immortality without his beloved wife Chang'e. 



However, while Yi went out hunting, Fengmeng broke into his house and forced Chang'e to give up the elixir of immortality to him, but she refused to do so. Instead, Chang'e drank it and flew upwards towards the heavens, choosing the moon as residence to be nearby her beloved husband.



Yi discovered what had transpired and felt sad, so he displayed the fruits and cakes that his wife Chang'e had liked, and gave sacrifices to her. Now, let’s help Yi to the moon so that he can see his beloved wife. Imagine the earth is a point and the moon is also a point, there are n kinds of short chains in the earth, each chain is described as a number, we can also take it as a string, the quantity of each kind of chain is infinite. The only condition that a string A connect another string B is there is a suffix of A , equals a prefix of B, and the length of the suffix(prefix) must bigger than one(just make the joint more stable for security concern), Yi can connect some of the chains to make a long chain so that he can reach the moon, but before he connect the chains, he wonders that how many different long chains he can make if he choose m chains from the original chains.

Input
The first line is an integer T represent the number of test cases.
Each of the test case begins with two integers n, m. 
(n <= 50, m <= 1e9)
The following line contains n integer numbers describe the n kinds of chains.
All the Integers are less or equal than 1e9.

Output
Output the answer mod 1000000007.

Sample Input
  
2 10 50 12 1213 1212 1313231 12312413 12312 4123 1231 3 131 5 50 121 123 213 132 321

Sample Output
  
86814837 797922656
Hint
11 111 is different with 111 11

题意:有n段小梯子吧,要选m段组成一个大的长的梯子,问有多少种不同的选法。m的范围很大。

为了固定梯子,要求两段梯子要有至少2长的公共子串,A的后缀是B的前缀。那么长度为1的字段梯子都可以丢掉了。

坑点:输入有重复的梯子,需要去重。

做法:dp[m][i]表示长度为m,当前最后段为第i段字段的种数。那么转移方程为:

dp[m][i]=sigma( dp[m-1][j] ) 当i-j能连边

m的规模很大, 转移会T。

类似斐波那契数列第n项,可以用矩阵快速幂转移。

矩阵为各字段能否连接的关系

#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
#define LL long long
#define MOD 1000000007
struct duan{char name[100];
}p[60];
struct mtx{LL f[60][60];LL n;mtx(LL n_=0):n(n_){memset(f,0,sizeof f); }mtx operator * (mtx b){mtx c(n),a=*this;for(int i=0;i<n;i++)for(int j=0;j<n;j++){c.f[i][j]=0;for(int k=0;k<n;k++)c.f[i][j]=(c.f[i][j]+a.f[i][k]*b.f[k][j])%MOD;}return c;}mtx operator ^ (LL k){mtx c(n),a=*this;for(int i=0;i<n;i++)for(int j=0;j<n;j++)c.f[i][j]=i==j?1:0;while(k){if(k&1)c=c*a;a=a*a;k>>=1;}return c;}
};
char tmp1[100],tmp2[100];
bool judge(char *s1,char *s2){int len1=strlen(s1);int len2=strlen(s2);int len=min(len1,len2);int t=0;tmp1[t]=s1[--len1];tmp2[t]=s2[t++];while(t+1<=len){tmp1[t]=s1[--len1];tmp2[t]=s2[t++];bool eq=true;for(int i=0;i<t;i++){if(tmp1[t-1-i]!=tmp2[i]){eq=false;break;}}if(eq)return true;}return false;
}
int main(){
//    freopen("5318.in","r",stdin);
//    freopen("5318.out","w",stdout);int T;scanf("%d",&T);while(T--){LL n,m;scanf("%lld%lld",&n,&m);LL cnt=0;while(n--){scanf("%s",p[cnt].name);if(strlen(p[cnt].name)<=1)continue;bool have=false;for(int j=0;j<cnt;j++){if(strcmp(p[cnt].name,p[j].name)==0){have=true;break;}}if(have==false)cnt++;}n=cnt;mtx ans(n);for(int i=0;i<n;i++)for(int j=0;j<n;j++)if(judge(p[i].name,p[j].name))ans.f[i][j]=1;if(m<1){puts("0");continue; }ans=ans^(m-1);LL tot=0;for(int i=0;i<n;i++)for(int j=0;j<n;j++)tot=(tot+ans.f[i][j])%MOD;printf("%lld\n",tot);}return 0;
}



这篇关于hdu 5318 2015多校对抗赛三的文章就介绍到这儿,希望我们推荐的文章对编程师们有所帮助!



http://www.chinasem.cn/article/1123947

相关文章

usaco 1.3 Mixing Milk (结构体排序 qsort) and hdu 2020(sort)

到了这题学会了结构体排序 于是回去修改了 1.2 milking cows 的算法~ 结构体排序核心: 1.结构体定义 struct Milk{int price;int milks;}milk[5000]; 2.自定义的比较函数,若返回值为正,qsort 函数判定a>b ;为负,a<b;为0,a==b; int milkcmp(const void *va,c

poj 3974 and hdu 3068 最长回文串的O(n)解法(Manacher算法)

求一段字符串中的最长回文串。 因为数据量比较大,用原来的O(n^2)会爆。 小白上的O(n^2)解法代码:TLE啦~ #include<stdio.h>#include<string.h>const int Maxn = 1000000;char s[Maxn];int main(){char e[] = {"END"};while(scanf("%s", s) != EO

hdu 2093 考试排名(sscanf)

模拟题。 直接从教程里拉解析。 因为表格里的数据格式不统一。有时候有"()",有时候又没有。而它也不会给我们提示。 这种情况下,就只能它它们统一看作字符串来处理了。现在就请出我们的主角sscanf()! sscanf 语法: #include int sscanf( const char *buffer, const char *format, ... ); 函数sscanf()和

hdu 2602 and poj 3624(01背包)

01背包的模板题。 hdu2602代码: #include<stdio.h>#include<string.h>const int MaxN = 1001;int max(int a, int b){return a > b ? a : b;}int w[MaxN];int v[MaxN];int dp[MaxN];int main(){int T;int N, V;s

hdu 1754 I Hate It(线段树,单点更新,区间最值)

题意是求一个线段中的最大数。 线段树的模板题,试用了一下交大的模板。效率有点略低。 代码: #include <stdio.h>#include <string.h>#define TREE_SIZE (1 << (20))//const int TREE_SIZE = 200000 + 10;int max(int a, int b){return a > b ? a :

hdu 1166 敌兵布阵(树状数组 or 线段树)

题意是求一个线段的和,在线段上可以进行加减的修改。 树状数组的模板题。 代码: #include <stdio.h>#include <string.h>const int maxn = 50000 + 1;int c[maxn];int n;int lowbit(int x){return x & -x;}void add(int x, int num){while

hdu 3790 (单源最短路dijkstra)

题意: 每条边都有长度d 和花费p,给你起点s 终点t,要求输出起点到终点的最短距离及其花费,如果最短距离有多条路线,则输出花费最少的。 解析: 考察对dijkstra的理解。 代码: #include <iostream>#include <cstdio>#include <cstdlib>#include <algorithm>#include <cstrin

hdu 2489 (dfs枚举 + prim)

题意: 对于一棵顶点和边都有权值的树,使用下面的等式来计算Ratio 给定一个n 个顶点的完全图及它所有顶点和边的权值,找到一个该图含有m 个顶点的子图,并且让这个子图的Ratio 值在所有m 个顶点的树中最小。 解析: 因为数据量不大,先用dfs枚举搭配出m个子节点,算出点和,然后套个prim算出边和,每次比较大小即可。 dfs没有写好,A的老泪纵横。 错在把index在d

hdu 1102 uva 10397(最小生成树prim)

hdu 1102: 题意: 给一个邻接矩阵,给一些村庄间已经修的路,问最小生成树。 解析: 把已经修的路的权值改为0,套个prim()。 注意prim 最外层循坏为n-1。 代码: #include <iostream>#include <cstdio>#include <cstdlib>#include <algorithm>#include <cstri

hdu 1285(拓扑排序)

题意: 给各个队间的胜负关系,让排名次,名词相同按从小到大排。 解析: 拓扑排序是应用于有向无回路图(Direct Acyclic Graph,简称DAG)上的一种排序方式,对一个有向无回路图进行拓扑排序后,所有的顶点形成一个序列,对所有边(u,v),满足u 在v 的前面。该序列说明了顶点表示的事件或状态发生的整体顺序。比较经典的是在工程活动上,某些工程完成后,另一些工程才能继续,此时