本文主要是介绍1012. The Best Rank (25)暴力枚举 排序,希望对大家解决编程问题提供一定的参考价值,需要的开发者们随着小编来一起学习吧!
1012. The Best Rank (25)
To evaluate the performance of our first year CS majored students, we consider their grades of three courses only: C - C Programming Language, M - Mathematics (Calculus or Linear Algebra), and E - English. At the mean time, we encourage students by emphasizing on their best ranks -- that is, among the four ranks with respect to the three courses and the average grade, we print the best rank for each student.
For example, The grades of C, M, E and A - Average of 4 students are given as the following:
StudentID C M E A 310101 98 85 88 90 310102 70 95 88 84 310103 82 87 94 88 310104 91 91 91 91
Then the best ranks for all the students are No.1 since the 1st one has done the best in C Programming Language, while the 2nd one in Mathematics, the 3rd one in English, and the last one in average.
Input
Each input file contains one test case. Each case starts with a line containing 2 numbers N and M (<=2000), which are the total number of students, and the number of students who would check their ranks, respectively. Then N lines follow, each contains a student ID which is a string of 6 digits, followed by the three integer grades (in the range of [0, 100]) of that student in the order of C, M and E. Then there are M lines, each containing a student ID.
Output
For each of the M students, print in one line the best rank for him/her, and the symbol of the corresponding rank, separated by a space.
The priorities of the ranking methods are ordered as A > C > M > E. Hence if there are two or more ways for a student to obtain the same best rank, output the one with the highest priority.
If a student is not on the grading list, simply output "N/A".
Sample Input5 6 310101 98 85 88 310102 70 95 88 310103 82 87 94 310104 91 91 91 310105 85 90 90 310101 310102 310103 310104 310105 999999Sample Output
1 C 1 M 1 E 1 A 3 A N/A
提交代码
#include<cstdio>
#include<iostream>
#include<algorithm>
#include<cstring>
#include<string>
#include<cmath>
#include<stack>
using namespace std;
typedef long long ll;
const int maxn=1000001;
const int inf=9999;
int C[maxn];
int M[maxn];
int E[maxn];
double avg[maxn];
int n,m;
int minid=99999999,maxid=0;
void solve(int id,char&c,int &rank)
{int numA=1,numC=1,numM=1,numE=1;//假设当前排在第一 ,那么有比他大的,名次就加一for(int i=minid;i<=maxid;i++)if(i!=id&&avg[i]>avg[id])numA++;for(int i=minid;i<=maxid;i++)if(i!=id&&C[i]>C[id])numC++;for(int i=minid;i<=maxid;i++)if(i!=id&&M[i]>M[id])numM++;for(int i=minid;i<=maxid;i++)if(i!=id&&E[i]>E[id])numE++;if(numA<=numC&&numA<=numM&&numA<=numE){rank=numA;c='A';}else if(numC<=numA&&numC<=numM&&numC<=numE){rank=numC;c='C';}else if(numM<=numA&&numM<=numC&&numM<=numE){rank=numM;c='M';}else if(numE<=numA&&numE<=numC&&numE<=numM){rank=numE;c='E';}//printf("(((%d %c)))\n",rank,c);
}int main()
{int i,j,k,t;scanf("%d%d",&n,&m);for(i=0;i<n;i++){int id;scanf("%d",&id);minid=min(id,minid);maxid=max(id,maxid);scanf("%d%d%d",&C[id],&M[id],&E[id]);avg[id]=(C[id]+M[id]+E[id])*1.0/3.0;}for(i=0;i<m;i++){int id;scanf("%d",&id);if(id<minid||id>maxid){printf("N/A\n");continue;}char c=NULL;int rank0;solve(id,c,rank0);printf("%d %c\n",rank0,c);}return 0;
}
这篇关于1012. The Best Rank (25)暴力枚举 排序的文章就介绍到这儿,希望我们推荐的文章对编程师们有所帮助!