本文主要是介绍Rikka with string BC#37,希望对大家解决编程问题提供一定的参考价值,需要的开发者们随着小编来一起学习吧!
Rikka with string
Accepts: 395
Submissions: 2281Time Limit: 2000/1000 MS (Java/Others)
Memory Limit: 65536/65536 K (Java/Others)
问题描述
众所周知,萌萌哒六花不擅长数学,所以勇太给了她一些数学问题做练习,其中有一道是这样的:
有一天勇太得到了一个长度为n的字符串,但是六花一不小心把这个字符串搞丢了。于是他们想要复原这一个字符串。勇太记得这个字符串只包含小写字母而且这个串不是回文串。然而不幸的是他已经不记得这个字符串中的一些字符了,你可以帮他复原这个字符串吗?
当然,这个问题对于萌萌哒六花来说实在是太难了,你可以帮帮她吗?
输入描述
多组数据,数据组数不超过20,每组数据第一行两个正整数n。接下来一行一个长度为n的只包含小写字母和’?’的字符串,’?’表示勇太已经忘了这一个位置的字符了。
1≤n≤103
输出描述
每组数据输出仅一行一个长度为n的仅包含小写字母的字符串,如果有多种合法解,请输出字典序最小的,如果无解,请输出”QwQ”
输入样例
5
a?bb?
3
aaa
输出样例
aabba
QwQ
//#include<bits/stdc++.h>
#include<iostream>
#include<cstdio>
#include<algorithm>
#include<cmath>
#include<string>
#include<queue>
#include<vector>
#include<map>
#include<cstdlib>
#include<set>
#include<stack>
#include<cstring>
using namespace std;
template<class T>inline T read(T&x)
{char c;while((c=getchar())<=32)if(c==EOF)return 0;bool ok=false;if(c=='-')ok=true,c=getchar();for(x=0; c>32; c=getchar())x=x*10+c-'0';if(ok)x=-x;return 1;
}
template<class T> inline T read_(T&x,T&y)
{return read(x)&&read(y);
}
template<class T> inline T read__(T&x,T&y,T&z)
{return read(x)&&read(y)&&read(z);
}
template<class T> inline void write(T x)
{if(x<0)putchar('-'),x=-x;if(x<10)putchar(x+'0');else write(x/10),putchar(x%10+'0');
}
template<class T>inline void writeln(T x)
{write(x);putchar('\n');
}
//-------ZCC IO template------
const int maxn=100001;
const double inf=999999999;
#define lson (rt<<1),L,M
#define rson (rt<<1|1),M+1,R
#define M ((L+R)>>1)
#define For(i,t,n) for(int i=(t);i<(n);i++)
typedef long long LL;
typedef double DB;
typedef pair<int,int> P;
#define bug printf("---\n");
#define mod 10007
int n;
char a[maxn];
bool pan(char *s)
{for(int i=0; i<=n/2; i++){if(a[i]!=a[n-1-i])return true;}return false;
}int b[maxn];int main()
{
// #ifndef ONLINE_JUDGE
// freopen("in.txt","r",stdin);
// #endif // ONLINE_JUDGEint m,i,j,k,t;while(read(n)){scanf("%s",a);memset(b,0,sizeof(b));bool flag=false;for(i=0,j=0; i<n; i++)if(a[i]=='?'){flag=true;b[j++]=i;}if((!flag&&!pan(a))||(!pan(a)&&n%2==1&&a[n/2]=='?'&&j==1)){puts("QwQ");}else{bool ok=false;for(i=0;i<n;i++)if(a[i]=='?')a[i]='a';for(i=j-1; i>=0; i--){for(char k='a'; k<='z'; k++){a[b[i]]=k;if(pan(a)){ok=true;break;}}if(ok)break;elsea[b[i]]='a';}puts(a);}}return 0;
}
这篇关于Rikka with string BC#37的文章就介绍到这儿,希望我们推荐的文章对编程师们有所帮助!