hdu 2473 Junk-Mail Filter 并查集 删除点

2024-08-28 17:18

本文主要是介绍hdu 2473 Junk-Mail Filter 并查集 删除点,希望对大家解决编程问题提供一定的参考价值,需要的开发者们随着小编来一起学习吧!

题意:
有n封邮件现在要将其含有相同的特征的放在一起,
M X Y代表X,Y具有相同的特征,S Y代表Y被错判了
现在问你这两种操作完成后还有多少种的信,注意
特征可以传递 X Y 有相同特征Y Z有相同的特征,则
X Y Z同时具有相同的特征。如果X Y Z中有一个被
误判这剩下的两个仍然具有相同的特征。

Description

Recognizing junk mails is a tough task. The method used here consists of two steps: 
1) Extract the common characteristics from the incoming email. 
2) Use a filter matching the set of common characteristics extracted to determine whether the email is a spam. 

We want to extract the set of common characteristics from the N sample junk emails available at the moment, and thus having a handy data-analyzing tool would be helpful. The tool should support the following kinds of operations: 

a) “M X Y”, meaning that we think that the characteristics of spam X and Y are the same. Note that the relationship defined here is transitive, so 
relationships (other than the one between X and Y) need to be created if they are not present at the moment. 

b) “S X”, meaning that we think spam X had been misidentified. Your tool should remove all relationships that spam X has when this command is received; after that, spam X will become an isolated node in the relationship graph. 

Initially no relationships exist between any pair of the junk emails, so the number of distinct characteristics at that time is N. 
Please help us keep track of any necessary information to solve our problem.

Input

There are multiple test cases in the input file. 
Each test case starts with two integers, N and M (1 ≤ N ≤ 10  5 , 1 ≤ M ≤ 10  6), the number of email samples and the number of operations. M lines follow, each line is one of the two formats described above. 
Two successive test cases are separated by a blank line. A case with N = 0 and M = 0 indicates the end of the input file, and should not be processed by your program.

Output

For each test case, please print a single integer, the number of distinct common characteristics, to the console. Follow the format as indicated in the sample below.

Sample Input

       
5 6 M 0 1 M 1 2 M 1 3 S 1 M 1 2 S 33 1 M 1 20 0

Sample Output

       
Case #1: 3 Case #2: 2

#include <iostream>
#include <cstdio>
#include <string>
#include <cstring>
#include <algorithm>
using namespace std;
int set[1000001],rank[1000001],v1[1000001];
int find(int x)
{if(set[x]!=x){set[x]=find(set[x]);}return set[x];
}
void get(int x,int y)
{int xx=find(x);int yy=find(y);if(xx!=yy){set[xx]=yy;rank[yy]+=rank[xx];rank[xx]=0;}
}
int main()
{int n,m;char ch;int u,v;int Case=1;while(~scanf("%d %d",&n,&m),n||m){int num=n;int s=0;for(int i=0; i<n; i++){set[i]=i;v1[i]=i;rank[i]=1;}while(m--){getchar();scanf("%c",&ch);if(ch=='M'){scanf("%d %d",&u,&v);get(v1[u],v1[v]);}else{scanf("%d",&u);int xx=find(v1[u]);rank[xx]--;rank[num]=1;v1[u]=num;set[num]=num++;}}for(int i=0; i<num; i++)if(rank[i]>0)s++;printf("Case #%d: %d\n",Case++,s);}return 0;
}

第一次接触并查集删除的题目看了别人的代码才懂得

因为并查集是树形结构,所以无法简单的把一个节点从一棵树中删去并维护原来的信息。那这里用到的思想就是还是保持原来的树的结构不变,只是把被删掉的那个点设为虚点,并新建一个点,把原来的点映射到这个新点上,代表以后的操作都是对这个新点进行操作。这样空间开销虽然大,但还是可以解决问题的。

#include<cstdio>
#include<iostream>
#include<algorithm>
#include<cstring>
using namespace std;
int rank[20000],v[22000],set[20000];
int find(int x)
{int y=set[x];if(set[x]!=x){set[x]=find(set[x]);rank[x]+=rank[y];}return set[x];
}
void get(int x,int y)
{int xx=find(x);int yy=find(y);if(xx!=yy){set[xx]=yy;rank[yy]+=rank[yy];rank[xx]=0;}
}
int main()
{int n,m;char ch;int a,b;int Case=1,s;while(~scanf("%d %d",&n,&m),n||m){int num=n;s=0;for(int i=0; i<=n; i++){set[i]=i;v[i]=i;rank[i]=1;}while(m--){getchar();scanf("%c",&ch);if(ch=='M'){scanf("%d %d",&a,&b);get(v[a],v[b]);}else{scanf("%d",&a);int xx=find(v[a]);rank[v[a]]=0;rank[xx]--;rank[num]=1;v[a]=num;set[num]=num++;}}for(int i=0; i<num; i++)if(rank[i]>0)s++;printf("Case #%d: %d\n",Case++,s);}
}


这篇关于hdu 2473 Junk-Mail Filter 并查集 删除点的文章就介绍到这儿,希望我们推荐的文章对编程师们有所帮助!



http://www.chinasem.cn/article/1115386

相关文章

redis过期key的删除策略介绍

《redis过期key的删除策略介绍》:本文主要介绍redis过期key的删除策略,具有很好的参考价值,希望对大家有所帮助,如有错误或未考虑完全的地方,望不吝赐教... 目录第一种策略:被动删除第二种策略:定期删除第三种策略:强制删除关于big key的清理UNLINK命令FLUSHALL/FLUSHDB命

springboot filter实现请求响应全链路拦截

《springbootfilter实现请求响应全链路拦截》这篇文章主要为大家详细介绍了SpringBoot如何结合Filter同时拦截请求和响应,从而实现​​日志采集自动化,感兴趣的小伙伴可以跟随小... 目录一、为什么你需要这个过滤器?​​​二、核心实现:一个Filter搞定双向数据流​​​​三、完整代码

使用C#代码在PDF文档中添加、删除和替换图片

《使用C#代码在PDF文档中添加、删除和替换图片》在当今数字化文档处理场景中,动态操作PDF文档中的图像已成为企业级应用开发的核心需求之一,本文将介绍如何在.NET平台使用C#代码在PDF文档中添加、... 目录引言用C#添加图片到PDF文档用C#删除PDF文档中的图片用C#替换PDF文档中的图片引言在当

macOS无效Launchpad图标轻松删除的4 种实用方法

《macOS无效Launchpad图标轻松删除的4种实用方法》mac中不在appstore上下载的应用经常在删除后它的图标还残留在launchpad中,并且长按图标也不会出现删除符号,下面解决这个问... 在 MACOS 上,Launchpad(也就是「启动台」)是一个便捷的 App 启动工具。但有时候,应

Mysql删除几亿条数据表中的部分数据的方法实现

《Mysql删除几亿条数据表中的部分数据的方法实现》在MySQL中删除一个大表中的数据时,需要特别注意操作的性能和对系统的影响,本文主要介绍了Mysql删除几亿条数据表中的部分数据的方法实现,具有一定... 目录1、需求2、方案1. 使用 DELETE 语句分批删除2. 使用 INPLACE ALTER T

C++从序列容器中删除元素的四种方法

《C++从序列容器中删除元素的四种方法》删除元素的方法在序列容器和关联容器之间是非常不同的,在序列容器中,vector和string是最常用的,但这里也会介绍deque和list以供全面了解,尽管在一... 目录一、简介二、移除给定位置的元素三、移除与某个值相等的元素3.1、序列容器vector、deque

C++原地删除有序数组重复项的N种方法

《C++原地删除有序数组重复项的N种方法》给定一个排序数组,你需要在原地删除重复出现的元素,使得每个元素只出现一次,返回移除后数组的新长度,不要使用额外的数组空间,你必须在原地修改输入数组并在使用O(... 目录一、问题二、问题分析三、算法实现四、问题变体:最多保留两次五、分析和代码实现5.1、问题分析5.

SQL Server清除日志文件ERRORLOG和删除tempdb.mdf

《SQLServer清除日志文件ERRORLOG和删除tempdb.mdf》数据库再使用一段时间后,日志文件会增大,特别是在磁盘容量不足的情况下,更是需要缩减,以下为缩减方法:如果可以停止SQLSe... 目录缩减 ERRORLOG 文件(停止服务后)停止 SQL Server 服务:找到错误日志文件:删除

mysql删除无用用户的方法实现

《mysql删除无用用户的方法实现》本文主要介绍了mysql删除无用用户的方法实现,文中通过示例代码介绍的非常详细,对大家的学习或者工作具有一定的参考学习价值,需要的朋友们下面随着小编来一起学习学习吧... 1、删除不用的账户(1) 查看当前已存在账户mysql> select user,host,pa

Spring Boot拦截器Interceptor与过滤器Filter详细教程(示例详解)

《SpringBoot拦截器Interceptor与过滤器Filter详细教程(示例详解)》本文详细介绍了SpringBoot中的拦截器(Interceptor)和过滤器(Filter),包括它们的... 目录Spring Boot拦截器(Interceptor)与过滤器(Filter)详细教程1. 概述1