HDU 2962 Trucking

2024-08-28 07:48
文章标签 hdu 2962 trucking

本文主要是介绍HDU 2962 Trucking,希望对大家解决编程问题提供一定的参考价值,需要的开发者们随着小编来一起学习吧!

http://acm.hdu.edu.cn/showproblem.php?pid=2962   我醉了  一定要二分h吗

Trucking

Time Limit: 20000/10000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 1938    Accepted Submission(s): 670


Problem Description
A certain local trucking company would like to transport some goods on a cargo truck from one place to another. It is desirable to transport as much goods as possible each trip. Unfortunately, one cannot always use the roads in the shortest route: some roads may have obstacles (e.g. bridge overpass, tunnels) which limit heights of the goods transported. Therefore, the company would like to transport as much as possible each trip, and then choose the shortest route that can be used to transport that amount.

For the given cargo truck, maximizing the height of the goods transported is equivalent to maximizing the amount of goods transported. For safety reasons, there is a certain height limit for the cargo truck which cannot be exceeded.

Input
The input consists of a number of cases. Each case starts with two integers, separated by a space, on a line. These two integers are the number of cities (C) and the number of roads (R). There are at most 1000 cities, numbered from 1. This is followed by R lines each containing the city numbers of the cities connected by that road, the maximum height allowed on that road, and the length of that road. The maximum height for each road is a positive integer, except that a height of -1 indicates that there is no height limit on that road. The length of each road is a positive integer at most 1000. Every road can be travelled in both directions, and there is at most one road connecting each distinct pair of cities. Finally, the last line of each case consists of the start and end city numbers, as well as the height limit (a positive integer) of the cargo truck. The input terminates when C = R = 0.

Output
For each case, print the case number followed by the maximum height of the cargo truck allowed and the length of the shortest route. Use the format as shown in the sample output. If it is not possible to reach the end city from the start city, print "cannot reach destination" after the case number. Print a blank line between the output of the cases.

Sample Input
    
5 6 1 2 7 5 1 3 4 2 2 4 -1 10 2 5 2 4 3 4 10 1 4 5 8 5 1 5 10 5 6 1 2 7 5 1 3 4 2 2 4 -1 10 2 5 2 4 3 4 10 1 4 5 8 5 1 5 4 3 1 1 2 -1 100 1 3 10 0 0

Sample Output
    
Case 1: maximum height = 7 length of shortest route = 20Case 2: maximum height = 4 length of shortest route = 8Case 3: cannot reach destination

Source
2008 Rocky Mountain Regional

Recommend
gaojie   |   We have carefully selected several similar problems for you:   2722  1690  1598  1217  1142 
题目大意:给c个城市r条路,r个描述。每个描述包括,起点 终点 高度 距离。要求在高度h限制内,的最大高度(此最大高度为起点到终点的所有路径中高度的最小值),并求最出短路径。
思路:二分枚举1~h,在limit的限制下求最短路。用spfa代码如下

#include<iostream>
#include<cstring>
#include<algorithm>
#include<cstdlib>
#include<vector>
#include<cmath>
#include<stdlib.h>
#include<iomanip>
#include<list>
#include<deque>
#include<map>
#include <stdio.h>
#include <queue>

#define maxn 1000+5
#define ull unsigned long long
#define ll long long
#define reP(i,n) for(i=1;i<=n;i++)
#define rep(i,n) for(i=0;i<n;i++)
#define cle(a) memset(a,0,sizeof(a))
#define mod 90001
#define PI 3.141592657
#define INF 1<<30
const ull inf = 1LL << 61;
const double eps=1e-5;
const int maxm=1005*1005/2;
using namespace std;

bool cmp(int a,int b){
return a>b;
}
int n,m;
int pre[maxn];
struct node
{
int next,v,hight,w;
}edge[maxm];
int vis[maxn];
int dist[maxn];
int h;
void init()
{
int i,x,y,w,hight1;
memset(pre,-1,sizeof(pre));
int Index=1;
for(i=1;i<=m;i++)
{
scanf("%d%d%d%d",&x,&y,&hight1,&w);
if(hight1!=-1)hight1=hight1;
else hight1=INF;

edge[Index].hight=hight1;
edge[Index].v=y;
edge[Index].w=w;
edge[Index].next=pre[x];
pre[x]=Index++;

edge[Index].hight=hight1;
edge[Index].v=x;
edge[Index].w=w;
edge[Index].next=pre[y];
pre[y]=Index++;
}
}
int spfa(int a,int b,int limit)
{
cle(vis);
vis[a]=1;
for(int i=1;i<=n;i++)dist[i]=INF;
dist[a]=0;
queue<int>q;
q.push(a);
while(!q.empty())
{
int u=q.front();
q.pop();
vis[u]=0;
for(int j=pre[u];j!=-1;j=edge[j].next)
{
if(edge[j].hight>=limit)
{
int e=edge[j].v;
if(dist[e]>edge[j].w+dist[u])
{
dist[e]=edge[j].w+dist[u];
if(!vis[e])
{
q.push(e);
vis[e]=1;
}
}
}
}
}
return dist[b];
}
int main()
{
//freopen("in.txt","r",stdin);
//freopen("out.txt","w",stdout);
int cas=0;int a,b;
while(cin>>n>>m)
{
if(n==0&&m==0)break;
cas++; if(cas!=1)cout<<endl;
init();
scanf("%d%d%d",&a,&b,&h);
int low=1,high=h+1,ans_len=INF,ans_h=0;
while(low<high)
{
int limit=(low+high)>>1;
int r=spfa(a,b,limit);
if(r==INF)
{
high=limit;
}
else
{
low=limit+1;
if(limit>ans_h){ans_h=limit;ans_len=r;}///高度优先
else if(limit==ans_h&&r<ans_len)ans_len=r;///最短路~
}
}
printf("Case %d:\n",cas);
if(ans_len==INF)cout<<"cannot reach destination"<<endl;
else
{
printf("maximum height = %d\n", ans_h);
printf("length of shortest route = %d\n",ans_len);
}

}
return 0;
}



 

这篇关于HDU 2962 Trucking的文章就介绍到这儿,希望我们推荐的文章对编程师们有所帮助!



http://www.chinasem.cn/article/1114167

相关文章

usaco 1.3 Mixing Milk (结构体排序 qsort) and hdu 2020(sort)

到了这题学会了结构体排序 于是回去修改了 1.2 milking cows 的算法~ 结构体排序核心: 1.结构体定义 struct Milk{int price;int milks;}milk[5000]; 2.自定义的比较函数,若返回值为正,qsort 函数判定a>b ;为负,a<b;为0,a==b; int milkcmp(const void *va,c

poj 3974 and hdu 3068 最长回文串的O(n)解法(Manacher算法)

求一段字符串中的最长回文串。 因为数据量比较大,用原来的O(n^2)会爆。 小白上的O(n^2)解法代码:TLE啦~ #include<stdio.h>#include<string.h>const int Maxn = 1000000;char s[Maxn];int main(){char e[] = {"END"};while(scanf("%s", s) != EO

hdu 2093 考试排名(sscanf)

模拟题。 直接从教程里拉解析。 因为表格里的数据格式不统一。有时候有"()",有时候又没有。而它也不会给我们提示。 这种情况下,就只能它它们统一看作字符串来处理了。现在就请出我们的主角sscanf()! sscanf 语法: #include int sscanf( const char *buffer, const char *format, ... ); 函数sscanf()和

hdu 2602 and poj 3624(01背包)

01背包的模板题。 hdu2602代码: #include<stdio.h>#include<string.h>const int MaxN = 1001;int max(int a, int b){return a > b ? a : b;}int w[MaxN];int v[MaxN];int dp[MaxN];int main(){int T;int N, V;s

hdu 1754 I Hate It(线段树,单点更新,区间最值)

题意是求一个线段中的最大数。 线段树的模板题,试用了一下交大的模板。效率有点略低。 代码: #include <stdio.h>#include <string.h>#define TREE_SIZE (1 << (20))//const int TREE_SIZE = 200000 + 10;int max(int a, int b){return a > b ? a :

hdu 1166 敌兵布阵(树状数组 or 线段树)

题意是求一个线段的和,在线段上可以进行加减的修改。 树状数组的模板题。 代码: #include <stdio.h>#include <string.h>const int maxn = 50000 + 1;int c[maxn];int n;int lowbit(int x){return x & -x;}void add(int x, int num){while

hdu 3790 (单源最短路dijkstra)

题意: 每条边都有长度d 和花费p,给你起点s 终点t,要求输出起点到终点的最短距离及其花费,如果最短距离有多条路线,则输出花费最少的。 解析: 考察对dijkstra的理解。 代码: #include <iostream>#include <cstdio>#include <cstdlib>#include <algorithm>#include <cstrin

hdu 2489 (dfs枚举 + prim)

题意: 对于一棵顶点和边都有权值的树,使用下面的等式来计算Ratio 给定一个n 个顶点的完全图及它所有顶点和边的权值,找到一个该图含有m 个顶点的子图,并且让这个子图的Ratio 值在所有m 个顶点的树中最小。 解析: 因为数据量不大,先用dfs枚举搭配出m个子节点,算出点和,然后套个prim算出边和,每次比较大小即可。 dfs没有写好,A的老泪纵横。 错在把index在d

hdu 1102 uva 10397(最小生成树prim)

hdu 1102: 题意: 给一个邻接矩阵,给一些村庄间已经修的路,问最小生成树。 解析: 把已经修的路的权值改为0,套个prim()。 注意prim 最外层循坏为n-1。 代码: #include <iostream>#include <cstdio>#include <cstdlib>#include <algorithm>#include <cstri

hdu 1285(拓扑排序)

题意: 给各个队间的胜负关系,让排名次,名词相同按从小到大排。 解析: 拓扑排序是应用于有向无回路图(Direct Acyclic Graph,简称DAG)上的一种排序方式,对一个有向无回路图进行拓扑排序后,所有的顶点形成一个序列,对所有边(u,v),满足u 在v 的前面。该序列说明了顶点表示的事件或状态发生的整体顺序。比较经典的是在工程活动上,某些工程完成后,另一些工程才能继续,此时