本文主要是介绍HDU 5050 Divided Land,希望对大家解决编程问题提供一定的参考价值,需要的开发者们随着小编来一起学习吧!
http://acm.hdu.edu.cn/showproblem.php?pid=5050
Divided Land
Time Limit: 8000/4000 MS (Java/Others) Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 713 Accepted Submission(s): 339
Problem Description
It’s time to fight the local despots and redistribute the land. There is a rectangular piece of land granted from the government, whose length and width are both in binary form. As the mayor, you must segment the land into multiple squares of equal size for the villagers. What are required is there must be no any waste and each single segmented square land has as large area as possible. The width of the segmented square land is also binary.
Input
The first line of the input is T (1 ≤ T ≤ 100), which stands for the number of test cases you need to solve.
Each case contains two binary number represents the length L and the width W of given land. (0 < L, W ≤ 2 1000)
Output
For each test case, print a line “Case #t: ”(without quotes, t means the index of the test case) at the beginning. Then one number means the largest width of land that can be divided from input data. And it will be show in binary. Do not have any useless number or space.
Sample Input
3
10 100
100 110
10010 1100
Sample Output
Case #1: 10
Case #2: 10
Case #3: 110
Source
2014 ACM/ICPC Asia Regional Shanghai Online
Recommend
hujie | We have carefully selected several similar problems for you: 5177 5176 5175 5173 5172
大数的练习,第一次java.真是方便啊。ACM也能用C#就好了。
C++好像也能写 用itoa()等函数吧
import java.math.BigInteger;
import java.util.Scanner;
public class dashu
{
public static void main(String[] args)
{
//TODO Auto-generated method stub
Scanner sc = new Scanner(System.in);
int T = sc.nextInt();
for (int nc = 1; nc <= T; ++nc)
{
BigInteger a = sc.nextBigInteger(2);
BigInteger b = sc.nextBigInteger(2);
BigInteger ans = a.gcd(b);
System.out.println("Case #" + nc + ": " + ans.toString(2));
}
}
}
这篇关于HDU 5050 Divided Land的文章就介绍到这儿,希望我们推荐的文章对编程师们有所帮助!