本文主要是介绍Message Flood(字典树),希望对大家解决编程问题提供一定的参考价值,需要的开发者们随着小编来一起学习吧!
题目描述
Well, how do you feel about mobile phone? Your answer would probably be something like that "It's so convenient and benefits people a lot". However, If you ask Merlin this question on the New Year's Eve, he will definitely answer "What a trouble! I have to keep my fingers moving on the phone the whole night, because I have so many greeting message to send!" Yes, Merlin has such a long name list of his friends, and he would like to send a greeting message to each of them. What's worse, Merlin has another long name list of senders that have sent message to him, and he doesn't want to send another message to bother them Merlin is so polite that he always replies each message he receives immediately). So, before he begins to send message, he needs to figure to how many friends are left to be sent. Please write a program to help him. Here is something that you should note. First, Merlin's friend list is not ordered, and each name is alphabetic strings and case insensitive. These names are guaranteed to be not duplicated. Second, some senders may send more than one message to Merlin, therefore the sender list may be duplicated. Third, Merlin is known by so many people, that's why some message senders are even not included in his friend list.
输入
There are multiple test cases. In each case, at the first line there are two numbers n and m (1<=n,m<=20000), which is the number of friends and the number of messages he has received. And then there are n lines of alphabetic strings(the length of each will be less than 10), indicating the names of Merlin's friends, one per line. After that there are m lines of alphabetic strings, which are the names of message senders. The input is terminated by n=0.
输出
For each case, print one integer in one line which indicates the number of left friends he must send.
示例输入
5 3 Inkfish Henry Carp Max Jericho Carp Max Carp 0
示例输出
3
来源
#include<stdio.h>
#include <string.h>
#include <stdlib.h>
struct node
{int flag;node *next[26];
};
node *newnode()
{int i;node *p=new node;for(i=0; i<26; i++){p->next[i]=NULL;}p->flag=0;return p;
}
void charu(node *root, char *s)
{int i, k=strlen(s),t;node *p=root;for(i=0; i<k; i++){if(s[i]>='A'&&s[i]<='Z')t=s[i]-'A';elset=s[i]-'a';if(p->next[t]==NULL)p->next[t]=newnode();p=p->next[t];}p->flag=1;
}
int seach(node *root, char *s)
{node *p=root;int i, t, k=strlen(s);for(i=0; i<k; i++){if(s[i]>='A'&&s[i]<='Z')t=s[i]-'A';elset=s[i]-'a';if(p->next[t]==NULL)return 0;p=p->next[t];}if(p->flag){p->flag=0;return 1;}return 0;
}
void del(struct node *p)
{int i;for(i=0; i<26; i++)if(p->next[i]!=NULL)del(p->next[i]);free(p);p=NULL;
}
int main()
{int n, i, j,k, m;char s[20001][20], s0[20];struct node *p;while(scanf("%d",&n)!=EOF){if(n==0) break;k=0;scanf("%d",&m);p=newnode();for(i=0; i<n; i++){scanf("%s",s[i]);}for(i=0; i<m; i++){scanf("%s",s0);charu(p, s0);}for(i=0;i<n;i++){j=seach(p,s[i]);if(j)k++;}printf("%d\n",n-k);del(p);}return 0;
}
这篇关于Message Flood(字典树)的文章就介绍到这儿,希望我们推荐的文章对编程师们有所帮助!