本文主要是介绍【PAT】【Advanced Level】1038. Recover the Smallest Number (30),希望对大家解决编程问题提供一定的参考价值,需要的开发者们随着小编来一起学习吧!
1038. Recover the Smallest Number (30)
Given a collection of number segments, you are supposed to recover the smallest number from them. For example, given {32, 321, 3214, 0229, 87}, we can recover many numbers such like 32-321-3214-0229-87 or 0229-32-87-321-3214 with respect to different orders of combinations of these segments, and the smallest number is 0229-321-3214-32-87.
Input Specification:
Each input file contains one test case. Each case gives a positive integer N (<=10000) followed by N number segments. Each segment contains a non-negative integer of no more than 8 digits. All the numbers in a line are separated by a space.
Output Specification:
For each test case, print the smallest number in one line. Do not output leading zeros.
Sample Input:5 32 321 3214 0229 87Sample Output:
22932132143287
https://www.patest.cn/contests/pat-a-practise/1038
https://www.nowcoder.com/questionTerminal/05c37a5c79964945930f526c75c87ba5
思路:
首先想到的是直接排序输出
得9分
后来参考牛客网上Uncle_Sugar的题解:
链接:https://www.nowcoder.com/questionTerminal/05c37a5c79964945930f526c75c87ba5
来源:牛客网
其实就是一个序的关系,所有的组合有n!种,(像"所谓组出最小数其实是获得字典序最小的拼接方式"这种废话我就不说了)。假设我们获得了其中的一个组合,然后又两个相邻的数字片段a,b。然后我们就要想,把a和b交换能不能使整个序列变小呢?这个问题的其实等价于b+a 是否小于a+b(此处"+"为连接符),也就是说对于这样一个序列,如果某两个相邻的元素之间发生交换可以使得整个序列的值变小,我们就应该坚决的交换啊,所以这里定义一个新的序,用<<来表示,若a+b < b + a 则a应当在b前面,即a << b。然后呢,这种序是满足传递性的若a<<b ,b << c,则a<<c,所以迭代到最后,我们就会获得一个任何两个相邻元素都不能交换的局面,也就是所谓的答案。
CODE:
#include<iostream>
#include<cstring>
#include<string>
#include<cstdio>
#include<algorithm>
using namespace std;
string ch[100000];
/*
bool cmp(char* a,char* b)
{return strcmp(a,b)<0;
}
*/
bool cmp(string a,string b)
{return a+b<b+a;
}
int main()
{int n;cin>>n;for (int i=0;i<n;i++){cin>>ch[i];//scanf("%s",&ch[i]);//cout<<ch[i]<<endl;}sort(ch,ch+n,cmp);int st=0;while (atoi(ch[st].c_str())==0){st++;if(st>=n)break;}if (st==n){cout<<0<<endl;}else{printf("%d",atoi(ch[st].c_str()));st++;for (int i=st;i<n;i++)printf("%s",ch[i].c_str());}return 0;
}
这篇关于【PAT】【Advanced Level】1038. Recover the Smallest Number (30)的文章就介绍到这儿,希望我们推荐的文章对编程师们有所帮助!