POJ 2887:Big String ← 块状链表

2024-06-11 00:20
文章标签 链表 string poj big 块状 2887

本文主要是介绍POJ 2887:Big String ← 块状链表,希望对大家解决编程问题提供一定的参考价值,需要的开发者们随着小编来一起学习吧!

【题目来源】
http://poj.org/problem?id=2887

【题目描述】
You are given a string and supposed to do some string manipulations.

【输入格式】
The first line of the input contains the initial string. You can assume that it is non-empty and its length does not exceed
1,000,000.
The second line contains the number of manipulation commands N (
0 < N ≤ 2,000). The following N lines describe a command each. The commands are in one of the two formats below:
(1)
I ch p: Insert a character ch before the p-th character of the current string. If p is larger than the length of the string, the character is appended to the end of the string.
(2)
Q p: Query the p-th character of the current string. The input ensures that the p-th character exists.
All characters in the input are digits or lowercase letters of the English alphabet.

【输出格式】
For each Q command output one line containing only the single character queried.

【输入样例】
ab
7
Q 1
I c 2
I d 4
I e 2
Q 5
I f 1
Q 3

【输出样例】
a
d
e

【算法分析】
● 顾名思义,
块状链表=分块+链表,或者理解为用链表串起来的分块。根据对分块最优性的思思,n 个数据分为 sqrt(n) 块,每块 sqrt(n) 个数据。
​​​​​​​​​​​● 块状链表结合了数组与链表的优势,优化了计算复杂度。
● POJ 不支持万能头文件 #include <bits/stdc++.h>。
​​​​​​​●​​​​​​​ 针对错误提示 
error C2668: 'sqrt' : ambiguous call to overloaded function 的解决方法,就是将代码 sz=sqrt(n); 中的 n 进行强制类型转换,修改为 sz=sqrt((double)n); 即可。

【算法代码一】

#include <iostream>
#include <cstring>
#include <cmath>
using namespace std;const int maxn=1e6+5;
const int maxm=1e3+5;
char str[maxn];
int block[maxm];
char ch[maxm][5*maxm];
int n,sz,cnt;void build() {sz=sqrt((double)n);cnt=(n+sz-1)/sz; //向上取整for(int i=0; i<n; i++) {ch[i/sz+1][block[i/sz+1]++]=str[i];}
}void insert(char c, int p) {int i;for(i=1; i<=cnt; i++) {if(p-block[i]<=0) break;p-=block[i];}if(i==cnt+1) {ch[cnt][block[cnt]++]=c;return ;}block[i]++;int len=strlen(ch[i]);for(int j=len-1; j>=p-1; j--) ch[i][j+1]=ch[i][j];ch[i][p-1]=c;
}void query(int p) {int i;for(i=1; i<=cnt; i++) {if(p-block[i]<=0) break;p-=block[i];}cout<<ch[i][p-1]<<endl;
}int main() {cin>>str;n=strlen(str);int T;cin>>T;build();while(T--) {char op, c;int num;cin>>op;if(op=='I') {cin>>c>>num;insert(c, num);} else {cin>>num;query(num);}}return 0;
}/*
in:
ab
7
Q 1
I c 2
I d 4
I e 2
Q 5
I f 1
Q 3out:
a
d
e
*/


【算法代码二】

#include <iostream>
#include <cstring>
#include <cmath>
using namespace std;const int maxn=1e6+5;
const int maxm=1e3+5;
char str[maxn];
int block[maxm];
char ch[maxm][5*maxm];
int n,sz,cnt;void build() {sz=sqrt((double)n);cnt=(n+sz-1)/sz; //向上取整for(int i=0; i<n; i++) {ch[i/sz+1][block[i/sz+1]++]=str[i];}
}void insert(char c, int p) {int i;for(i=1; i<=cnt; i++) {if(p-block[i]<=0) break;p-=block[i];}if(i==cnt+1) {ch[cnt][block[cnt]++]=c;return ;}block[i]++;int len=strlen(ch[i]);for(int j=len-1; j>=p-1; j--) ch[i][j+1]=ch[i][j];ch[i][p-1]=c;
}void query(int p) {int i;for(i=1; i<=cnt; i++) {if(p-block[i]<=0) break;p-=block[i];}printf("%c\n", ch[i][p-1]);
}int main() {scanf("%s", str);n=strlen(str);int T;scanf("%d", &T);build();while(T--) {char op[3], c[3];int num;scanf("%s", op);if(op[0]=='I') {scanf("%s %d", c, &num);insert(c[0], num);} else {scanf("%d", &num);query(num);}}return 0;
}/*
in:
ab
7
Q 1
I c 2
I d 4
I e 2
Q 5
I f 1
Q 3out:
a
d
e
*/




【参考文献】
https://www.cnblogs.com/fightfordream/p/6565816.html
https://blog.csdn.net/hnjzsyjyj/article/details/138955263
https://oi-wiki.org/ds/block-list/
https://www.cnblogs.com/nancheng58/p/10068136.html




 

这篇关于POJ 2887:Big String ← 块状链表的文章就介绍到这儿,希望我们推荐的文章对编程师们有所帮助!



http://www.chinasem.cn/article/1049685

相关文章

csu1329(双向链表)

题意:给n个盒子,编号为1到n,四个操作:1、将x盒子移到y的左边;2、将x盒子移到y的右边;3、交换x和y盒子的位置;4、将所有的盒子反过来放。 思路分析:用双向链表解决。每个操作的时间复杂度为O(1),用数组来模拟链表,下面的代码是参考刘老师的标程写的。 代码如下: #include<iostream>#include<algorithm>#include<stdio.h>#

poj 3974 and hdu 3068 最长回文串的O(n)解法(Manacher算法)

求一段字符串中的最长回文串。 因为数据量比较大,用原来的O(n^2)会爆。 小白上的O(n^2)解法代码:TLE啦~ #include<stdio.h>#include<string.h>const int Maxn = 1000000;char s[Maxn];int main(){char e[] = {"END"};while(scanf("%s", s) != EO

hdu 2602 and poj 3624(01背包)

01背包的模板题。 hdu2602代码: #include<stdio.h>#include<string.h>const int MaxN = 1001;int max(int a, int b){return a > b ? a : b;}int w[MaxN];int v[MaxN];int dp[MaxN];int main(){int T;int N, V;s

poj 1511 Invitation Cards(spfa最短路)

题意是给你点与点之间的距离,求来回到点1的最短路中的边权和。 因为边很大,不能用原来的dijkstra什么的,所以用spfa来做。并且注意要用long long int 来存储。 稍微改了一下学长的模板。 stack stl 实现代码: #include<stdio.h>#include<stack>using namespace std;const int M

poj 3259 uva 558 Wormholes(bellman最短路负权回路判断)

poj 3259: 题意:John的农场里n块地,m条路连接两块地,w个虫洞,虫洞是一条单向路,不但会把你传送到目的地,而且时间会倒退Ts。 任务是求你会不会在从某块地出发后又回来,看到了离开之前的自己。 判断树中是否存在负权回路就ok了。 bellman代码: #include<stdio.h>const int MaxN = 501;//农场数const int

poj 1258 Agri-Net(最小生成树模板代码)

感觉用这题来当模板更适合。 题意就是给你邻接矩阵求最小生成树啦。~ prim代码:效率很高。172k...0ms。 #include<stdio.h>#include<algorithm>using namespace std;const int MaxN = 101;const int INF = 0x3f3f3f3f;int g[MaxN][MaxN];int n

poj 1287 Networking(prim or kruscal最小生成树)

题意给你点与点间距离,求最小生成树。 注意点是,两点之间可能有不同的路,输入的时候选择最小的,和之前有道最短路WA的题目类似。 prim代码: #include<stdio.h>const int MaxN = 51;const int INF = 0x3f3f3f3f;int g[MaxN][MaxN];int P;int prim(){bool vis[MaxN];

poj 2349 Arctic Network uva 10369(prim or kruscal最小生成树)

题目很麻烦,因为不熟悉最小生成树的算法调试了好久。 感觉网上的题目解释都没说得很清楚,不适合新手。自己写一个。 题意:给你点的坐标,然后两点间可以有两种方式来通信:第一种是卫星通信,第二种是无线电通信。 卫星通信:任何两个有卫星频道的点间都可以直接建立连接,与点间的距离无关; 无线电通信:两个点之间的距离不能超过D,无线电收发器的功率越大,D越大,越昂贵。 计算无线电收发器D

poj 1502 MPI Maelstrom(单源最短路dijkstra)

题目真是长得头疼,好多生词,给跪。 没啥好说的,英语大水逼。 借助字典尝试翻译了一下,水逼直译求不喷 Description: BIT他们的超级计算机最近交货了。(定语秀了一堆词汇那就省略吧再见) Valentine McKee的研究顾问Jack Swigert,要她来测试一下这个系统。 Valentine告诉Swigert:“因为阿波罗是一个分布式共享内存的机器,所以它的内存访问

uva 10061 How many zero's and how many digits ?(不同进制阶乘末尾几个0)+poj 1401

题意是求在base进制下的 n!的结果有几位数,末尾有几个0。 想起刚开始的时候做的一道10进制下的n阶乘末尾有几个零,以及之前有做过的一道n阶乘的位数。 当时都是在10进制下的。 10进制下的做法是: 1. n阶位数:直接 lg(n!)就是得数的位数。 2. n阶末尾0的个数:由于2 * 5 将会在得数中以0的形式存在,所以计算2或者计算5,由于因子中出现5必然出现2,所以直接一