本文主要是介绍uva201 Squares 记录,希望对大家解决编程问题提供一定的参考价值,需要的开发者们随着小编来一起学习吧!
uva201 Squares 题解
Squares
Squares |
A children's board game consists of a square array of dots that contains lines connecting some of the pairs of adjacent dots. One part of the game requires that the players count the number of squares of certain sizes that are formed by these lines. For example, in the figure shown below, there are 3 squares-2 of size 1 and 1 of size 2. (The ``size" of a square is the number of lines segments required to form a side.)
Your problem is to write a program that automates the process of counting all the possible squares.
Input
The input file represents a series of game boards. Each board consists of a description of a square array ofn2 dots (where 2 <= n <= 9) and some interconnecting horizontal and vertical lines. A record for a single board with n2 dots and m interconnecting lines is formatted as follows:
Line 1: n the number of dots in a single row or column of the arrayLine 2: m the number of interconnecting lines
Each of the next m lines are of one of two types:
H i j indicates a horizontal line in row i which connects
the dot in column j to the one to its right in column j + 1
or
V i j indicates a vertical line in column i which connects
the dot in row j to the one below in row j + 1
Information for each line begins in column 1. The end of input is indicated by end-of-file. The first record of the sample input below represents the board of the square above.
Output
For each record, label the corresponding output with ``Problem #1", ``Problem #2", and so forth. Output for a record consists of the number of squares of each size on the board, from the smallest to the largest. lf no squares of any size exist, your program should print an appropriate message indicating so. Separate output for successive input records by a line of asterisks between two blank lines, like in the sample below.
Sample Input
4 16 H 1 1 H 1 3 H 2 1 H 2 2 H 2 3 H 3 2 H 4 2 H 4 3 V 1 1 V 2 1 V 2 2 V 2 3 V 3 2 V 4 1 V 4 2 V 4 3 2 3 H 1 1 H 2 1 V 2 1
Sample Output
Problem #12 square (s) of size 1 1 square (s) of size 2**********************************Problem #2No completed squares can be found.
#include <cstdio>
#include <cstring>
#include <cstdlib>
#include <iostream>
using namespace std;
const int N=20;
int h[N][N];
int v[N][N];
int Gnum;
void judge(int nsize,int n){int i,j,k;int num=0;if (nsize>n){return;}for ( i = 1; i+nsize <= n; ++i){for ( j = 1; j+nsize <= n ; ++j){int x=0;while(x<nsize){if (!h[i][j+x]||!h[i+nsize][j+x]){break;}if (!v[i+x][j]||!v[i+x][j+nsize]){break;}x++;}if (x>=nsize){num++;Gnum++;}}}if (num){printf("%d square (s) of size %d\n",num,nsize);}judge(nsize+1,n);
}
int main()
{int n,m,i;int T=0;while(cin>>n){T++;Gnum=0;if (T!=1){printf("\n**********************************\n\n");}int m;cin>>m;memset(h,0,sizeof(h));memset(v,0,sizeof(v));for ( i = 0; i < m; ++i){char ch;int x,y;cin>>ch>>x>>y;if (ch=='H'){h[x][y]=1;}else if(ch=='V'){v[y][x]=1;}}printf("Problem #%d\n\n",T);//printfcheck(n);judge(1,n);if (Gnum==0){printf("No completed squares can be found.\n");}}return 0;
}
void judge(int nsize,int n){int i,j,k;int num=0;if (nsize>n){return;}for ( i = 1; i+nsize <= n; ++i){for ( j = 1; j+nsize <= n ; ++j){int x=0;while(x<nsize){if (!h[i][j+x]||!h[i+nsize][j+x]){break;}if (!v[i+x][j]||!v[i+x][j+nsize]){break;}x++;}if (x>=nsize){num++;Gnum++;}}}if (num){printf("%d square (s) of size %d\n",num,nsize);}judge(nsize+1,n);
}
这篇关于uva201 Squares 记录的文章就介绍到这儿,希望我们推荐的文章对编程师们有所帮助!