本文主要是介绍hdu——1686——Oulipo,希望对大家解决编程问题提供一定的参考价值,需要的开发者们随着小编来一起学习吧!
Problem DescriptionThe French author Georges Perec (1936–1982) once wrote a book, La disparition, without the letter 'e'. He was a member of the Oulipo group. A quote from the book:
Tout avait Pair normal, mais tout s’affirmait faux. Tout avait Fair normal, d’abord, puis surgissait l’inhumain, l’affolant. Il aurait voulu savoir où s’articulait l’association qui l’unissait au roman : stir son tapis, assaillant à tout instant son imagination, l’intuition d’un tabou, la vision d’un mal obscur, d’un quoi vacant, d’un non-dit : la vision, l’avision d’un oubli commandant tout, où s’abolissait la raison : tout avait l’air normal mais…
Perec would probably have scored high (or rather, low) in the following contest. People are asked to write a perhaps even meaningful text on some subject with as few occurrences of a given “word” as possible. Our task is to provide the jury with a program that counts these occurrences, in order to obtain a ranking of the competitors. These competitors often write very long texts with nonsense meaning; a sequence of 500,000 consecutive 'T's is not unusual. And they never use spaces.
So we want to quickly find out how often a word, i.e., a given string, occurs in a text. More formally: given the alphabet {'A', 'B', 'C', …, 'Z'} and two finite strings over that alphabet, a word W and a text T, count the number of occurrences of W in T. All the consecutive characters of W must exactly match consecutive characters of T. Occurrences may overlap.
Input
The first line of the input file contains a single number: the number of test cases to follow. Each test case has the following format:
One line with the word W, a string over {'A', 'B', 'C', …, 'Z'}, with 1 ≤ |W| ≤ 10,000 (here |W| denotes the length of the string W).
One line with the text T, a string over {'A', 'B', 'C', …, 'Z'}, with |W| ≤ |T| ≤ 1,000,000.
Output
For every test case in the input file, the output should contain a single number, on a single line: the number of occurrences of the word W in the text T.
Sample Input
3
BAPC
BAPC
AZA
AZAZAZA
VERDI
AVERDXIVYERDIAN
Sample Output
1
3
0
题意:kmp每一次输入两行,输出第二行能形成第一行的个数
/*AAA
AAAAA
3*/
#include<iostream>
#include<cstring>
#include<cstdio>
using namespace std;
const int pMax = 10005;
const int tMax = 1000005;char s1[tMax], s2[tMax];
int L1, L2, next[tMax];
void getnext()
{int i = 0;int j = -1;next[0] = -1;while(i <L1){if(j == -1 ||s1[i] ==s1[j]){i ++;j ++;next[i] = j;}elsej = next[j];}
}
int KMPMatch()
{int ans = 0;int i = 0;int j = 0;getnext();while(i <L2){if(j == -1 || s2[i] == s1[j]){i ++;j ++;}elsej = next[j];if(j ==L1){ans ++;j = next[j];}}return ans;
}int main()
{int t;scanf("%d", &t);while(t --){scanf("%s%s",s1, s2);L1= strlen(s1);L2= strlen(s2);printf("%d\n", KMPMatch());}return 0;
}
这篇关于hdu——1686——Oulipo的文章就介绍到这儿,希望我们推荐的文章对编程师们有所帮助!