hdu1978 How many ways

2024-06-08 18:32
文章标签 many ways hdu1978

本文主要是介绍hdu1978 How many ways,希望对大家解决编程问题提供一定的参考价值,需要的开发者们随着小编来一起学习吧!

How many ways

Time Limit: 3000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 2543    Accepted Submission(s): 1499


Problem Description
这是一个简单的生存游戏,你控制一个机器人从一个棋盘的起始点(1,1)走到棋盘的终点(n,m)。游戏的规则描述如下:
1.机器人一开始在棋盘的起始点并有起始点所标有的能量。
2.机器人只能向右或者向下走,并且每走一步消耗一单位能量。
3.机器人不能在原地停留。
4.当机器人选择了一条可行路径后,当他走到这条路径的终点时,他将只有终点所标记的能量。

如上图,机器人一开始在(1,1)点,并拥有4单位能量,蓝色方块表示他所能到达的点,如果他在这次路径选择中选择的终点是(2,4)

点,当他到达(2,4)点时将拥有1单位的能量,并开始下一次路径选择,直到到达(6,6)点。
我们的问题是机器人有多少种方式从起点走到终点。这可能是一个很大的数,输出的结果对10000取模。

Input
第一行输入一个整数T,表示数据的组数。
对于每一组数据第一行输入两个整数n,m(1 <= n,m <= 100)。表示棋盘的大小。接下来输入n行,每行m个整数e(0 <= e < 20)。

Output
对于每一组数据输出方式总数对10000取模的结果.

Sample Input
  
1 6 6 4 5 6 6 4 3 2 2 3 1 7 2 1 1 4 6 2 7 5 8 4 3 9 5 7 6 6 2 1 5 3 1 1 3 7 2

Sample Output
  
3948

Author
xhd

状态转移方程:dp[i+k][j+l] = (dp[i+k][j+l] + dp[i][j]) % 10000;

dp[i][j]表示到达点(i,j)的途径数, 其中k,l为处在点(i,j)时,能够到达点(i+k,j+l)。半径。

dp要开到120以上;

106813062014-05-05 17:22:30Accepted1978250MS356K594 BC++向往蓝天的鱼
106812802014-05-05 17:19:04Accepted1978250MS468K592 BC++向往蓝天的鱼
106812702014-05-05 17:17:48Accepted1978171MS464K594 BC++向往蓝天的鱼

scanf省时间;

#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
int dp[122][122];
int main()
{int t;int m,n,num;int i,j,k,l;cin>>t;while(t--){cin>>m>>n;memset(dp,0,sizeof(dp));dp[0][0]=1;for(i=0;i<m;++i)for(j=0;j<n;++j){cin>>num;//scanf("%d",&num);for(k=0;k<=num;++k)for(l=0;l+k<=num;++l){if(k==0&&l==0)continue;dp[i+k][j+l]=(dp[i+k][j+l]+dp[i][j])%10000;}}cout<<dp[m-1][n-1]<<endl;//printf("%d\n",dp[m-1][n-1]);  }return 0;
}

106824632014-05-05 19:26:03Accepted1978156MS340K683 BC++向往蓝天的鱼

控制一下边界dp就开小了

时间用的更少

#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
int dp[110][112];
int main()
{int t;int m,n,num;int i,j,k,l;cin>>t;while(t--){cin>>m>>n;memset(dp,0,sizeof(dp));dp[0][0]=1;for(i=0;i<m;++i)for(j=0;j<n;++j){//cin>>num;scanf("%d",&num);for(k=0;k<=num;++k){if(i+k >= m)  break; for(l=0;l+k<=num;++l){if(l+j >= n)  break; if(k==0&&l==0)continue;dp[i+k][j+l]=(dp[i+k][j+l]+dp[i][j])%10000;}}}//cout<<dp[m-1][n-1]<<endl;printf("%d\n",dp[m-1][n-1]);  }return 0;
}



这篇关于hdu1978 How many ways的文章就介绍到这儿,希望我们推荐的文章对编程师们有所帮助!



http://www.chinasem.cn/article/1042966

相关文章

uva 10061 How many zero's and how many digits ?(不同进制阶乘末尾几个0)+poj 1401

题意是求在base进制下的 n!的结果有几位数,末尾有几个0。 想起刚开始的时候做的一道10进制下的n阶乘末尾有几个零,以及之前有做过的一道n阶乘的位数。 当时都是在10进制下的。 10进制下的做法是: 1. n阶位数:直接 lg(n!)就是得数的位数。 2. n阶末尾0的个数:由于2 * 5 将会在得数中以0的形式存在,所以计算2或者计算5,由于因子中出现5必然出现2,所以直接一

【HDU】How Many Answers Are Wrong(带权并查集)

num[i]代表i到根节点的值 这道题一开始竟然以为是线段树= =!后来发现线段树无法进行子区间的维护 #include<cstdio>#include<cstring>#include<algorithm>using namespace std;const int maxn = 222222;int fa[maxn],num[maxn];int find_father(int

kubernetes Pod failed to create fsnotify watcher: too many open files

fs.nr_open: 控制单个进程可以打开的文件描述符的最大数量。单个进程的文件描述符限制可以通过 ulimit 命令来设置。 /proc/sys/fs/nr_open 是一个系统级别的全局参数,表示系统中单个进程能够打开的文件描述符总数的限制。/proc/sys/fs/file-max 系统级别,当前系统可打开的最大数量/etc/security/limits.conf 用户级别,指定用户

for 出错 ValueError: too many values to unpack (expected 2) 遍历多个变量

贼简单的代码示例 for [i,j] in [range(3),range(3)]:print(i,j) 输出: ValueError: too many values to unpack (expected 2) 正确示例 for i,j in zip(range(3),range(3)):print(i,j) 输出: 0 0 1 1 2 2 原因:后面zip()包装了两个lis

Host '10.10.120.174' is blocked beacuse of many connection errors;

Host '10.10.120.174' is blocked beacuse of many connection errors;unblock with 'mysqldamin flush-hosts' #使用清楚缓存的方法,这样就会把计数清理掉,进入mysql控制台,执行:flush hosts; /usr/bin/mysqladmin  -u jiaobo -puukkgg  flus

nginx 出错:socket() failed (24: Too many open files) while connecting to upstream

1. 错误描述 通过nginx负载两个节点的rabbitmq 当用java代码创建超过500个连接时(我的机器默认只能创建这么多),出现错误: com.rabbitmq.client.ShutdownSignalException: connection errorjava.net.SocketException: Software caused connection abort: recv

【并查集】 HDU 1213 How Many Tables

HDU 1213 How Many Tables 纯粹的并查集 #include <iostream>#include <string>#include <algorithm>#include <math.h>#include <stdio.h>#include <stdlib.h>using namespace std;int father[1111];int get_fa(

es集群重新分片报错Too many open files解决

现象 查看es集群状态 后面所有操作均在开发工具中操作, 命令行是 curl -XGET -uelastic:password http://ip:9200/_cluster/health GET _cluster/health 查看解释 GET /_cluster/allocation/explain 查看es日志 [WARN ][o.e.c.r.a.AllocationS

How many ways 记忆化搜索

http://acm.hdu.edu.cn/showproblem.php?pid=1978 第一次见到dp记忆化搜索 这题可以分为两种DP方式,一种是当前的这个点可以到达其他点的方法数,二是 能到达当前点的方法数。 第一种方法 #include<iostream>#include<cstring>#include<algorithm>#include<cstdlib>#inclu

论文学习—Efficient Multi-label Classification with Many Labels

论文学习:Efficient Multi-label Classification with Many Labels 摘要2. 多标签分类相关工作2.1 Label Transformation1. **降维(Dimensionality Reduction)**2. **回归模型(Regression Model)**3. **逆变换(Inverse Transformation)** 2