zoj 3914 Semantic Version(模拟)

2024-06-05 00:32
文章标签 模拟 version zoj semantic 3914

本文主要是介绍zoj 3914 Semantic Version(模拟),希望对大家解决编程问题提供一定的参考价值,需要的开发者们随着小编来一起学习吧!

题目链接:zoj 3914 Semantic Version

代码

#include <cstdio>
#include <cstring>
#include <vector>
#include <string>
#include <algorithm>using namespace std;
const int maxn = 100;int P, N;
char a[maxn], b[maxn];
vector<string> A, B;bool ischar(char ch) {if (ch >= 'a' && ch <= 'z') return true;if (ch >= 'A' && ch <= 'Z') return true;return false;
}
bool isnumber(char ch) { return ch >= '0' && ch <= '9'; }
void match(char c, char* s) { if (P < N && s[P] == c) P++; }
int getNumber (char* s) {int u = 0;while (P < N && isnumber(s[P]))u = u * 10 + s[P++] - '0';return u;
}string get (char* s) {string ret = "";while (P < N && s[P] != '.' && s[P] != '-')ret = ret + s[P++];return ret;
}void solve (vector<string>& u, char* s) {u.clear();P = 0;N = strlen(s);while (P < N) {u.push_back(get(s));if (s[P] == '.' || s[P] == '-') P++;}
}int change(string& u) {int ret = 0;for (int i = 0; i < u.length(); i++)ret = ret * 10 + (u[i]-'0');return ret;
}bool judge () {for (int i = 0; i < A.size() || i < B.size(); i++) {if (i >= A.size()) return i != 3;if (i >= B.size()) return i == 3;if (isnumber(A[i][0]) && isnumber(B[i][0])) {int tmpa = change(A[i]), tmpb = change(B[i]);if (tmpa != tmpb) return tmpa < tmpb;} else if (A[i] != B[i]) return A[i] < B[i];}return false;
}int main () {while (scanf("%s%s", a, b) == 2) {solve(A, a);solve(B, b);printf("%s\n", judge() ? "Wow! Such feature! Very smart! I'm excited!" : "I'm angry!");}return 0;
}

这篇关于zoj 3914 Semantic Version(模拟)的文章就介绍到这儿,希望我们推荐的文章对编程师们有所帮助!



http://www.chinasem.cn/article/1031568

相关文章

提示:Decompiled.class file,bytecode version如何解决

《提示:Decompiled.classfile,bytecodeversion如何解决》在处理Decompiled.classfile和bytecodeversion问题时,通过修改Maven配... 目录问题原因总结问题1、提示:Decompiled .class file,China编程 bytecode

【C++】_list常用方法解析及模拟实现

相信自己的力量,只要对自己始终保持信心,尽自己最大努力去完成任何事,就算事情最终结果是失败了,努力了也不留遗憾。💓💓💓 目录   ✨说在前面 🍋知识点一:什么是list? •🌰1.list的定义 •🌰2.list的基本特性 •🌰3.常用接口介绍 🍋知识点二:list常用接口 •🌰1.默认成员函数 🔥构造函数(⭐) 🔥析构函数 •🌰2.list对象

usaco 1.2 Transformations(模拟)

我的做法就是一个一个情况枚举出来 注意计算公式: ( 变换后的矩阵记为C) 顺时针旋转90°:C[i] [j]=A[n-j-1] [i] (旋转180°和270° 可以多转几个九十度来推) 对称:C[i] [n-j-1]=A[i] [j] 代码有点长 。。。 /*ID: who jayLANG: C++TASK: transform*/#include<

数论ZOJ 2562

题意:给定一个数N,求小于等于N的所有数当中,约数最多的一个数,如果存在多个这样的数,输出其中最大的一个。 分析:反素数定义:对于任何正整数x,其约数的个数记做g(x).例如g(1)=1,g(6)=4.如果某个正整数x满足:对于任意i(0<i<x),都有g(i)<g(x),则称x为反素数。 性质一:一个反素数的质因子必然是从2开始连续的质数。 性质二:p=2^t1*3^t2*5^t3*7

zoj 1721 判断2条线段(完全)相交

给出起点,终点,与一些障碍线段。 求起点到终点的最短路。 枚举2点的距离,然后最短路。 2点可达条件:没有线段与这2点所构成的线段(完全)相交。 const double eps = 1e-8 ;double add(double x , double y){if(fabs(x+y) < eps*(fabs(x) + fabs(y))) return 0 ;return x + y ;

zoj 4624

题目分析:有两排灯,每排n个,每个灯亮的概率为p,每个灯之间互不影响,亮了的灯不再灭,问两排中,每排有大于等于m个灯亮的概率。 设dp[ i ][ j ]为第一排亮了i个灯,第二排亮了j个灯,距离目标状态的期望天数。显然 i >= m ,j >= m时 , dp[ i ][ j ] = 0 。 状态转移 : 第一排亮了a个灯,a 在[ 0 , n - i] 之间,第二排亮了b个灯 , b 在

zoj 3228 ac自动机

给出一个字符串和若干个单词,问这些单词在字符串里面出现了多少次。单词前面为0表示这个单词可重叠出现,1为不可重叠出现。 Sample Input ab 2 0 ab 1 ab abababac 2 0 aba 1 aba abcdefghijklmnopqrstuvwxyz 3 0 abc 1 def 1 jmn Sample Output Case 1 1 1 Case 2

ZOJ Monthly, August 2014小记

最近太忙太忙,只能抽时间写几道简单题。不过我倒是明白要想水平提高不看题解是最好的了。 A  我只能死找规律了,无法证明 int a[50002][2] ;vector< vector<int> > gmax , gmin ;int main(){int n , i , j , k , cmax , cmin ;while(cin>>n){/* g

hdu4431麻将模拟

给13张牌。问增加哪些牌可以胡牌。 胡牌有以下几种情况: 1、一个对子 + 4组 3个相同的牌或者顺子。 2、7个不同的对子。 3、13幺 贪心的思想: 对于某张牌>=3个,先减去3个相同,再组合顺子。 import java.io.BufferedInputStream;import java.io.BufferedReader;import java.io.IOExcepti

Maven创建项目中的groupId, artifactId, 和 version的意思

文章目录 groupIdartifactIdversionname groupId 定义:groupId 是 Maven 项目坐标的第一个部分,它通常表示项目的组织或公司的域名反转写法。例如,如果你为公司 example.com 开发软件,groupId 可能是 com.example。作用:groupId 被用来组织和分组相关的 Maven artifacts,这样可以避免