hdu 题目1247 Hat’s Words(字典树)

2024-06-03 19:48
文章标签 题目 字典 words hdu hat 1247

本文主要是介绍hdu 题目1247 Hat’s Words(字典树),希望对大家解决编程问题提供一定的参考价值,需要的开发者们随着小编来一起学习吧!

Hat’s Words

Time Limit : 2000/1000ms (Java/Other)   Memory Limit : 65536/32768K (Java/Other)
Total Submission(s) : 5   Accepted Submission(s) : 3
Problem Description
A hat’s word is a word in the dictionary that is the concatenation of exactly two other words in the dictionary.
You are to find all the hat’s words in a dictionary.

Input
Standard input consists of a number of lowercase words, one per line, in alphabetical order. There will be no more than 50,000 words.
Only one case.

Output
Your output should contain all the hat’s words, one per line, in alphabetical order.

Sample Input
  
a ahat hat hatword hziee word

Sample Output
  
ahat hatword


1.将所有单词创建字典树

2.将每个单词拆分成两个,(如单词 ahat 依次拆分成 a,hat ;  ah,at;   aha,t; )依次判断拆分的两个单词是否存在与字典树




#define N 50005
#include<stdio.h>
#include<string.h>
#include<stdlib.h>typedef struct Tire
{Tire * child[26];bool flag;
}Tire;Tire * root;
void insert(char * s)//创建字典树
{Tire *p,*q=root;for(int i=0;i<strlen(s);i++)	{if(q->child[s[i]-'a']) q = q->child[s[i]-'a'];else{p = (Tire *)malloc(sizeof(Tire));p->flag=0;for(int j=0;j<26;j++) p->child[j]=NULL;q->child[s[i]-'a'] = p;q = p;}}q->flag = 1;//标志为1的代表这里是某个单词的结尾
}
bool find(char *s)
{Tire * q=root;for(int i=0;i<strlen(s);i++){	if(q->child[s[i]-'a']) q = q->child[s[i]-'a'];else	return false;}if(q->flag==1) return true;//在字典树中找到该单词else return false;
}
int main()
{char s[N][20],s1[20],s2[20];root = (Tire *)malloc(sizeof(Tire));for(int i=0;i<26;i++) root->child[i]=NULL;int k=0;while(scanf("%s",s[k])!=EOF )insert(s[k++]);for(int i=0;i<k;i++){for(int j=1;j<strlen(s[i]);j++){for(int m=0;m<j;m++) s1[m]=s[i][m]; //将每个单词拆分成两个s1[j] = '\0';sscanf(s[i]+j,"%s",s2);if(find(s1)&&find(s2)) { //拆分的两个单词都存在与字典树puts(s[i]);	break;}}}return 0;
}



别人的STL 简单代码,没用过,不懂!!!先贴着,学过STL 以后看,这个效率不高。。

#include <iostream>
#include <string>
#include <map>
using namespace std;
map <string, int> m_v;
string str[50006];
int main() {int k(-1);while(cin >> str[++k]) {m_v[str[k]] = 1;}for(int i = 0; i <= k; i++) {int e = str[i].size()-1;for(int j = 1; j < e; j++) {string s1(str[i], 0, j);string s2(str[i], j);if(m_v[s1] == 1 && m_v[s2] == 1) {cout << str[i] << endl;break;}}}return 0;
}




这篇关于hdu 题目1247 Hat’s Words(字典树)的文章就介绍到这儿,希望我们推荐的文章对编程师们有所帮助!



http://www.chinasem.cn/article/1027942

相关文章

usaco 1.3 Mixing Milk (结构体排序 qsort) and hdu 2020(sort)

到了这题学会了结构体排序 于是回去修改了 1.2 milking cows 的算法~ 结构体排序核心: 1.结构体定义 struct Milk{int price;int milks;}milk[5000]; 2.自定义的比较函数,若返回值为正,qsort 函数判定a>b ;为负,a<b;为0,a==b; int milkcmp(const void *va,c

poj 3974 and hdu 3068 最长回文串的O(n)解法(Manacher算法)

求一段字符串中的最长回文串。 因为数据量比较大,用原来的O(n^2)会爆。 小白上的O(n^2)解法代码:TLE啦~ #include<stdio.h>#include<string.h>const int Maxn = 1000000;char s[Maxn];int main(){char e[] = {"END"};while(scanf("%s", s) != EO

hdu 2093 考试排名(sscanf)

模拟题。 直接从教程里拉解析。 因为表格里的数据格式不统一。有时候有"()",有时候又没有。而它也不会给我们提示。 这种情况下,就只能它它们统一看作字符串来处理了。现在就请出我们的主角sscanf()! sscanf 语法: #include int sscanf( const char *buffer, const char *format, ... ); 函数sscanf()和

hdu 2602 and poj 3624(01背包)

01背包的模板题。 hdu2602代码: #include<stdio.h>#include<string.h>const int MaxN = 1001;int max(int a, int b){return a > b ? a : b;}int w[MaxN];int v[MaxN];int dp[MaxN];int main(){int T;int N, V;s

hdu 1754 I Hate It(线段树,单点更新,区间最值)

题意是求一个线段中的最大数。 线段树的模板题,试用了一下交大的模板。效率有点略低。 代码: #include <stdio.h>#include <string.h>#define TREE_SIZE (1 << (20))//const int TREE_SIZE = 200000 + 10;int max(int a, int b){return a > b ? a :

hdu 1166 敌兵布阵(树状数组 or 线段树)

题意是求一个线段的和,在线段上可以进行加减的修改。 树状数组的模板题。 代码: #include <stdio.h>#include <string.h>const int maxn = 50000 + 1;int c[maxn];int n;int lowbit(int x){return x & -x;}void add(int x, int num){while

hdu 3790 (单源最短路dijkstra)

题意: 每条边都有长度d 和花费p,给你起点s 终点t,要求输出起点到终点的最短距离及其花费,如果最短距离有多条路线,则输出花费最少的。 解析: 考察对dijkstra的理解。 代码: #include <iostream>#include <cstdio>#include <cstdlib>#include <algorithm>#include <cstrin

hdu 2489 (dfs枚举 + prim)

题意: 对于一棵顶点和边都有权值的树,使用下面的等式来计算Ratio 给定一个n 个顶点的完全图及它所有顶点和边的权值,找到一个该图含有m 个顶点的子图,并且让这个子图的Ratio 值在所有m 个顶点的树中最小。 解析: 因为数据量不大,先用dfs枚举搭配出m个子节点,算出点和,然后套个prim算出边和,每次比较大小即可。 dfs没有写好,A的老泪纵横。 错在把index在d

hdu 1102 uva 10397(最小生成树prim)

hdu 1102: 题意: 给一个邻接矩阵,给一些村庄间已经修的路,问最小生成树。 解析: 把已经修的路的权值改为0,套个prim()。 注意prim 最外层循坏为n-1。 代码: #include <iostream>#include <cstdio>#include <cstdlib>#include <algorithm>#include <cstri

hdu 1285(拓扑排序)

题意: 给各个队间的胜负关系,让排名次,名词相同按从小到大排。 解析: 拓扑排序是应用于有向无回路图(Direct Acyclic Graph,简称DAG)上的一种排序方式,对一个有向无回路图进行拓扑排序后,所有的顶点形成一个序列,对所有边(u,v),满足u 在v 的前面。该序列说明了顶点表示的事件或状态发生的整体顺序。比较经典的是在工程活动上,某些工程完成后,另一些工程才能继续,此时