本文主要是介绍FatMouse' Trade(sourtqsourt),希望对大家解决编程问题提供一定的参考价值,需要的开发者们随着小编来一起学习吧!
FatMouse' Trade
Time Limit : 2000/1000ms (Java/Other) Memory Limit : 65536/32768K (Java/Other)
Total Submission(s) : 15 Accepted Submission(s) : 10
Font: Times New Roman | Verdana | Georgia
Font Size: ← →
Problem Description
The warehouse has N rooms. The i-th room contains J[i] pounds of JavaBeans and requires F[i] pounds of cat food. FatMouse does not have to trade for all the JavaBeans in the room, instead, he may get J[i]* a% pounds of JavaBeans if he pays F[i]* a% pounds of cat food. Here a is a real number. Now he is assigning this homework to you: tell him the maximum amount of JavaBeans he can obtain.
Input
Output
Sample Input
5 3 7 2 4 3 5 2 20 3 25 18 24 15 15 10 -1 -1
Sample Output
13.333 31.500
Author
#include <cstdio>
#include <algorithm>
using namespace std;
struct node
{
int be;
int cat;
double bl;
}t[100000]; //数组应大点
bool cmp(const node &a,const node &b) //取地址很重要
{
if(a.bl>b.bl)
return true;
return false;
}
int main()
{
int n,m,i;
double sum;
while(~scanf("%d%d",&n,&m))
{
if(n==-1||m==-1) break;
for(i=0;i<m;i++)
{
scanf("%d%d",&t[i].be,&t[i].cat);
t[i].bl=(double)t[i].be/t[i].cat;
}
sum=0;
sort(t,t+m,cmp);
for(i=0;i<m;i++)
{
if(n-t[i].cat>0)
{
sum+=t[i].be;
n-=t[i].cat;
}
else
{
sum+=n*t[i].bl;
break;
}
}
printf("%.3f\n",sum);
}
return 0;
}
或者:
#include <cstdio>
#include <algorithm>
using namespace std;
struct node
{
int be;
int cat;
double bl;
}t[100000];
bool cmp(const node &a,const node &b)
{
if(a.bl>b.bl)
return true;
return false;
}
int main()
{
int n,m,i;
double sum;
while(~scanf("%d%d",&n,&m))
{
if(n==-1||m==-1) break;
for(i=0;i<m;i++)
{
scanf("%d%d",&t[i].be,&t[i].cat);
t[i].bl=(double)t[i].be/t[i].cat;
}
sum=0;
sort(t,t+m,cmp);
for(i=0;i<m;i++)
{
if(n>0&&n>=t[i].cat)
{
n-=t[i].cat;
sum+=t[i].be;
continue;
}
if(n>0&&n<t[i].cat)
{
sum+=n*t[i].bl;
break;
}
}
printf("%.3f\n",sum);
}
return 0;
}
说明:
bool cmp(const node &a,const node &b)
运算符重载的条件是,必须存在至少一个自定义的类型。 而指针实际上就是地址,即一个32位的整数值,它们的大小是直接进行数值的比较的 如果想比较2个指针所指的对象的大小,可以对它们取 * 操作,再调用 operator < 即可。 另外,楼主写的 operator < 重载,参数应设定为 const node &, 即 bool operator < (const node &a, const node &b) { ... } 按LZ的方式去写的话,每次调用 < 运算符时都会存在对象的拷贝。 再者,结构体里面的成员,在默认情况下均是 public 的权限,不需要将 bool operator < 设置为结构体的友员函数,可以直接通过对象访问成员变量。
比较:#include<stdio.h> #include<stdlib.h> #include<algorithm> using namespace std; const int MAXN = 1010; struct node { double j,f; double r; }a[MAXN]; /* int cmp(const void *a,const void *b)//从大到小排序 { struct node *c=(node *)a; struct node *d=(node *)b; if(c->r > d->r) return -1; else return 1; } */ bool cmp(node a,node b) { return a.r > b.r; } int main() { int N; double M; double ans; while(scanf("%lf%d",&M,&N)) { if(M==-1&&N==-1) break; for(int i=0;i<N;i++) { scanf("%lf%lf",&a[i].j,&a[i].f); a[i].r=(double)a[i].j/a[i].f; } //qsort(a,N,sizeof(a[0]),cmp); sort(a,a+N,cmp); ans=0; for(int i=0;i<N;i++) { if(M>=a[i].f) { ans+=a[i].j; M-=a[i].f; } else { ans+=(a[i].j/a[i].f)*M; break; } } printf("%.3lf\n",ans); } return 0; }
这篇关于FatMouse' Trade(sourtqsourt)的文章就介绍到这儿,希望我们推荐的文章对编程师们有所帮助!